ispCP - Board - Support
[solved] New domains don't work - Printable Version

+- ispCP - Board - Support (
+-- Forum: ispCP Omega Support Area (/forum-30.html)
+--- Forum: Usage (/forum-34.html)
+--- Thread: [solved] New domains don't work (/thread-16474.html)

[solved] New domains don't work - cwigham - 01-22-2013 07:32 PM

Strange problem I'm experiencing...within the last month or two whenever I add a new domain it doesn't work, what happens is after adding a domain I browse to the URL and it takes me to the ispcp control panel login page. I have checked that the folders and users are created when the domain is added so not sure what's going.

I'm not getting any errors regarding domains in the debugger either which leaves me baffled.

Using ispCP version 1.0.7 OMEGA
build: 20101124

Appreciate any help, thanks!

RE: New domains don't work - joximu - 01-22-2013 10:47 PM

You get the login form of ispcp -> DNS is ok.

Next step: check apache:

apache2ctl -S

Seems that the config is not updated.

One thought: did you ever replace the ispcp.conf file (/etc/apache2/sites-enabled/ispcp.conf)? This should be a symlink to /etc/apache2/sites-available/ispcp.conf... if it's not a symlnk then the configuration won't be updated...


RE: New domains don't work - cwigham - 01-22-2013 11:18 PM

jackpot! checked both files and they were different so added the symlink and it's working as it should be.