ispCP - Board - Support
[SOLVED] Helo command rejected: need fully-qualified hostname; - Printable Version

+- ispCP - Board - Support (
+-- Forum: ispCP Omega Support Area (/forum-30.html)
+--- Forum: Usage (/forum-34.html)
+--- Thread: [SOLVED] Helo command rejected: need fully-qualified hostname; (/thread-2726.html)

[SOLVED] Helo command rejected: need fully-qualified hostname; - NetworkExpertise - 03-14-2008 05:08 AM

Debian Etch -
Fresh Installation of ispCP

Every domain user when sending I see this error message in the log and their email gets rejected. I searched the forums for this error and found some responses in German, but I cannot read German. SMTP Outbound Auth is turned on in users Outlook 2003/2007. Here is my postfix -n:

netxweb01:/var/log# postconf -n
alias_database = hash:/etc/aliases
append_at_myorigin = yes
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
content_filter = amavis:[]:10024
daemon_directory = /usr/lib/postfix
inet_interfaces = all
local_destination_recipient_limit = 1
local_recipient_maps = unix:passwd.byname $alias_database
local_transport = local
mail_spool_directory = /var/mail
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
mydestination = $myhostname, $mydomain
mydomain =
myhostname = netxweb01
mynetworks =,,,,
mynetworks_style = host
myorigin = $mydomain
setgid_group = postdrop
smtpd_banner = $myhostname ESMTP ispCP 1.0 Priamos Managed 1.0.0 RC3 OMEGA
smtpd_data_restrictions = reject_multi_recipient_bounce, reject_unauth_pipelining
smtpd_helo_required = yes
smtpd_helo_restrictions = permit_mynetworks, permit_sasl_authenticated,
smtpd_recipient_restrictions = reject_non_fqdn_recipient, reject_unknown_recipient_domain, permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, reject_unlisted_recipient, check_policy_service inet:, check_policy_service inet:, permit
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous, noplaintext
smtpd_sender_restrictions = reject_non_fqdn_sender, reject_unknown_sender_domain, permit_mynetworks, permit_sasl_authenticated
transport_maps = hash:/etc/postfix/ispcp/transport
virtual_alias_maps = hash:/etc/postfix/ispcp/aliases
virtual_gid_maps = static:8
virtual_mailbox_base = /var/mail/virtual
virtual_mailbox_domains = hash:/etc/postfix/ispcp/domains
virtual_mailbox_limit = 0
virtual_mailbox_maps = hash:/etc/postfix/ispcp/mailboxes
virtual_minimum_uid = 1001
virtual_transport = virtual
virtual_uid_maps = static:1001

This worked just fine when it was VHCS2. I decided to build a new box and switch over to ispCP and now I have SMTP send issues. Let me know what will fix this problem. Its a fresh load!

RE: Helo command rejected: need fully-qualified hostname; - joximu - 03-14-2008 07:27 AM

try this

instead of
smtpd_sasl_security_options = noanonymous, noplaintext

smtpd_sasl_security_options = noanonymous

This is the "outook hack"...


RE: Helo command rejected: need fully-qualified hostname; - NetworkExpertise - 03-14-2008 07:52 AM

This did fix it as long as you set Outlook (all versions) to do SMTP Authentication and set "Use same settings as my incoming mail server"

Thanks Joximu. I would recommend to the package maintainers for ispCP to take this off on a default install as most US Hosting customers use Outlook products.

RE: [SOLVED] Helo command rejected: need fully-qualified hostname; - vlastimir.georgiev - 10-04-2009 12:56 AM

Outlook users must set following in Tools -> Account Settings -> ispCP_mail_account -> More settings (Advanced) :

1. Check - My outgoing server (SMTP) requires authentication
2. Choose - Use same settings as my incoming mail server

This working fine with all version of MS Outlook and the settings for Outlook Express is the same.