ispCP - Board - Support
problems with migration - Printable Version

+- ispCP - Board - Support (
+-- Forum: ispCP Omega Support Area (/forum-30.html)
+--- Forum: Migration (/forum-35.html)
+--- Thread: problems with migration (/thread-4079.html)

problems with migration - phboos - 08-21-2008 12:25 AM


i encountered some problems while trying to migrate from an old vhcs2 installation to a new setup server from ispcp

The New Server works fine, new Domains already runs on it, but when i try to restore an old backup from vhcs, all php scripts brings up an

Quote:No input file specified.

i already went thru the search function and read many threads here and on google.

Here is my actual situtation:

- Used the Backup tar.gz from vhcs2, scp it to ispcp, change from tar.gz to tar.bz2 and reinstalled it with the backup restore in the panel
- checked the file and directory permissions
- tryed to access the main page... error see above

i tryed to change the owner of the files to the vu2xxx with group www-data or vu2xxx, changed to nobody:nogroup, always getting the above error.

another site running on the same machine had no problems with php.

i went threw the php.ini file in the /var/www/fcgi/domain/php5/php.ini and changed the cgi.force_rewrite option to 1 and 0, no effect (restarting apache2ctl, doing a ispcp-rqst-mgr)

i moved made a new file in the directory with just a echo hello world, same failure. this new file works fine in the other directory on the server.

both domains uses the same hosting plan....

can anybody help me, wich option this could be....

thx a lot


RE: problems with migration - BeNe - 08-21-2008 01:11 AM

From which VHCS2 Version to want to which ispCP Version ?

If there are not too many Domains to migrate - i would do it manually.
Create the Domain in ispCP and extract the htdocs. Change the User and Permissions to the new vu20XX User.Create the DB with the same username and password - import the DB.

Greez BeNe

RE: problems with migration - pgentoo - 08-22-2008 10:38 AM

"No input file specified" error from cgi's is often caused when using suexec, and having incorrect permissions on the .php files.

Make sure these are chown/chgrp'd to to the right user.