ispCP - Board - Support
[SOLVED] Pure-FTPD - Printable Version

+- ispCP - Board - Support (
+-- Forum: ispCP Omega Support Area (/forum-30.html)
+--- Forum: Usage (/forum-34.html)
+--- Thread: [SOLVED] Pure-FTPD (/thread-5566.html)

Pages: 1 2

RE: Pure-FTPD - rbtux - 02-02-2009 08:29 PM

Nope won't do... I know where this leads ;-)

just do
/etc/init.d/pure-ftpd stop
/usr/sbin/pure-ftpd -d -d or /usr/sbin/pure-ftpd -dd (i don't remember right now)

And then do a connection from the client. So you will see the logs in the console that the above command opened...

RE: Pure-FTPD - tsyoker - 02-02-2009 08:30 PM

Debian-40-etch-32-minimal:~# /etc/init.d/pure-ftpd stop
Stopping ftp server: pure-ftpd

that command won't kill the proccess

Debian-40-etch-32-minimal:~# /usr/sbin/pure-ftpd -d -d or /usr/sbin/pure-ftpd -d
Unable to start a standalone server: Address already in use

RE: Pure-FTPD - rbtux - 02-02-2009 08:34 PM

lsof -i | grep ftp

there is something listening maybe proftpd/inetd

RE: Pure-FTPD - tsyoker - 02-02-2009 08:47 PM

well thank you it is works now but i can't log in because 530 Login authentication failed
im create new user in ISPCP but it doesn't works.

RE: Pure-FTPD - rbtux - 02-02-2009 09:22 PM

check database...
check that you have the right username (user@domain.tld)
check that you have the right password
try to execute the sql queries from the pure-ftpd config with the specified user in config...

When you go away from default environment you must be prepared to debug such stuff...

RE: Pure-FTPD - ceco91 - 02-03-2009 04:04 AM

Pure FTPd Write its log in syslog. Could you post last lines of your log ?

RE: Pure-FTPD - tsyoker - 02-08-2009 07:27 AM

This is topic you can close too because PROFTPD works is fine for me, just first install was bad. Linux skill is bad.