Current time: 01-29-2022, 10:28 PM Hello There, Guest! (LoginRegister)


Post Reply 
subversion server problems
Author Message
untitled1 Offline


Posts: 3
Joined: Aug 2010
Reputation: 0
Post: #1
subversion server problems
Hello community,

unfortunately I am not able to get run subversion server (debian) on my ispcp (1.0.3) installation.

I did install libapache2-svn and subversion packages, created the svn directory in /var/www/svn (first I did it in /var/local/svn but later changed is, as I thought this could solve the problem). I set the owner of the folder with subfolders to www-data:www-data.

I tried to add the following to the /etc/apache2/mods-enabled/dav_svn.conf (I also created the pass entries in dav_svn.passwd):

Code:
<Location /svn>
       DAV svn
       SVNPath /var/www/svn
       AuthType Basic
       AuthName "Subversion repository"
       AuthUserFile /etc/apache2/dav_svn.passwd
       Require valid-user
     </Location>

After that I got the message with th login request when calling mydomain.com/svn but after that: 403 error.

Then I also tried to add the above code to /etc/apache2/ispcp/subdomain.mydomain.com.conf after creating the subdomain. But still the same result: 403.

Can someone please help me with this annoying issue, as it was very easy to setup subversion without ispcp and now I have no idea where o begin to search.

Thank you very much!
un1
08-08-2010 08:00 AM
Find all posts by this user Quote this message in a reply
kilburn Offline
Development Team
*****
Dev Team

Posts: 2,182
Joined: Feb 2007
Reputation: 34
Post: #2
RE: subversion server problems
1. Are you sure that www-data can read /etc/apache2/dav_svn.passwd?
2. You're getting a 403 Forbidden error, so go check the logs and you should get more info about what's going wrong.
08-08-2010 06:39 PM
Visit this user's website Find all posts by this user Quote this message in a reply
untitled1 Offline


Posts: 3
Joined: Aug 2010
Reputation: 0
Post: #3
RE: subversion server problems
(08-08-2010 06:39 PM)kilburn Wrote:  1. Are you sure that www-data can read /etc/apache2/dav_svn.passwd?
2. You're getting a 403 Forbidden error, so go check the logs and you should get more info about what's going wrong.

Hi and thanks for you quick reply.


1. it has the right rights, so www-data should be able to read:
Code:
-rw-r--r-- 1 root root    17 2010-08-05 20:31 dav_svn.passwd


2.
/var/log/apache2/users/domain.com-access.log:
Code:
8x.xxx.xxx.xxx - - [08/Aug/2010:11:08:33 +0200] "GET /svn/ HTTP/1.1" 403 461 "-" "Opera/9.80 (X11; Linux x86_64; U; de) Presto/2.6.31 Version/10.70"

/var/log/apache2/users/domain.com-error.log:
Code:
[Sun Aug 08 11:08:33 2010] [error] [client 8x.xxx.xxx.xxx ] (13)Permission denied: cannot read directory for multi: /var/www/virtual/domain.com/htdocs/

So why is it trying to read this directory, or do I have to change something more?

Thank you in advance!
un1
08-08-2010 07:12 PM
Find all posts by this user Quote this message in a reply
kilburn Offline
Development Team
*****
Dev Team

Posts: 2,182
Joined: Feb 2007
Reputation: 34
Post: #4
RE: subversion server problems
1. /var/www/virtual/domain.tld/htdocs should be readable independently of the svn setup. In fact, the panel creates it as readable by the www-data user, so what did you change there?

2. This specific error is thrown by the multiviews module, so you can try disabling it (Options -MultiViews).
08-09-2010 03:45 AM
Visit this user's website Find all posts by this user Quote this message in a reply
untitled1 Offline


Posts: 3
Joined: Aug 2010
Reputation: 0
Post: #5
RE: subversion server problems
The "Options MultiViews" was the problem, I deleted it manually in the ispcp.conf file but it seems to be not permanently, where can I turn off MultiViews permanently?
08-10-2010 08:07 PM
Find all posts by this user Quote this message in a reply
kilburn Offline
Development Team
*****
Dev Team

Posts: 2,182
Joined: Feb 2007
Reputation: 34
Post: #6
RE: subversion server problems
You can either:

- Change it in both /etc/apache2/sites-enabled/ispcp.conf *and* /etc/ispcp/apache2/working/ispcp.conf

or

- Override this setting (I would put the whole svn-related stuff here) in /etc/apache2/ispcp/domain.tld.conf
08-10-2010 11:45 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)