Current time: 07-03-2022, 05:54 AM Hello There, Guest! (LoginRegister)


Post Reply 
Upgrade from 1.0.6 to 1.0.7 fails (now with new errors)
Author Message
Paddy0174 Offline


Posts: 4
Joined: Jan 2011
Reputation: 0
Post: #1
Upgrade from 1.0.6 to 1.0.7 fails (now with new errors)
EDIT: Updated the last post, to give a better inside on the things I've done....

click here to get there

------------

Hello!

I've a problem with upgrading from version 1.0.6 to 1.0.7.

log shows the following:
Code:
[ERROR]: Error: Unable to establish connection to the database! SQL returned: SQLSTATE[28000] [1045] Access denied for user 'root'@'localhost' (using password: YES)

Anybody an idea, what could cause this? I tried with no password or other passwords in the ispcp.old.conf file, to overwrite the actual one, nothing seemed to help?

Any ideas would be very welcome, as the server is not reachable at the moment....and I don't want to hear any annoying things from my boss tomorrow morning.... Sad

Thanks a lot for your help!
(This post was last modified: 01-27-2011 01:06 AM by Paddy0174.)
01-26-2011 05:08 AM
Find all posts by this user Quote this message in a reply
woro Offline
Newbie
*

Posts: 6
Joined: Jan 2011
Reputation: 0
Post: #2
RE: Upgrade from 1.0.6 to 1.0.7 fails with SQL password error
(01-26-2011 05:08 AM)Paddy0174 Wrote:  Hello!

I've a problem with upgrading from version 1.0.6 to 1.0.7.

log shows the following:
Code:
[ERROR]: Error: Unable to establish connection to the database! SQL returned: SQLSTATE[28000] [1045] Access denied for user 'root'@'localhost' (using password: YES)

Anybody an idea, what could cause this? I tried with no password or other passwords in the ispcp.old.conf file, to overwrite the actual one, nothing seemed to help?

Sorry, cannot help but just a few minutes ago I ran into the same issue and have no idea how to fix it :-(

Edit: Just found this post http://isp-control.net/forum/thread-1266...l#pid93783
but no answer there.
I found some hints somewhere. No idea what the real reason is but my solution was to
- wipe out the DATABASE_PASSWORD from ispcp.conf
- use ispcp_db_passwd to set the old password again
- copy the new value from ispcp.conf to ispcp.old.conf

Afterwards the upgrade worked.
(This post was last modified: 01-26-2011 06:32 AM by woro.)
01-26-2011 06:05 AM
Find all posts by this user Quote this message in a reply
Paddy0174 Offline


Posts: 4
Joined: Jan 2011
Reputation: 0
Post: #3
RE: Upgrade from 1.0.6 to 1.0.7 fails with SQL password error
Thanks a lot for your help, but I tried your way four times. It didn't work! Sad

But thank you very much for your help!

Was it for you the same, that the entered password in ispcp-db-passwd is a totally different value, then the one that is written in the ispcp.conf file afterwards???
01-26-2011 07:13 AM
Find all posts by this user Quote this message in a reply
Paddy0174 Offline


Posts: 4
Joined: Jan 2011
Reputation: 0
Post: #4
RE: Upgrade from 1.0.6 to 1.0.7 fails with SQL password error
OK, two steps more...

Thanks woro, helped after the next try (maybe some mistyping...).

No I had the PORT_POSTGREY error, solved that by typing

PORT_POSTGREY = 60000 in ispcp.conf

Next error just right ahead:

Unable to found your resolv.conf

WTH is going with this update? I've made a few in the last months from any previous version, but this one gets me.

Anybody any ideas? What is wrong wih this one???
01-26-2011 10:51 AM
Find all posts by this user Quote this message in a reply
Paddy0174 Offline


Posts: 4
Joined: Jan 2011
Reputation: 0
Post: #5
RE: Upgrade from 1.0.6 to 1.0.7 fails (now with new errors)
OK, so I hope, somebody can jum in here and help a little further. I try to write down, what I've done to come further step by step.

Any help is really appreciated! Smile

From the beginning:
Started to update the installation according to the readme in package / the manual in the documentation:
  • 1 to 9 went smoothly (no wonder)
  • starting the ispcp-update script
  • failed with "access denied for sql user root" => erased the old password from ispcp.conf and set a new one with ispcp-dp-passwd => worked
  • next run => failed with "PORT_POSTGREY" not available => set "PORT_POSTGREY = 60000" in ispcp.conf => worked
  • next run => failed with "Couldn't find resolv.conf => set RESOLV_CONF_FILE = /etc/resolv.conf" in ispcp.conf => worked
    Rebuilding all services configuration files so did come to an end and worked
  • next run => failed with no specific error, log says "[ERROR] Unknown user 'v2000' !"
    This is the part Rebuilding all GUI configuration files,
    "ispCP GUI Bind9 configuration: [DONE]
    ispCP GUI fastCGI/PHP configuration: [FAILED]

All ideas are welcome, I'm stuck with this, and the machine is still off. My boss is going to kill me (maybe he already hired someone that is waiting for me outside....), so please, all ideas, crazy or not, are very welcome!

Thanks a lot!
01-27-2011 01:04 AM
Find all posts by this user Quote this message in a reply
viperiii Offline
Junior Member
*

Posts: 65
Joined: Feb 2008
Reputation: 0
Post: #6
RE: Upgrade from 1.0.6 to 1.0.7 fails (now with new errors)
Yup... Pretty Bad huh?!?

I've tried the upgrade on my system 3-4 times with no luck... had to restore from backups to get it back online... and mine isn't major.. just dev and a few live sites...

Restore from backup and try again...

There are a few experts that know how to fix it and will make it work... They need to post a warning that the 1.0.7 Update should NOT be Considered if you don't have Expert Knowledge of Linux.... Us Novice guys got hammered with this update...

I've gone through the last 5/6 with no issues until this one...
01-29-2011 11:09 AM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)