Current time: 12-01-2021, 01:36 AM Hello There, Guest! (LoginRegister)


Post Reply 
[SOLVED] Autoresponder problem
Author Message
comTim Offline


Posts: 3
Joined: Mar 2011
Reputation: 0
Post: #1
[SOLVED] Autoresponder problem
Hi,

after hours searching Google and this site, i have to ask...

My auto responder seems not to work correct. I upgraded my installation today (i don't know, if its worked before). I got a mail back from the responder once, but after that nothing else.

I have the last stable release installed on a Debian Lenny system.

Quote:Mar 28 20:19:53 hosting postfix/smtpd[28769]: connect from mo-p00-ob.rzone.de[81.169.146.162]
Mar 28 20:19:53 hosting postfix/policyd-weight[25348]: decided action=PREPEND X-policyd-weight: using cached result; rate: -8.5; <client=81.169.146.162> <helo=mo-p00-ob.rzone.de> <from=tim@aaaaaa.de> <to=tim@bbbbbb.de>; delay: 0s
Mar 28 20:19:53 hosting postgrey[2274]: action=pass, reason=client AWL, client_name=mo-p00-ob.rzone.de, client_address=81.169.146.162, sender=Tim@aaaaaa.de, recipient=tim@bbbbbb.de
Mar 28 20:19:53 hosting postfix/smtpd[28769]: 9B5FE3C0F1: client=mo-p00-ob.rzone.de[81.169.146.162]
Mar 28 20:19:53 hosting postfix/cleanup[28807]: 9B5FE3C0F1: message-id=<4D90D110.6020409@aaaaaa.de>
Mar 28 20:19:53 hosting postfix/qmgr[25547]: 9B5FE3C0F1: from=<Tim@aaaaaa.de>, size=1452, nrcpt=2 (queue active)
Mar 28 20:19:53 hosting postfix/virtual[28808]: 9B5FE3C0F1: to=<tim@bbbbbb.de>, relay=virtual, delay=0.39, delays=0.37/0.01/0/0.01, dsn=2.0.0, status=sent (delivered to maildir)
Mar 28 20:19:53 hosting postfix/smtpd[28769]: disconnect from mo-p00-ob.rzone.de[81.169.146.162]
Mar 28 20:19:53 hosting postfix/pipe[28809]: 9B5FE3C0F1: to=<tim@ispcp-arpl.bbbbbb.de>, orig_to=<tim@bbbbbb.de>, relay=ispcp-arpl, delay=0.6, delays=0.37/0.02/0/0.21, dsn=2.0.0, status=sent (delivered via ispcp-arpl service)
Mar 28 20:19:53 hosting postfix/qmgr[25547]: 9B5FE3C0F1: removed
(This post was last modified: 03-29-2011 08:17 PM by comTim.)
03-29-2011 04:36 AM
Find all posts by this user Quote this message in a reply
kilburn Offline
Development Team
*****
Dev Team

Posts: 2,182
Joined: Feb 2007
Reputation: 34
Post: #2
RE: Autoresponder problem
Have you taken into account that the autoresponder will *not* reply to the same e-mail twice within 24 hours? This is built in to avoid "autoreply wars", where two addresses with autoreplys start e-mailing back and forward in a loop.
03-29-2011 01:44 PM
Visit this user's website Find all posts by this user Quote this message in a reply
comTim Offline


Posts: 3
Joined: Mar 2011
Reputation: 0
Post: #3
RE: Autoresponder problem
ahh! Thanks for that! I tried multiple times in a few minutes..

Do you know, where i can change the limit? Maybe to a few minutes or an hour..
03-29-2011 05:15 PM
Find all posts by this user Quote this message in a reply
comTim Offline


Posts: 3
Joined: Mar 2011
Reputation: 0
Post: #4
RE: Autoresponder problem
ok, i have the answer...

in /var/www/ispcp/engine/messenger/ispcp-arpl-msgr

the mysql-query:

Quote:# Detect duplicates within 24h to avoid autoreplying loops
$sql = "
SELECT
`time`
FROM
`autoreplies_log` AS `al`
WHERE
`al`.`from` = " . $main:: db->quote($mail_to) . "
AND
`al`.`to` = " . $main:: db->quote($head->get('From')) . "
AND
ADDTIME(al.`time`, '24:00:00') > NOW()
;
";

thanks again Wink
(This post was last modified: 03-29-2011 08:17 PM by comTim.)
03-29-2011 08:15 PM
Find all posts by this user Quote this message in a reply
kilburn Offline
Development Team
*****
Dev Team

Posts: 2,182
Joined: Feb 2007
Reputation: 34
Post: #5
RE: [SOLVED] Autoresponder problem
You're welcome. It's actually quite nice to find someone who can inspect the code and solve its own problems with only minor guidance, so thanks for that! Smile
03-30-2011 12:07 PM
Visit this user's website Find all posts by this user Quote this message in a reply
deepaku504 Offline


Posts: 1
Joined: Jun 2011
Reputation: 0
Post: #6
RE: Autoresponder problem
Hey I have an autoresponder problem ,
I wanna make arrangements such as when the viewer signs up , he is directly taken to another page and not in the email
06-18-2011 03:41 PM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)