Current time: 08-15-2022, 07:33 AM Hello There, Guest! (LoginRegister)


Post Reply 
Upgrade from 1.06 to 1.07 Error
Author Message
nikolas22t Offline
Junior Member
*

Posts: 16
Joined: Nov 2009
Reputation: 0
Post: #1
Upgrade from 1.06 to 1.07 Error
I followed the steps on documentation and i get error


Code:
Can't locate feature.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at ispcp-update line 40.
BEGIN failed--compilation aborted at ispcp-update line 40.


I am on ubuntu 32bits
(This post was last modified: 12-08-2010 10:56 PM by nikolas22t.)
12-08-2010 10:56 PM
Find all posts by this user Quote this message in a reply
ShadowJumper Offline
Member
***

Posts: 287
Joined: Sep 2008
Reputation: 2
Post: #2
RE: Upgrade from 1.06 to 1.07 Error
Hi,

your version of perl is to old. You need perl 5.10.x to use ispCP 1.0.7 or never.
12-08-2010 11:21 PM
Find all posts by this user Quote this message in a reply
nikolas22t Offline
Junior Member
*

Posts: 16
Joined: Nov 2009
Reputation: 0
Post: #3
RE: Upgrade from 1.06 to 1.07 Error
i fixed that ... now the setup is giving error


Rebuilding all customers configuration files
* Please wait, this may take some time: [ Failed ]

[FATAL] An error occurred during update process!
Correct it and re-run this program.

Log files are stored in /var/log/ispcp/setup
You can also find help at http://isp-control.net/forum
12-09-2010 01:38 AM
Find all posts by this user Quote this message in a reply
RatS Offline
Project Leader
******

Posts: 1,854
Joined: Oct 2006
Reputation: 17
Post: #4
RE: Upgrade from 1.06 to 1.07 Error
have you checked for subdomain orphans? you can run

Code:
perl /var/www/ispcp/engine/ispcp-rqst-mngr

in Debug mode to check this. We are working on a patch.
12-09-2010 04:10 AM
Visit this user's website Find all posts by this user Quote this message in a reply
nikolas22t Offline
Junior Member
*

Posts: 16
Joined: Nov 2009
Reputation: 0
Post: #5
RE: Upgrade from 1.06 to 1.07 Error
i did but didn't help ... logs dosn't help also..
(This post was last modified: 12-09-2010 06:37 AM by nikolas22t.)
12-09-2010 04:41 AM
Find all posts by this user Quote this message in a reply
nikolas22t Offline
Junior Member
*

Posts: 16
Joined: Nov 2009
Reputation: 0
Post: #6
RE: Upgrade from 1.06 to 1.07 Error
very bad desition to upgrade ... a million errors ...


when i am trying to access ispcp admin page i get

[Image: lockedg.png]

any ideas?


Also customers ftp accounts not working...
(This post was last modified: 12-09-2010 07:19 AM by nikolas22t.)
12-09-2010 06:26 AM
Find all posts by this user Quote this message in a reply
tomdooley Offline
Development Team
*****
Dev Team

Posts: 332
Joined: Sep 2007
Reputation: 7
Post: #7
RE: Upgrade from 1.06 to 1.07 Error
if you get

Code:
[FATAL] An error occurred during update process!
Correct it and re-run this program.

during upgrade, nothing (!) is running. There are some errors fixed in current trunk now for upgrade process (i hope). I also had several errors upgrading my own servers. Please have a look at the log files after setting debug mode to 1. You should see what went wrong and you can perhaps correct some entries via console with mysql -u root (etc.).

I'm also very unpleased with the upgrade process of 1.0.7.
(This post was last modified: 12-09-2010 09:41 PM by BioALIEN.)
12-09-2010 08:10 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Nuxwin
Unregistered

 
Post: #8
RE: Upgrade from 1.06 to 1.07 Error
Why you have deleted my previous answer ? It's easy to do like this...

Also, it's easy to say that the fault come from former developer. It's your job to check trunk code state before release. You have release 1.0.7 directly instead of rc3. Who is responsible of this shit exactly ? Me ? I don't think so...
12-09-2010 09:07 AM
Quote this message in a reply
viperiii Offline
Junior Member
*

Posts: 65
Joined: Feb 2008
Reputation: 0
Post: #9
RE: Upgrade from 1.06 to 1.07 Error
several ops were blaming my server for issues...

while that was possibly true why was it running fine in 1.0.6 and only the upgrade completely fails...

1st issue is with fcgi mods enabled...
2nd the same issue as above with rqst-mgr or whatever... when updating customer files

beyond that the system works and runs great on 1.0.6 so holding until the upgrade path is working right..

(side note did find that my bind was really thrashed and wasn't starting at all..)

Bind9 Error Fixed -
#> named -d9 -g -c /etc/bind/named.conf
was used to find the problem - simply duplicate entry for administration site.

Still have plenty of other issues I'm sure...
12-18-2010 06:26 AM
Find all posts by this user Quote this message in a reply
tomdooley Offline
Development Team
*****
Dev Team

Posts: 332
Joined: Sep 2007
Reputation: 7
Post: #10
RE: Upgrade from 1.06 to 1.07 Error
(12-18-2010 06:26 AM)viperiii Wrote:  several ops were blaming my server for issues...

1st issue is with fcgi mods enabled...

Can you please be more concrete?

(12-18-2010 06:26 AM)viperiii Wrote:  2nd the same issue as above with rqst-mgr or whatever... when updating customer files

Should be solved in trunk, I hope we can release soon.

(12-18-2010 06:26 AM)viperiii Wrote:  Bind9 Error Fixed -
#> named -d9 -g -c /etc/bind/named.conf
was used to find the problem - simply duplicate entry for administration site.
Still have plenty of other issues I'm sure...

If you have, please provide us some more information to make the upgrade process more stable.
12-18-2010 06:21 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: