Current time: 07-03-2020, 04:23 AM Hello There, Guest! (LoginRegister)


Post Reply 
Update ispCP database schema ... FAILED
Author Message
rethus Offline
Junior Member
*

Posts: 202
Joined: May 2009
Reputation: 3
Post: #9
Question RE: Update ispCP database schema ... FAILED
(04-24-2010 05:07 AM)theGrimm Wrote:  Hey guys i got the same Problem , i double ckecked my mysqlroot password and it works with mysql-pxxxxx
i followed this tutorial to change the password again http://www.isp-control.net/documentation...ge_db_pass
but didn't help ...

in the db ky files there are the same passwords inside,nothing with default variables

what can i do ?

Same Problem here on 1.0.5
Have doing all "step by step" which are descriped here: http://isp-control.net/documentation/sta...ade:debian

And got:
Quote:ispCP database
Update ispCP database schema Failed

FATAL: An error was occured during update process!
Correct it and re-run this program.

Then i have tryed to login into mysql on server directly, which worked [mysql -uroot -p (than type my password)

After that i have delete the input of the VAR: "DATABASE_PASSWORD ="in /etc/ispcp/ispcp.conf

Then i have done a: /var/www/ispcp/engine/ispcp-db-passwd and enter my password which worked at mysql directly.

After that i look again into /etc/ispcp/ispcp.conf and see now a crypted password like: /J8OkbCjc1xAAdDqp3wcTg==

I close the file, and run
Code:
perl ispcp-update
in
Code:
/var/www/ispcp/engine/setup

Update abort with the error i've posted above.

NOW i look again into the file /etc/ispcp/ispcp.conf and i wonder, why DATABASE_PASSWORD = has no value.. such like before.

Can anybody help me to fix this problem?
####################
Have solve the problem and write it into the wiki (7.1 and 10.1)
http://isp-control.net/documentation/sta...ade:debian
(This post was last modified: 06-24-2010 02:55 AM by rethus.)
05-12-2010 03:01 AM
Find all posts by this user Quote this message in a reply
Post Reply 


Messages In This Thread
RE: Update ispCP database schema ... FAILED - rethus - 05-12-2010 03:01 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)