Current time: 08-15-2022, 08:29 AM Hello There, Guest! (LoginRegister)


Post Reply 
ispcp omega 1.0.6 After updating PHP5 I get this error
Author Message
al_paun Offline


Posts: 4
Joined: Mar 2010
Reputation: 0
Post: #1
ispcp omega 1.0.6 After updating PHP5 I get this error
php5-cgi: PHP Warning: Unknown: open_basedir restriction in effect. File(/var/www/ispcp/gui/index.php) is not within the allowed path(s): (/var/www/ispcp/gui/:/etc/ispcp/:/var/run/ispcp.lock:/proc/:/bin/df:/bin/mount:/var/log/rkhunter.log:/var/log/chkrootkit.log:/usr/share/php/) in Unknown on line 0

I've upgraded to 1.0.7 but still get this error.

Can anyone help please?
(This post was last modified: 01-13-2011 12:29 AM by al_paun.)
01-12-2011 11:29 PM
Find all posts by this user Quote this message in a reply
al_paun Offline


Posts: 4
Joined: Mar 2010
Reputation: 0
Post: #2
RE: ispcp omega 1.0.6 After updating PHP5 I get this error
I've found a workaround this ...
I've modified php.ini for every domain removing trailing slash

/var/www/ispcp/gui/ -> /var/www/ispcp/gui

then restarting apache then worked.

What is strange that ispcp comes with template with slash at the end but php 5.2.9 I have installed doesn't accept this slash.

Remove the slash also in /etc/ispcp/fcgi/php5/php.ini at open_basedir line for the future created domains.
01-13-2011 01:13 AM
Find all posts by this user Quote this message in a reply
motokochan Offline
Member
***

Posts: 274
Joined: Jul 2008
Reputation: 1
Post: #3
RE: ispcp omega 1.0.6 After updating PHP5 I get this error
I seem to recall there being a bug in PHP concerning paths with an ending slash, but I can't pull it up right now. The fix for that possibly caused the error.
01-13-2011 03:15 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)