Current time: 10-18-2021, 05:40 PM Hello There, Guest! (LoginRegister)


Post Reply 
Upgrade problem 1.0.5 to 1.0.7
Author Message
NIIcK Offline
Junior Member
*

Posts: 43
Joined: Jan 2010
Reputation: 0
Post: #1
Upgrade problem 1.0.5 to 1.0.7
Hello,

I have tried to upgrade from 1.0.5 to 1.0.7 on Ubuntu Karmic but the update script seems to have a problem connecting to MySQL database:

Code:
ispCP database
         * Update ispCP database schema:                             [ Failed ]

        [FATAL] An error occurred during update process!
        Correct it and re-run this program.

The error is:

Code:
[ERROR]: Error: Unable to establish connection to the database! SQL returned: SQLSTATE[28000] [1045] Access denied for user 'root'@'localhost' (using password: YES)

I have changed the password in /etc/ispcp/ispcp.conf using this tutorial:
http://isp-control.net/ispcp/wiki/howto_dbchangepw

I can connect to MySQL with the new password using the console commands however the upgrade script can't.

Please help.

Thank you,

Nick
02-20-2011 02:30 AM
Visit this user's website Find all posts by this user Quote this message in a reply
NIIcK Offline
Junior Member
*

Posts: 43
Joined: Jan 2010
Reputation: 0
Post: #2
RE: Upgrade problem 1.0.5 to 1.0.7
Seems that php5-common no longer installs mhash ... I have moved:

Code:
/etc/php5/conf.d/mhash.ini
to
/etc/php5/conf.d/mhash.ini.old
generated a new password, copied it over to
Code:
/etc/ispcp/ispcp.old.conf

and it seems to be working now ...
02-20-2011 05:48 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)