Current time: 12-15-2019, 09:51 AM Hello There, Guest! (LoginRegister)


Post Reply 
Migrating CentOS to Lenny 64bit
Author Message
ledoktre Offline
Newbie
*

Posts: 6
Joined: May 2009
Reputation: 0
Post: #1
Toungue Migrating CentOS to Lenny 64bit
Hey guys,

Its been a long day. I migrated ISPcP 1.0.0 (yeah, I know I need an upgrade- that comes after the migrations running!) yesterday, and boy was it challenging (new to Debian) trying to figure out the best way to get all the user accounts in place and allow for the differences in configuration paths, difference in UID/GIDs, etc.

I have two kind of strange lingering issues.

---------
Question 1
---------
I was just advised last night that users are not able to send mail. I have always required using SSL/TLS on the mail servers. Users can receive without issue, but sending fails on their password.

I managed to figure out there was no smtpd.conf under /usr/lib64/sasl2, and so I've copied that in. I still could not validate my account via authtest. I got to work this morning, and miraculously authtest works (is there some cronjob that updates the sasldb2 file?). I thought postfix would work again, but surprisingly- it does not (SASL LOGIN authentication failed: authentication failure)

Postfix folder and smtpd.conf file copied from old server.

----------
Question 2
----------
Someone called me this morning reporting that their FTP didn't work. Well, I had that setup and working yesterday right after I transferred the files, but what this user was using FTP over explicit SSL/TLS.

/etc/proftpd.conf was copied from old server and placed into /etc/proftpd (also copied). FTP over explicit SSL/TLS worked great before. Right now, user can use plain FTP, but fails when using any TLS.

----

I am going to keep hacking away and try and figure it out, but hopefully having this ticket going in the mean time might help out if I can't get it.

Thanks!

Update, for question 2 anyway. It seems mod_tls.c is not included in lenny deb files? Any suggestion on installing it without breaking down & compiling? ;-)
(This post was last modified: 06-09-2011 04:44 AM by ledoktre.)
06-09-2011 04:27 AM
Find all posts by this user Quote this message in a reply
anarking Offline
Junior Member
*

Posts: 29
Joined: Nov 2009
Reputation: 0
Post: #2
RE: Migrating CentOS to Lenny 64bit
this may not be an exact answer, but it may have something to do with the SSL/TLS keys that the system is using. if you copied over config files, it's referencing old keys, and your new lenny system made new ones, so if you check logs deeper, it's probably failing on that. you can either change config files or change/regenerate keys. probably best to change configs to reflect the new keys. google will get you more specifics as i'm not on lenny i don't want to give you wrong details from there. of course this was 10 days ago... hope you got it!
06-18-2011 06:21 PM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)