Current time: 09-25-2018, 05:55 AM Hello There, Guest! (LoginRegister)


Post Reply 
Safe? Debian 5 to Debian 6 Upgrade
Author Message
DarkSide Offline
Junior Member
*

Posts: 35
Joined: Jan 2008
Reputation: 0
Post: #1
Safe? Debian 5 to Debian 6 Upgrade
I cant seem to find the answer to this question anywhere so I will ask here Smile

Is it safe for me to perform an upgrade from Debian 5 to 6 without breaking ispCP? I am currently running 1.0.6 and want to upgrade Debian and then ispCP to the latest beta.

Your assistance is greatly appreciated Smile
08-13-2011 12:47 AM
Find all posts by this user Quote this message in a reply
joximu Offline
helper
*****
Moderators

Posts: 7,034
Joined: Jan 2007
Reputation: 92
Post: #2
RE: Safe? Debian 5 to Debian 6 Upgrade
1.0.7 should run on squeeze - at least there are installations like this.

If it's better to update ispcp AFTER Debian - I don't know... (if ispcp 1.0.6 runs on Squeeze...).

/J
08-13-2011 10:12 PM
Visit this user's website Find all posts by this user Quote this message in a reply
DarkSide Offline
Junior Member
*

Posts: 35
Joined: Jan 2008
Reputation: 0
Post: #3
RE: Safe? Debian 5 to Debian 6 Upgrade
I think I will install a VM identical to my current server setup and test the upgrade to squeeze then to 1.0.7 and vice versa to see if there are any problems then report back Smile
08-14-2011 02:56 AM
Find all posts by this user Quote this message in a reply
joximu Offline
helper
*****
Moderators

Posts: 7,034
Joined: Jan 2007
Reputation: 92
Post: #4
RE: Safe? Debian 5 to Debian 6 Upgrade
Ok, thanx for reporting the results

/J
08-14-2011 07:18 AM
Visit this user's website Find all posts by this user Quote this message in a reply
DarkSide Offline
Junior Member
*

Posts: 35
Joined: Jan 2008
Reputation: 0
Post: #5
RE: Safe? Debian 5 to Debian 6 Upgrade
Upgrading from Debian 5 and ispCP 1.0.6 to Debian 6 resulted in apache not being able to start, if you need logs then please state which one. I will continue testing! Smile
08-14-2011 09:32 AM
Find all posts by this user Quote this message in a reply
DarkSide Offline
Junior Member
*

Posts: 35
Joined: Jan 2008
Reputation: 0
Post: #6
RE: Safe? Debian 5 to Debian 6 Upgrade
Success!

First I updated ispCP on Debian 5 to 1.0.7 which went without any problems at all but after updating to Debian 6, trying to access admin.domain.com resulted in an error which via the logs I saw was related to mysql.

I solved the problem by doing the following:
# cd /usr/local/src/ispcp/ispcp-omega-1.0.7
# aptitude install $(cat ./docs/Debian/debian-packages-`lsb_release -cs`)
# cd /var/www/ispcp/engine/setup
# perl ./ispcp-update

This corrected the error and the panel and domains were all working again! Smile

I hope this can help someone.
08-14-2011 09:01 PM
Find all posts by this user Quote this message in a reply
DarkSide Offline
Junior Member
*

Posts: 35
Joined: Jan 2008
Reputation: 0
Post: #7
RE: Safe? Debian 5 to Debian 6 Upgrade
I finally carried this out on my live box today!

1. Upgrade to 1.0.7 was fine as expected!
2. Upgrade to squeeze was fine as expected!
3. Apache2 died as expected!
4. My commands above succeeded as expected! Everything worked!
5. I then rebooted to test everything was okay.
6. Bad news, after a long time (about 1 hour) server would not respond to ping.
7. Hardware reboot initiated!
8. Server responded to ping, so did www and ftp (but they were SLOW)! Then it died again (for about 3-4 minutes) then it all responded again!
9. The story is a success, the lessons to be learnt I do not know.

If there are any logs which may help then please ask. I would like to see this project maximise its potential! :-)
08-31-2011 07:33 AM
Find all posts by this user Quote this message in a reply
robbo007 Offline
Junior Member
*

Posts: 136
Joined: Apr 2009
Reputation: 0
Post: #8
RE: Safe? Debian 5 to Debian 6 Upgrade
Hello,
Many thanks for this post. Its a massive help.

I run Lenny with 1.0.7 and will be upgrading to Squeeze this Friday evening. Can you indicate the upgrade from Lenny to Squeeze process you followed? I've found a few on the internet but not sure if they will break ISPCP. I'm a little nervous as I have quiet a few customers websites online.

Thanks,
Rob
08-08-2012 11:01 PM
Find all posts by this user Quote this message in a reply
DragonZX Offline
Moderator
*****
Moderators

Posts: 441
Joined: Aug 2010
Reputation: 5
Post: #9
RE: Safe? Debian 5 to Debian 6 Upgrade
(08-08-2012 11:01 PM)robbo007 Wrote:  I run Lenny with 1.0.7 and will be upgrading to Squeeze this Friday evening. Can you indicate the upgrade from Lenny to Squeeze process you followed? I've found a few on the internet but not sure if they will break ISPCP. I'm a little nervous as I have quiet a few customers websites online.

Don't worry, I upgraded my Lenny 1 year ago, no special bugs noticed, but I had some errors in configs, but it has been fixed by update 1.0.7 to 1.0.7 (in my case I upgraded to R2, I made).
08-12-2012 03:01 AM
Visit this user's website Find all posts by this user Quote this message in a reply
robbo007 Offline
Junior Member
*

Posts: 136
Joined: Apr 2009
Reputation: 0
Post: #10
RE: Safe? Debian 5 to Debian 6 Upgrade
After a few hairy moments all upgraded. Thanks.
08-13-2012 04:19 PM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)