Current time: 07-04-2020, 10:26 PM Hello There, Guest! (LoginRegister)


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installation ATmail ( Serverweit - suexec mismatch )
Author Message
HxD Offline
Junior Member
*

Posts: 66
Joined: Jul 2009
Reputation: 2
Post: #1
Installation ATmail ( Serverweit - suexec mismatch )
Guten Morgen

meine Firma hat sich als E-Mail Webclient ATmail geholt. Natürlich ohne vorher zu Fragen ob ich das überhaupt zum laufen kriege. Nun habe ich, so schlau wie ich nunmal bin mir das HowTo zu Roundcube rausgekramt und danach versucht ATmail zu Installieren.

System:
Debian Squeeze
ispCP 1.0.7
Keine sonstigen Erweiterungen / Änderungen etc pp.

Folgende Arbeitsschritte habe ich bereits abgearbeitet.

Code:
mkdir /var/www/ispcp/gui/tools/atmail
( Daten eingefügt )
chown vu2000:www-data /var/www/ispcp/gui/tools/atmail
chmod -R 777 /var/www/ispcp/gui/tools/atmail/log + tmp

vHost Datei unter /etc/apapche2/sites-avaiable erstellt mit dem Namen 06-atmail mit folgendem Inhalt:

Code:
<VirtualHost *:80>
    ServerAdmin     webmaster@domain.tld
    DocumentRoot    /var/www/ispcp/gui/tools/atmail

    ServerName      atmail.domain.tld
    ServerAlias     atmail.*

    ErrorLog        /var/log/apache2/users/atmail-error.log
    TransferLog     /var/log/apache2/users/atmail-access.log
    CustomLog       /var/log/apache2/atmail-traf.log traff
    CustomLog       /var/log/apache2/atmail-combined.log combined

    <IfModule suexec_module>
           SuexecUserGroup vu2000 vu2000
    </IfModule>

    <Directory /var/www/ispcp/gui/tools/atmail>
        Options -Indexes Includes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        Allow from all
    </Directory>

    <IfModule mod_fcgid.c>
        <Directory /var/www/ispcp/gui/tools/atmail>
            FCGIWrapper /var/www/fcgi/master/php5-fcgi-starter .php
            Options +ExecCGI
        </Directory>
        <Directory "/var/www/fcgi/master">
            AllowOverride None
            Options +ExecCGI MultiViews -Indexes
            Order allow,deny
            Allow from all
        </Directory>
    </IfModule>
    <IfModule mod_fastcgi.c>
        ScriptAlias /php5/ /var/www/fcgi/master/
        <Directory "/var/www/fcgi/master">
            AllowOverride None
            Options +ExecCGI MultiViews -Indexes
            Order allow,deny
            Allow from all
        </Directory>
    </IfModule>

    <IfModule mod_php5.c>
        <Directory /var/www/ispcp/gui/tools/atmail>
            php_admin_value open_basedir "/var/www/ispcp/gui/tools/atmail/:/etc/ispcp/:/var/run/ispcp.lock:/proc/:/bin/df:/bin/mount:/var/log/rkhunter.log:/var/log/chkrootkit.log:/usr/share/php/"
            php_admin_value session.save_path "/var/www/ispcp/gui/phptmp/"
            php_admin_value upload_tmp_dir "/var/www/ispcp/gui/phptmp/"
        </Directory>
    </IfModule>


</VirtualHost>

Soweit sogut, Erreichbar ist die Seite und beim Aufruf von domain.tld/atmail konnte ich auch den Installer ausführen und habe soweit es geht ATmail installiert. ( Habe open_basedir ausgeklammert in der Master php.ini, da ATmail angeblich open_basedir ausgeschaltet haben muss, damit alle Funktionen genutzt werden können )

Wenn ich nun unter domain.tld/atmail mich mit einem Postfach anmelde, spucken mir die Logs folgende Fehler aus.

suexec.log
Code:
[2011-09-08 10:45:54]: uid: (2000/vu2000) gid: (2000/vu2000) cmd: jquery.php.js
[2011-09-08 10:45:54]: target uid/gid (2000/2000) mismatch with directory (2000/33) or program (2000/33)

default-error.log
Code:
[Thu Sep 08 10:41:28 2011] [notice] Apache/2.2.16 (Debian) mod_fcgid/2.3.6 configured -- resuming normal operations
suexec policy violation: see suexec log for more details
[Thu Sep 08 10:41:52 2011] [warn] [client 192.168.5.14] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server, referer: http://squeeze.local/atmail/index.php/mail
[Thu Sep 08 10:41:52 2011] [error] [client 192.168.5.14] Premature end of script headers: jquery.php.js, referer: http://squeeze.local/atmail/index.php/mail
suexec policy violation: see suexec log for more details
[Thu Sep 08 10:43:08 2011] [warn] [client 192.168.5.14] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server, referer: http://squeeze.local/atmail/index.php/mail
[Thu Sep 08 10:43:08 2011] [error] [client 192.168.5.14] Premature end of script headers: jquery.php.js, referer: http://squeeze.local/atmail/index.php/mail
suexec policy violation: see suexec log for more details
[Thu Sep 08 10:43:09 2011] [warn] [client 192.168.5.14] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server, referer: http://squeeze.local/atmail/index.php/mail
[Thu Sep 08 10:43:09 2011] [error] [client 192.168.5.14] Premature end of script headers: jquery.php.js, referer: http://squeeze.local/atmail/index.php/mail
suexec policy violation: see suexec log for more details
[Thu Sep 08 10:44:41 2011] [warn] [client 192.168.5.14] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server, referer: http://squeeze.local/atmail/index.php/mail
[Thu Sep 08 10:44:41 2011] [error] [client 192.168.5.14] Premature end of script headers: jquery.php.js, referer: http://squeeze.local/atmail/index.php/mail
suexec policy violation: see suexec log for more details
[Thu Sep 08 10:44:56 2011] [warn] [client 192.168.5.14] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server, referer: http://squeeze.local/atmail/index.php/mail
[Thu Sep 08 10:44:56 2011] [error] [client 192.168.5.14] Premature end of script headers: jquery.php.js, referer: http://squeeze.local/atmail/index.php/mail
suexec policy violation: see suexec log for more details
[Thu Sep 08 10:45:54 2011] [warn] [client 192.168.5.14] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server, referer: http://squeeze.local/atmail/
[Thu Sep 08 10:45:54 2011] [error] [client 192.168.5.14] Premature end of script headers: jquery.php.js, referer: http://squeeze.local/atmail/

Und langsam aber sicher bin ich mit meinem Latein am Ende... Habe sogar schon allen Dateien im Ordner atmail 777 Rechte gegeben, gleiches Spiel... Jemand Lösungsvorschläge?

Grüße
(This post was last modified: 09-08-2011 07:07 PM by HxD.)
09-08-2011 07:04 PM
Find all posts by this user Quote this message in a reply
ZooL Offline
Moderator
*****
Moderators

Posts: 3,429
Joined: Jan 2007
Reputation: 79
Post: #2
RE: Installation ATmail ( Serverweit - suexec mismatch )
Also erstmal muss ich sagen 777 ist nicht immer gut, auch da können Probleme auftreten.

Ich denke deine frage gehört, da wir keine anderen Kategorien haben, eher in die Plauderecke..

mfg
09-08-2011 10:52 PM
Visit this user's website Find all posts by this user Quote this message in a reply
HxD Offline
Junior Member
*

Posts: 66
Joined: Jul 2009
Reputation: 2
Post: #3
RE: Installation ATmail ( Serverweit - suexec mismatch )
Jagut, das mag vielleicht sogar so sein, allerdings auch die von ATmail vorgeschriebenen Rechte bringen keine Besserung! Sad
09-08-2011 11:51 PM
Find all posts by this user Quote this message in a reply
joximu Offline
helper
*****
Moderators

Posts: 7,024
Joined: Jan 2007
Reputation: 92
Post: #4
RE: Installation ATmail ( Serverweit - suexec mismatch )
Sorge doch mal dafür, dass alle Verzeichnisse und Dateien unterhalb gui/tools/atmail dem Benutzer und Gruppe vu2000:vu2000 gehören....

da ist was der www-data Gruppe (33), das wird angemeckert.

/J
09-09-2011 10:00 PM
Visit this user's website Find all posts by this user Quote this message in a reply
HxD Offline
Junior Member
*

Posts: 66
Joined: Jul 2009
Reputation: 2
Post: #5
RE: Installation ATmail ( Serverweit - suexec mismatch )
Nachdem ich die Rechte auf vu2000:vu2000 gesetzt habe, spuckt mir die suexec.log folgenden Fehler aus:

Code:
[2011-09-12 09:55:34]: uid: (2000/vu2000) gid: (2000/vu2000) cmd: jquery.php.js
[2011-09-12 09:55:34]: file has no execute permission: (/var/www/ispcp/gui/tools/atmail/js/jQuery/plugins/jquery.php.js)

Dabei gibt es jedoch für mich ein kleines Verständnisproblem. Das angezeigte Script ist JS, normalerweise kenn ich unter fcgi diesen Fehler nur bei CGI Scripten, oder etwa nicht?

Oftmal sind einfach nur falsche Header vorhanden, ich hab jedoch in dieser Datei generell keine Headerinformationen stehen.. Zumindestens keine in der Datei stehen...

Dadurch bin ich jetzt definitiv ratloser als vorher Rolleyes

Ich weiss einfach nicht woran es liegen könnte. Sogar diverse Rechte wie 0600, 0655, 0755, 0777 bringen keine Besserung...

//edit:

Also, ich habe herausgefunden, das beim Aufruf der index.php von ATmail der Header die jquery.php.js mit einem 500er Ausgibt:

Code:
Request-URL:
    http://xxx/atmail/js/jQuery/plugins/jquery.php.js
  
  
    Request-Methode:
    GET
  
  
    Status-Code:
    HTTP/1.1 500 Internal Server Error
  



  
    Request-Headers
    10:29:03.085
  
  Accept:*/*Accept-Charset:ISO-8859-1,utf-8;q=0.7,*;q=0.7Accept-Encoding:gzip, deflateAccept-Language:de-de,de;q=0.8,en-us;q=0.5,en;q=0.3Cache-Control:max-age=0Connection:keep-aliveHost:xxxIf-Modified-Since:Thu, 08 Sep 2011 08:15:33 GMTIf-None-Match:"45b6-277-4ac69aa25f340"Referer:http://xxx/atmail/index.php/mailUser-Agent:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2

  
    Gesendetes Cookie
    atmail6:8tjc7c5abktonj3rhai1a1tul3ispCP:1kb1q0qsk1he8vi0ie5anbcum7
  

  
  



  
    Response-Header
    Δ45ms
  
  Accept-Ranges:bytesConnection:closeContent-Encoding:gzipContent-Length:375Content-Type:text/htmlDate:Mon, 12 Sep 2011 08:17:01 GMTEtag:"45b6-277-4ac69aa25f340"Last-Modified:Thu, 08 Sep 2011 08:15:33 GMTServer:Apache/2.2.16 (Debian)Vary:Accept-Encoding

Mir gibt nur Frage auf, wieso ich das mit execute Rechten einfach nicht ausgeliefert bekomme... Habe jetzt schon fast alle chmods durch die es gibt ...
(This post was last modified: 09-12-2011 06:21 PM by HxD.)
09-12-2011 06:03 PM
Find all posts by this user Quote this message in a reply
joximu Offline
helper
*****
Moderators

Posts: 7,024
Joined: Jan 2007
Reputation: 92
Post: #6
RE: Installation ATmail ( Serverweit - suexec mismatch )
hm.
könnte dran leigen, dass da ".php" drinsteht - und dann könnte es sein, dass da fcgid oder fastcgi meint, es sei zuständig (oder apache will es an die weiterleiten). aber es sollte ja nur an den Browser durchgereicht werden, da nur eine .js Datei...
... so sieht's grad aus.

Ich hatte auch schon Probleme mit atmail (aktuelle version) - eine alte offene Version lief, aber die war schrecklich.

Versuch mal im apache-conf die Zuordnungen von .php Dateien zu ändern (.php$ oder so??? ich weiss auch nicht...). Oder mal versuchen, die datei umzubenennen und den Aufruf anpassen - einfach mal um zu sehen, obs das ist.

Gruss J
09-12-2011 07:16 PM
Visit this user's website Find all posts by this user Quote this message in a reply
HxD Offline
Junior Member
*

Posts: 66
Joined: Jul 2009
Reputation: 2
Post: #7
RE: Installation ATmail ( Serverweit - suexec mismatch )
Da fress mir doch einer einen Besen... Das war der Fehler... Der Handler versucht die .js Datei als .php auszugeben, dadurch - falscher Header - kackt sich der Apache ein und liefert nicht...

Das umbennen der entsprechenden jquery Datei hat geholfen.
Vermutlich nicht der eleganteste, aber er funktioniert!

Roundup:
  • Verzeichnisse erstellen
  • chmod + chowner zuweisen
  • vHost erstellen
  • ATmail hochladen
  • folgende Dateien verändern:

Datei ~ application/models/calendar.php
Suchen:
Code:
        <script type="text/javascript" src="{$siteurl}js/jQuery/plugins/jquery.php.js"></script>

Ersetzen:
Code:
        <script type="text/javascript" src="{$siteurl}js/jQuery/plugins/jquery.js"></script>

Datei ~ application/modules/admin/views/scripts/index/index.phtml
Suchen:
Code:
    <script type="text/javascript" src="<?php echo $this->siteBaseUrl ?>js/jQuery/plugins/jquery.php.js"></script>

Ersetzen:
Code:
    <script type="text/javascript" src="<?php echo $this->siteBaseUrl ?>js/jQuery/plugins/jquery.js"></script>

Datei ~ application/modules/mail/views/scripts/composemessage/headerstandalone.phtml
Suchen:
Code:
    <script type="text/javascript" src="<?php echo $this->siteBaseUrl ?>js/jQuery/plugins/jquery.php.js"></script>

Ersetzen:
Code:
    <script type="text/javascript" src="<?php echo $this->siteBaseUrl ?>js/jQuery/plugins/jquery.js"></script>

Datei ~ application/modules/mail/views/scripts/global/header.phtml
Suchen:
Code:
    <script type="text/javascript" src="<?php echo $this->siteBaseUrl ?>js/jQuery/plugins/jquery.php.js"></script>

Ersetzen:
Code:
    <script type="text/javascript" src="<?php echo $this->siteBaseUrl ?>js/jQuery/plugins/jquery.js"></script>

Datei ~ application/modules/mail/views/scripts/signup/signup.phtml
Suchen:
Code:
    <script type="text/javascript" src="<?php echo $this->siteBaseUrl ?>js/jQuery/plugins/jquery.php.js"></script>

Ersetzen:
Code:
    <script type="text/javascript" src="<?php echo $this->siteBaseUrl ?>js/jQuery/plugins/jquery.js"></script>


Datei ~ js/jQuery/jquery.php.js UND js/jQuery/plugins/jquery.php.js jeweils in jquery.js umbennen! - Voilá, fertig...

Viel Spass mit ATmail Smile
09-12-2011 07:49 PM
Find all posts by this user Quote this message in a reply
joximu Offline
helper
*****
Moderators

Posts: 7,024
Joined: Jan 2007
Reputation: 92
Post: #8
RE: Installation ATmail ( Serverweit - suexec mismatch )
Danke für die Anleitung - nun kann ich's auch mal wieder testen...

zusammen geht's halt besser :-)

/Joxi
09-12-2011 07:52 PM
Visit this user's website Find all posts by this user Quote this message in a reply
HxD Offline
Junior Member
*

Posts: 66
Joined: Jul 2009
Reputation: 2
Post: #9
RE: Installation ATmail ( Serverweit - suexec mismatch )
Japp, aber wie ich mir schon immer zu sagen pflege, "komm erstmal da drauf!" Wink

Danke für deine Hilfestellungen joxi.
09-12-2011 10:13 PM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)