Current time: 10-22-2021, 08:46 PM Hello There, Guest! (LoginRegister)


Post Reply 
[Resuelto] Extraños del Correo...
Author Message
jdriank Offline
Junior Member
*

Posts: 26
Joined: Nov 2011
Reputation: 0
Post: #1
[Resuelto] Extraños del Correo...
Buenas noches!

Tengo un problema, con el mail entre dos de mis servidores...

Cuando hago pruebas cruzadas, hay veces que funciona el mail sin problemas...y hay otras que no me lo envia...

Os pongo LOG de los dos casos:
Quote:Dec 30 01:50:51 srv01 amavis[1755]: (01755-01) Passed CLEAN, [79.108.xxx.xxx] [79.108.xxx.xxx] <soporte@xxx1.es> -> <jdriank@xxx2.es>, Message-ID: <BB30ABB5E5214DB881BBD3617FAA2B52@PERSONAL>, Hits: -, 152 ms
Dec 30 01:50:51 srv01 postfix/smtp[1941]: A777F57A460: to=<jdriank@xxx2.es>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.3, delays=0.14/0/0.01/0.15, dsn=2.6.0, status=sent (250 2.6.0 Ok, id=01755-01, from MTA: 250 2.0.0 Ok: queued as DAA5D57A46A)
Dec 30 01:50:51 srv01 postfix/qmgr[3241]: A777F57A460: removed
En ese caso no llega...

Y ahora cuando si:
Quote:Dec 30 01:50:51 srv01 postfix/smtpd[1943]: connect from srv01.xxx2.es.local[127.0.0.1]
Dec 30 01:50:51 srv01 postfix/smtpd[1943]: DAA5D57A46A: client=srv01.xxx2.es.local[127.0.0.1]
Dec 30 01:50:51 srv01 postfix/cleanup[1940]: DAA5D57A46A: message-id=<BB30ABB5E5214DB881BBD3617FAA2B52@PERSONAL>
Dec 30 01:50:51 srv01 postfix/qmgr[3241]: DAA5D57A46A: from=<soporte@xxx1.es>, size=4032, nrcpt=1 (queue active)
Dec 30 01:50:51 srv01 postfix/smtpd[1943]: disconnect from srv01.xxx2.es.local[127.0.0.1]
Dec 30 01:50:51 srv01 postfix/virtual[1945]: DAA5D57A46A: to=<jdriank@xxx2.es>, relay=virtual, delay=0.05, delays=0.04/0/0/0, dsn=2.0.0, status=sent (delivered to maildir)

Por que me remueve el mail y no lo llega a entregar si antes si que lo ha realizado sin problemas?? por que puede ser esto??

Debian 6.0 Squeeze
iSPcp Omega 1.0.7
(This post was last modified: 01-31-2012 08:07 PM by kurgans.)
12-30-2011 10:59 AM
Find all posts by this user Quote this message in a reply
kurgans Offline
Moderator
*****
Moderators

Posts: 1,565
Joined: Feb 2008
Reputation: 23
Post: #2
RE: Extraños del Correo...
Ese correo te llega perfectamente, es decir no es que mande 2 correos.

Si no que pasa 2 veces por postfix debido a amavis, por aqui Kilburn dejo como solucionar eso y unos problemas secundarios a raiz de eso.

Busca por concepto autoresponder encontraras los hilos.
12-30-2011 06:06 PM
Visit this user's website Find all posts by this user Quote this message in a reply
jdriank Offline
Junior Member
*

Posts: 26
Joined: Nov 2011
Reputation: 0
Post: #3
RE: Extraños del Correo...
(12-30-2011 06:06 PM)kurgans Wrote:  Ese correo te llega perfectamente, es decir no es que mande 2 correos.

Si no que pasa 2 veces por postfix debido a amavis, por aqui Kilburn dejo como solucionar eso y unos problemas secundarios a raiz de eso.

Busca por concepto autoresponder encontraras los hilos.
Mi problema Kurgans, es que entre dos servidores mios no puedo enviarme un mail...

Yo envio de soporte@dominioA > soporte@dominioB
y en el webmail me da el siguiente error:
Quote:Mensaje no enviado. Respuesta del servidor:

Acción no realizada: buzón no disponible
550 5.1.1 <soporte@DOMINIOB>: Recipient address rejected: User unknown in virtual mailbox table

Y en el Windows Live Mail que es mi programa de correo, da el siguiente error:
Quote:Asunto 'Re: Prueba301211-1400'
Error de servidor: 504
Respuesta del servidor: 504 5.5.2 <PERSONAL>: Helo command rejected: need fully-qualified hostname
Servidor: 'smtp.DOMINIOA'
Id. de error de Windows Live Mail: 0x800CCC79
Protocolo: SMTP
Puerto: 25
Seguridad (SSL): No

El problema esta ahi " Helo command rejected: need fully-qualified hostname" aunque son dos servers mios con ispCP Omega 1.0.7 los dos y la misma configuracion....

En el server de destino en /etc/resolv.conf tengo :
Quote:nameserver 127.0.0.1
nameserver 91.121.87.xx
nameserver 8.8.8.8
nameserver 8.8.4.4
nameserver 213.186.33.99
Y en el server que envia, tengo :
Quote:nameserver 127.0.0.1
nameserver 91.121.104.xx
nameserver 8.8.8.8
nameserver 8.8.4.4
nameserver 213.186.33.99

Hay algo mas que deba de mirar...?¿? el dominio en un principio no me aparece tampoco en ninguna blacklist...

Muchas gracias
12-30-2011 11:41 PM
Find all posts by this user Quote this message in a reply
kurgans Offline
Moderator
*****
Moderators

Posts: 1,565
Joined: Feb 2008
Reputation: 23
Post: #4
RE: Extraños del Correo...
Es que eso nada tiene que ver con tu primer post y el log puesto


Quote:Asunto 'Re: Prueba301211-1400'
Error de servidor: 504
Respuesta del servidor: 504 5.5.2 <PERSONAL>: Helo command rejected: need fully-qualified hostname
Servidor: 'smtp.DOMINIOA'
Id. de error de Windows Live Mail: 0x800CCC79
Protocolo: SMTP
Puerto: 25
Seguridad (SSL): No

Tu FQDN se encuentra en la config de postfix (hostname // main.cf) y se supone que ahi debes de tener un nombre tipo srv.midominio.tld y este debe resolver a tu ip por un servidor externo


Quote:Mensaje no enviado. Respuesta del servidor:

Acción no realizada: buzón no disponible
550 5.1.1 <soporte@DOMINIOB>: Recipient address rejected: User unknown in virtual mailbox table

Luego el domino receptor no puede estar en ambos servidores ya que tienes como nameserver tu propio servidor no saldra a internet a buscarlo si lo encuentra localmente
(This post was last modified: 12-31-2011 02:48 AM by kurgans.)
12-31-2011 02:43 AM
Visit this user's website Find all posts by this user Quote this message in a reply
jdriank Offline
Junior Member
*

Posts: 26
Joined: Nov 2011
Reputation: 0
Post: #5
RE: Extraños del Correo...
En cada uno hay un hostname diferente...

En el server A es : srv01.hostme.es
En el server B es : srv01.hostmespain.es

El A apunta a la IP: 91.121.104.65
El B apunta a la IP: 91.121.87.86

Con lo cual eso no esta mal configurado...no?

Sl2 y gracias!!
12-31-2011 03:11 AM
Find all posts by this user Quote this message in a reply
kurgans Offline
Moderator
*****
Moderators

Posts: 1,565
Joined: Feb 2008
Reputation: 23
Post: #6
RE: Extraños del Correo...
Eso ya no te lo puedo decir una cosa es lo que tu tengas y otra cosa es lo que uses en el sistema de correo pero el error FQDN es por que tu postifx esta enviando una informacion erronea y no aceptan ese correo por que lo que envia (helo) no existe en internet (no resuelve) a una ip
12-31-2011 04:36 AM
Visit this user's website Find all posts by this user Quote this message in a reply
realnetwork Offline
Banned

Posts: 19
Joined: May 2011
Post: #7
RE: Extraños del Correo...
(12-31-2011 03:11 AM)jdriank Wrote:  En cada uno hay un hostname diferente...

En el server A es : srv01.hostme.es
En el server B es : srv01.hostmespain.es

El A apunta a la IP: 91.121.104.65
El B apunta a la IP: 91.121.87.86

Con lo cual eso no esta mal configurado...no?

Sl2 y gracias!!

Creo que te estas matando la cabeza jdriank porque el problema debe ser que yace en tu Windows entonces puedes probar haciendo lo siguiente:

1- Ir a C:\Windows\System32\drivers\etc
2- Abrir el archivo hosts con el bloc de notas (clic derecho abrir y seleccionas el bloc de notas)
3- Una vez alli debes configurar tus direcciones y a lo q deseas accesar por ej:

Direccion IP interna Nombre de la pagina o recurso que deseas utilizar

192.168.0.50 mail.elnombredetudominio.com
192.168.0.50 webftp.elnombredetudominio.com
192.168.0.50 pma.elnombredetudominio.com
#CON EL NUMERAL CREAS UNA LINEA DE COMENTARIOS
#SI TIENES OTRO SERVIDOR DEBES HACER LO MISMO
192.168.0.51 mail.elnombredetuotrodominio.com
192.168.0.51 webftp.elnombredetuotrodominio.com
192.168.0.51 pma.elnombredetuotrodominio.com

4-Configuras tu cliente de correo que muchas veces nos pide certificados de seguridad a los cuales podemos dar agregar excepcion.

5-Buala! debe funcionar revisa y nos cuentas... saludos...
01-01-2012 05:21 PM
Find all posts by this user Quote this message in a reply
jdriank Offline
Junior Member
*

Posts: 26
Joined: Nov 2011
Reputation: 0
Post: #8
RE: Extraños del Correo...
realnetwork, me parece buena tu idea...la he probado y no me funciona...

Aun así esa solucion es "poco practica" ya que no voy a modificarselo el fichero a mis clientes...

Voy a reinstalar desde 0 este server nuevo y a ver si así se soluciona todo...

En un rato os cuento!!
01-03-2012 12:35 AM
Find all posts by this user Quote this message in a reply
realnetwork Offline
Banned

Posts: 19
Joined: May 2011
Post: #9
RE: Extraños del Correo...
(01-03-2012 12:35 AM)jdriank Wrote:  realnetwork, me parece buena tu idea...la he probado y no me funciona...

Aun así esa solucion es "poco practica" ya que no voy a modificarselo el fichero a mis clientes...

Voy a reinstalar desde 0 este server nuevo y a ver si así se soluciona todo...

En un rato os cuento!!

jdriank creo que no has comprendido, esa configuracion unicamente la debes hacer en los pcs que se encuentren en tu LAN puesto que jamas van a poder encontrar tus webs por eso debes indicarle en donde se encuentran, ya que es como si estuvieran buscando afuera cuando realmente lo que buscan esta adentro.

Sin embargo es respetable tu decision y cuentanos como te fue...
(This post was last modified: 01-03-2012 01:31 AM by realnetwork.)
01-03-2012 01:30 AM
Find all posts by this user Quote this message in a reply
jdriank Offline
Junior Member
*

Posts: 26
Joined: Nov 2011
Reputation: 0
Post: #10
RE: Extraños del Correo...
Si que lo he entendido...pero yo no estoy trabajando en una LAN...

Yo dispongo de servidores dedicados ubicados en Datacenters...el problema lo tengo en que este servidor, por A o por B me estaba dando problemas....

Es la segunda vez que instalo un debian con Squeeze...con Lenny me van a la perfeccion, es mas tengo otros tres con Lenny que van muy finos y sin problemas, pero este me ha salido "rana"...

Estoy reinstalando todo desde 0 para de esa manera evitar problemas...

Luego os reporto si se ha solucionado, porque como muchos sabemos, aveces es mas rentable reinstalar de 0 que comerte la cabeza...jejejeje (Experiencias vividas...)aunque esta claro, que no es la solucion porque de esta manera no averiguamos de donde parte el problema...pero cuando la cosa se complica no queda mas!!...

Un abrazo y feliz año!!!
01-03-2012 01:41 AM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)