Current time: 01-29-2022, 10:49 PM Hello There, Guest! (LoginRegister)


Post Reply 
Apache fastcgi problem
Author Message
Spearoth Offline


Posts: 3
Joined: Feb 2012
Reputation: 0
Post: #1
Apache fastcgi problem
Ok, I just solved the problem by creating a the folder /etc/bind and the file named.conf in it.

BUT now I have another problem with Apache fastgci:

Code:
The program is now ready to set up ispCP on your system.
        Do you want to continue? [Y/n]: y

        Starting ispCP installation
         * Stopping all services: ......                                                                          [ Done ]
        Pre-installation tasks for Debian
         * Nothing to do...                                                                          [ Done ]

        System checks
         * Mysql server connection:                                                                  [ Done ]

        Services setup
         * ispCP users and groups:                                                                   [ Done ]
         * ispCP directories:                                                                        [ Done ]
         * ispCP main configuration file:                                                            [ Done ]
         * ispCP database:                                                                           [ Done ]
         * ispCP default language table:                                                             [ Done ]
         * ispCP default SQL data:                                                                   [ Done ]
         * ispCP system hosts file:                                                                  [ Done ]
         * ispCP system resolver:                                                                    [ Done ]
         * ispCP crontab file:                                                                       [ Done ]
         * ispCP Bind9 main configuration file:                                                      [ Done ]
         * ispCP Apache fastCGI modules configuration:                                             [ Failed ]

        [FATAL] An error occurred during setup process!
        Correct it and re-run this program.

        Log files are stored in /var/log/ispcp/setup
        You can also find help at http://isp-control.net/forum

ispcp-setup.log
Code:
sys_command()                  | Starting...
system()                       | [DEBUG] ERROR: Module fastcgi_ispcp does not exist!
getCmdExitValue()              | Starting...
getCmdExitValue()              | [DEBUG] External command exited with value 1
getCmdExitValue()              | Ending...
sys_command()                  | [ERROR] External command '/usr/sbin/a2dismod fastcgi_ispcp' exited with value                    1 !
exit_msg()                     | Starting...
exit_msg()                     | Ending...
del_file()                     | Starting...
del_file()                     | Ending...

Some system facts:
  • ubuntu-10.04-x86_32
  • newly installed system
  • neary every perl module installed to finally start the ispCP installation
  • ispCP 1.0.7
  • vServer
  • logged in as root

I used the installation guide from this website and followed every step:
http://isp-control.net/documentation/sta...ion/ubuntu

I'm frustrated. Minimum one problem in every step *arrrgh*

Regards, Spearoth
02-15-2012 06:46 PM
Find all posts by this user Quote this message in a reply
joximu Offline
helper
*****
Moderators

Posts: 7,024
Joined: Jan 2007
Reputation: 92
Post: #2
RE: Apache fastcgi problem
With step 4 the fastcgi-module should have been installed. But only if the previus steps were done. I don't know ubuntu very well - in Debian you need either to install this package manually or add another deb source for apt....

btw: by installing bind the folde /etc/bind should be created automatically....

So - I think there are at least some packages missing - do step 4 again and watch out for messages!

/J
02-15-2012 06:53 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)