Current time: 09-20-2018, 10:13 AM Hello There, Guest! (LoginRegister)


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ispCP Error
Author Message
Eomer Offline


Posts: 3
Joined: May 2012
Reputation: 0
Post: #1
ispCP Error
Hello Guys,

im running ispCP on OpenSSH_5.5p1 Debian-6+squeeze1, OpenSSL 0.9.8o 01 Jun 2010.

I did the following update:

apt-get install php5 php5-common php5-sqlite

And from then i was not able to access ispcp.domain.de or ispcp.domain.de/pma

I fixed php MyAdmin by setting up the permissions (chmod).

But if it try to get on ispcp.domain.de im getting:

Error: Unable to open the configuration file `/etc/ispcp/ispcp.conf`!

The config-file is still there.

Any idea why? I am a linux-dummy. It would be great i you could explain it as easy as possible to me but ill try my best.

regards,
Eomer
(This post was last modified: 05-23-2012 08:13 AM by Eomer.)
05-23-2012 08:12 AM
Find all posts by this user Quote this message in a reply
ephigenie Offline
Project Leader
*******
Administrators

Posts: 1,578
Joined: Oct 2006
Reputation: 15
Post: #2
RE: ispCP Error
Maybe you installed mod_php instead of staying with fastcgi php ?

If you're a linux dummy why did you installed software you already have on your system (php5-cgi) ... ?
05-23-2012 06:54 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Eomer Offline


Posts: 3
Joined: May 2012
Reputation: 0
Post: #3
RE: ispCP Error
Hi! Thank you for your reply!

I had to update it to get a weave server running and actually it helped me out but it created another problem...

How do i know if fastcgi is installed? There was no entry in the apache directory.

Should i just install fastcgi?

regards,
Eomer
05-23-2012 09:40 PM
Find all posts by this user Quote this message in a reply
ephigenie Offline
Project Leader
*******
Administrators

Posts: 1,578
Joined: Oct 2006
Reputation: 15
Post: #4
RE: ispCP Error
Fastcgi is the way php is being used in ispCP so by just changing the php - you changed the whole setup ...

try apt-get install php5-cgi apache2-mpm-worker

then a2enmod fastcgi ...

take a look if it helped.
05-25-2012 01:50 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Eomer Offline


Posts: 3
Joined: May 2012
Reputation: 0
Post: #5
RE: ispCP Error
It helped. Thank you very much!
05-25-2012 05:41 PM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)