Current time: 06-19-2018, 02:45 PM Hello There, Guest! (LoginRegister)


Post Reply 
problem with 500 error on php pages of virtual host
Author Message
cyril-c Offline
Newbie
*

Posts: 5
Joined: May 2013
Reputation: 0
Post: #1
Exclamation problem with 500 error on php pages of virtual host
I was installing linuxmint nadia ubuntu kernel after having doing the test on kde version is geniale, but I had concerns that the 500 error page in php (the html page on) I thought it was Were can be due to the kde version I was in linuxmint 12, I heberger my small site with ispCP omega-, php work, but since I was installing linuxmint nadia without going through an update (I'm my backups from external hard drive to my site), so my problem is that all my php site displays error 500 internal server error, however ispCP is Consus in php and all works, but I spend on the virtual host , well I is no website online and has a sacred problem, only the website in html walking vurtual host and not the php site: '(
someone would have a solution please?
05-05-2013 11:43 AM
Find all posts by this user Quote this message in a reply
joximu Offline
helper
*****
Moderators

Posts: 7,039
Joined: Jan 2007
Reputation: 92
Post: #2
RE: problem with 500 error on php pages of virtual host
Hi Cyril
your post is very confusing...

So you had linuxmint 12 and then installed linuxmint 14 (nadia) - without update...????
What dows this exactly mean?

It seams that there are permission problems that throw the 500 error. So you should see more about the problms in the log files.
Should be solvable - but it might be a big effort - depending on what you did ... :-/

/Joxi
05-06-2013 10:32 AM
Visit this user's website Find all posts by this user Quote this message in a reply
cyril-c Offline
Newbie
*

Posts: 5
Joined: May 2013
Reputation: 0
Post: #3
RE: problem with 500 error on php pages of virtual host
Hello and thank you joximus
the problem is not the distribution linuxmint, is encoded on ubuntu, the problem is that the installation of ispCP Omega, I was up with the only choice so lucid package for ubuntu which is the current kernel that is quantal package (linux mint nadia is quantal code on ubuntu), I think the version of apache and php are old can be? I do not know how you explain it, I glue the error log that I was so below, I hope its pouras help you in any case thank you in advance for your help



<b>Fatal error</b>: Directive 'allow_call_time_pass_reference' is no longer available in PHP in <b>Unknown</b> on line <b>0</b><br />
[Tue May 07 01:50:20 2013] [warn] [client 195.**.***.**.***] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
[Tue May 07 01:50:20 2013] [error] [client 195.**.***.**.***] Premature end of script headers: index.php
05-07-2013 10:01 AM
Find all posts by this user Quote this message in a reply
joximu Offline
helper
*****
Moderators

Posts: 7,039
Joined: Jan 2007
Reputation: 92
Post: #4
RE: problem with 500 error on php pages of virtual host
Hi Cyril

Here we have:
***
<b>Fatal error</b>: Directive 'allow_call_time_pass_reference' is no longer available in PHP in <b>Unknown</b> on line <b>0</b><br />
***

it looks like this is a php-config directive which is no more supported with your new php version.

ispcp ist - now - very old and does not support the newer php versions out of the box.

You can try the following:
change the php.ini in
/var/www/fcgi/<domain>/php5/php.ini and also for domain = "master" which is the panel itself.

Start with /var/www/fcgi/master/php5/php.ini
In the php.ini you search for "allow_call_time_pass_reference" and comment the whole line.

Then try again to load your ispcp-panel.

If there are more fatal errors (with "in Unknown" line "0") - then theres a good chance that there are more configuration directives that are no more supported with your php.

I assume you had php 5.2 or php 5.3 and now you have php 5.4

Read at least
http://ch2.php.net/manual/en/migration54...atible.php

If you found all the problems - also change the other php.ini and then you can change also the template so that new domains also hav a compatible php.ini:
/etc/ispcp/fcgi/parts/php5/php.ini

Hope this helps

/Joxi
05-07-2013 09:52 PM
Visit this user's website Find all posts by this user Quote this message in a reply
cyril-c Offline
Newbie
*

Posts: 5
Joined: May 2013
Reputation: 0
Post: #5
RE: problem with 500 error on php pages of virtual host
hello joximu Rolleyes
I is modified and Comenter line to / var / www / fcgi / <domain> / php5/php.ini and the master also
I is Pabel of amistration, was at the virtualhost that his work not php page, the page html I is
I know what to think :/
I was reinstall linux and reinstall ispCP Omega, lol I was mare of
(This post was last modified: 05-12-2013 11:36 AM by cyril-c.)
05-12-2013 11:35 AM
Find all posts by this user Quote this message in a reply
joximu Offline
helper
*****
Moderators

Posts: 7,039
Joined: Jan 2007
Reputation: 92
Post: #6
RE: problem with 500 error on php pages of virtual host
Hi Cyril

so.. is the problem solved or not? I have problems understanding your last post...

/Joxi
05-13-2013 08:23 PM
Visit this user's website Find all posts by this user Quote this message in a reply
cyril-c Offline
Newbie
*

Posts: 5
Joined: May 2013
Reputation: 0
Post: #7
RE: problem with 500 error on php pages of virtual host
hi joximu

I took you to apologize to the response time of your last post, is involuntary, so I solved by taking the php.ini file in / etc/php5/apache2/php.ini and replace the one in /var/www/fcgi/master/php5/php.ini and the same thing for virtual domains. So problem resolved, thank you for your help and I hope you will agree that this solution and it works.
By cons I is another concern with awstats, I is error 400 (not found) in the apache log it says that misses the awstats file in /var/www/ispCP/gui/awstats after verification I contaste the same thing it is not there yet it yas conf file field present in / etc / awstats, can you help me with this joximu? thank you in advance

cyril-c
05-22-2013 09:53 PM
Find all posts by this user Quote this message in a reply
joximu Offline
helper
*****
Moderators

Posts: 7,039
Joined: Jan 2007
Reputation: 92
Post: #8
RE: problem with 500 error on php pages of virtual host
Hi

php.ini: I assume you did change some settings in the several php.ini files (tmp path for example) - but this should work...
For new domains: change the php.ini template in
/etc/ispcp/fcgi/parts/php5/php.ini

awstats: there is no /var/www/ispcp/gui/awstats ...
the awstats support consists of several setings:
in the apache ispcp.conf:
Quote: # httpd awstats support BEGIN.

ProxyRequests Off

<Proxy *>
Order deny,allow
Allow from all
</Proxy>

ProxyPass /stats http://localhost/stats/test.tld
ProxyPassReverse /stats http://localhost/stats/test.tld

<Location /stats>
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteRule ^(.+)\?config=([^\?\&]+)(.*) $1\?config=test.tld&$3 [NC,L]
</IfModule>
AuthType Basic
AuthName "Statistics for domain test.tld"
AuthUserFile /var/www/virtual/test.tld/.htpasswd
AuthGroupFile /var/www/virtual/test.tld/.htgroup
Require group statistics
</Location>

# httpd awstats support END.

and /etc/apache2/sites-enabled/01_awstats.conf

at least this should be sufficient for the web-part of awstats...
(of course there are conf files for every domain in /etc/awstats...)

/J
05-23-2013 08:41 AM
Visit this user's website Find all posts by this user Quote this message in a reply
cyril-c Offline
Newbie
*

Posts: 5
Joined: May 2013
Reputation: 0
Post: #9
RE: problem with 500 error on php pages of virtual host
hi

can you tell me if that is in / var / www / ispCP / gui / stats of the errors after he told a log file per domain so I was after creating the stats file for each domain, and put awstats_domaine file. tld.conf the field, but is not aparament this is awastats.tpl can be the missing file? to generate the stats page? which are in / usr / lib / cgi-bin / awstats.pl? I was testing the generation of stats with sudo / usr / lib / cgi-bin / awstats.pl-update-config = ma_machine.mon_domaine.mon_pays and running, so where does the error is in which is located in / var/www/ispcp/gui/stats/domaine1 / etc ... It yas a folder in / var / www / awstats is empty cd is normal?
here is soon to thank you in advance
05-29-2013 12:11 AM
Find all posts by this user Quote this message in a reply
joximu Offline
helper
*****
Moderators

Posts: 7,039
Joined: Jan 2007
Reputation: 92
Post: #10
RE: problem with 500 error on php pages of virtual host
/var/www/awstats/ - is empty.
/var/www/ispcp/gui/stats - does not exist!

the awstats config files (for every/all domains) are in /etc/awstats

the cron job
Code:
# AWStats
15 */6 * * * root /var/www/ispcp/engine/awstats/awstats_updateall.pl now -awstatsprog=/usr/lib/cgi-bin/awstats.pl >/dev/null 2>&1
in /etc/cron.d/ispcp generates the awstats files (located in /var/cache/awstats) which are used to show the stats in http://domain.tld/stats

Maybe you need the correct setting in ispcp.conf:
AWSTATS_ACTIVE = yes
AWSTATS_MODE = 0
btw. there are also some path settings and maybe your paths are different to mine (debian 5).

Hope this helps...

/J


btw. what's your native language...?
(This post was last modified: 05-29-2013 08:20 PM by joximu.)
05-29-2013 08:19 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)