Current time: 01-25-2022, 09:56 AM Hello There, Guest! (LoginRegister)


Post Reply 
mod_evasive, apxs:Error: Activation failed for custom /etc/apache2/httpd.conf
Author Message
prale Offline
Junior Member
*

Posts: 92
Joined: Feb 2008
Reputation: 1
Post: #1
mod_evasive, apxs:Error: Activation failed for custom /etc/apache2/httpd.conf
Hello I have a problem with installing mod_evasive.
I followed the documentation of "Prevent DOS-Attacks".

At the last step it goes wrong:

# apxs2 -i -a -c mod_evasive20.c

Code:
/usr/share/apr-1.0/build/libtool --silent --mode=compile --tag=disable-static i4                                                                             86-linux-gnu-gcc -prefer-pic -DLINUX=2 -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -D_RE                                                                             ENTRANT -I/usr/include/apr-1.0 -I/usr/include/openssl -I/usr/include/postgresql                                                                              -I/usr/include/xmltok -pthread     -I/usr/include/apache2  -I/usr/include/apr-1.                                                                             0   -I/usr/include/apr-1.0 -I/usr/include/postgresql  -c -o mod_evasive20.lo mod                                                                             _evasive20.c && touch mod_evasive20.slo
/usr/share/apr-1.0/build/libtool --silent --mode=link --tag=disable-static i486-                                                                             linux-gnu-gcc -o mod_evasive20.la  -rpath /usr/lib/apache2/modules -module -avoi                                                                             d-version    mod_evasive20.lo
/usr/share/apache2/build/instdso.sh SH_LIBTOOL='/usr/share/apr-1.0/build/libtool                                                                             ' mod_evasive20.la /usr/lib/apache2/modules
/usr/share/apr-1.0/build/libtool --mode=install cp mod_evasive20.la /usr/lib/apa                                                                             che2/modules/
cp .libs/mod_evasive20.so /usr/lib/apache2/modules/mod_evasive20.so
cp .libs/mod_evasive20.lai /usr/lib/apache2/modules/mod_evasive20.la
PATH="$PATH:/sbin" ldconfig -n /usr/lib/apache2/modules
----------------------------------------------------------------------
Libraries have been installed in:
   /usr/lib/apache2/modules

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
chmod 644 /usr/lib/apache2/modules/mod_evasive20.so
apxs:Error: Activation failed for custom /etc/apache2/httpd.conf file..
apxs:Error: At least one `LoadModule' directive already has to exist..

The httpd.conf file seems to be empty now Sad

Any one has suggestions?
02-25-2008 06:46 AM
Find all posts by this user Quote this message in a reply
AlexS Offline


Posts: 1
Joined: Feb 2008
Reputation: 0
Post: #2
RE: mod_evasive, apxs:Error: Activation failed for custom /etc/apache2/httpd.conf
Hi,
just add the following line:

Code:
LoadModule evasive20_module /usr/lib/apache2/modules/mod_evasive20.so

in /etc/apache2/mods-available/actions.load

then restart apache2 and mod_evasive will work Smile

greetz
AlexS
(This post was last modified: 02-26-2008 06:22 PM by AlexS.)
02-26-2008 06:21 PM
Find all posts by this user Quote this message in a reply
prale Offline
Junior Member
*

Posts: 92
Joined: Feb 2008
Reputation: 1
Post: #3
RE: mod_evasive, apxs:Error: Activation failed for custom /etc/apache2/httpd.conf
Thank you! Cool

After I refresh my page more than 1time a sec it gives me a 403 forbidden! error.

So I guess it works.
02-27-2008 04:20 AM
Find all posts by this user Quote this message in a reply
prale Offline
Junior Member
*

Posts: 92
Joined: Feb 2008
Reputation: 1
Post: #4
RE: mod_evasive, apxs:Error: Activation failed for custom /etc/apache2/httpd.conf
I discovered a better solution for this.

Just add this to /etc/apache2/httdp.conf

#LoadModule directive to aid module installations
#LoadModule dummy_module /usr/lib/apache2/modules/mod_dummy.so

Then it wil be installed fine into httpd.conf.
03-31-2008 06:25 AM
Find all posts by this user Quote this message in a reply
Quemeros Offline
Junior Member
*

Posts: 86
Joined: Nov 2007
Reputation: 0
Post: #5
RE: mod_evasive, apxs:Error: Activation failed for custom /etc/apache2/httpd.conf
But i think that there a reason by the ispCP that httpd.conf it's empty, or not?
05-08-2008 12:36 PM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)