Current time: 01-18-2021, 11:23 PM Hello There, Guest! (LoginRegister)


Thread Closed 
RC4 testers needed
Author Message
bulforce Offline
Junior Member
*

Posts: 63
Joined: Oct 2007
Reputation: 0
Post: #11
RE: RC4 testers needed
I tried to upgrade to r1041 from some nightly build from the time of rc1 or rc2, but i ran into various problems. So now i trying to make a clean install, hopefully will work.

Currently i am stuck on the install screen, it says "Starting installation...". And also i cannot see any noticeable activity with "top". Any ideas?
(This post was last modified: 03-09-2008 10:46 AM by bulforce.)
03-09-2008 10:43 AM
Find all posts by this user
bulforce Offline
Junior Member
*

Posts: 63
Joined: Oct 2007
Reputation: 0
Post: #12
RE: RC4 testers needed
For some reason the r1041 leave my root user without any privileges in mysql, so i had to reinstall the mysql-server and attempt the install again. This time all was fine. However the /var/www/fcgi/master folder wasn't properly chown to vu2000:vu2000 so after changing it manually the daemon start functioning properly.

Thats for now, will report future issues if any when i meet them Smile
03-09-2008 12:12 PM
Find all posts by this user
RatS Offline
Project Leader
******

Posts: 1,854
Joined: Oct 2006
Reputation: 17
Post: #13
RE: RC4 testers needed
bulforce Wrote:root user without any privileges in mysql, so i had to reinstall the mysql-server
That's strange. Its not touched since RC2

bulforce Wrote:However the /var/www/fcgi/master folder wasn't properly chown to vu2000:vu2000
Maybe your folder was created another way than through the setup. I'll add an chown/chmod on it, if folder exists.
03-09-2008 06:46 PM
Visit this user's website Find all posts by this user
joximu Offline
helper
*****
Moderators

Posts: 7,024
Joined: Jan 2007
Reputation: 92
Post: #14
RE: RC4 testers needed
exactly theese two things (root in mysql corrupted, owner of fcgi/master) I already read in the forum in recent days.

Seems I have to do a fresh install...
03-09-2008 08:43 PM
Visit this user's website Find all posts by this user
bulforce Offline
Junior Member
*

Posts: 63
Joined: Oct 2007
Reputation: 0
Post: #15
RE: RC4 testers needed
Okay so the next thing i have notice was that even after the proper chown of fcgi/master, the resseler/rau3.php was producing a error 500. I couldn't get rid of it with restarting the apache and the ispcp_daemon. But after server reboot i was able to add users again.

However some of the domains wasnt created completely (errors 9 and 4), but this was because the users and the groups were already there from the previose rc2 install, so i had to remove those users manually from /etc/passwd and /etc/groups in order to create new users without problems.

Also, I am able to create mail users, but when i try to login into a mail acount i am getting this message:
ERROR: Connection dropped by IMAP server.

The mail log states this:
Mar 9 16:15:57 99centspage couriertcpd: authdaemon: s_connect() failed: No such file or directory


hopefully this is helpfull for you guys
(This post was last modified: 03-10-2008 06:14 AM by bulforce.)
03-10-2008 05:30 AM
Find all posts by this user
itanium Offline
Junior Member
*

Posts: 35
Joined: Apr 2007
Reputation: 0
Post: #16
RE: RC4 testers needed
Hello,

Quote:Also, I am able to create mail users, but when i try to login into a mail acount i am getting this message:
ERROR: Connection dropped by IMAP server.

The mail log states this:
Mar 9 16:15:57 99centspage couriertcpd: authdaemon: s_connect() failed: No such file or directory

In /etc/courier/authdaemonrc put:

Code:
##VERSION: $Id: authdaemonrc,v 1.3 2003/08/08 14:12:58 lisp Exp $
#
# Copyright 2000-2001 Double Precision, Inc.  See COPYING for
# distribution information.
#
# authdaemonrc created from authdaemonrc.dist by sysconftool
#
# Do not alter lines that begin with ##, they are used when upgrading
# this configuration.
#
# This file configures authdaemond, the resident authentication daemon.
#
# Comments in this file are ignored.  Although this file is intended to
# be sourced as a shell script, authdaemond parses it manually, so
# the acceptable syntax is a bit limited.  Multiline variable contents,
# with the \ continuation character, are not allowed.  Everything must
# fit on one line.  Do not use any additional whitespace for indentation,
# or anything else.

##NAME: authmodulelist:0
#
# The authentication modules that are linked into authdaemond.  The
# default list is installed.  You may selectively disable modules simply
# by removing them from the following list.  The available modules you
# can use are: authcustom authcram authuserdb authldap authpgsql authmysql authpam

authmodulelist="authuserdb"

##NAME: authmodulelistorig:1
#
# This setting is used by Courier's webadmin module, and should be left
# alone

authmodulelistorig="authcustom authcram authuserdb authldap authpgsql authmysql authpam"

##NAME: daemons:0
#
# The number of daemon processes that are started.  authdaemon is typically
# installed where authentication modules are relatively expensive: such
# as authldap, or authmysql, so it's better to have a number of them running.
# PLEASE NOTE:  Some platforms may experience a problem if there's more than
# one daemon.  Specifically, SystemV derived platforms that use TLI with
# socket emulation.  I'm suspicious of TLI's ability to handle multiple
# processes accepting connections on the same filesystem domain socket.
#
# You may need to increase daemons if as your system load increases.  Symptoms
# include sporadic authentication failures.  If you start getting
# authentication failures, increase daemons.  However, the default of 5
# SHOULD be sufficient.  Bumping up daemon count is only a short-term
# solution.  The permanent solution is to add more resources: RAM, faster
# disks, faster CPUs...

daemons=5

##NAME: version:0
#
# When you have multiple versions of authdaemond.* installed, authdaemond
# just picks the first one it finds.  Set "version" to override that.
# For example:  version=authdaemond.plain

version=""

##NAME: authdaemonvar:0
#
# authdaemonvar is here, but is not used directly by authdaemond.  It's
# used by various configuration and build scripts, so don't touch it!

authdaemonvar=/var/run/courier/authdaemon
03-10-2008 07:37 AM
Find all posts by this user
bulforce Offline
Junior Member
*

Posts: 63
Joined: Oct 2007
Reputation: 0
Post: #17
RE: RC4 testers needed
Itanium, thank you. Now it works.

One more thing that i have mentioned before, all the mail that is send to a valid user under the main domain(the one that is used during the installation) is bounced back with this error message:
Quote: The mail system

<admin@maindomain.com>: unknown user: "admin"

So what i am doing to get around this is to open /etc/postfix/main.cf

and replace:
myhostname = maindomain.com

with:
myhostname = mail.maindomain.com

Then restart the postfix and the mails send to users under this domain are going thru as the all others.
(This post was last modified: 03-10-2008 08:52 AM by bulforce.)
03-10-2008 08:34 AM
Find all posts by this user
Kika Offline
Member
***

Posts: 293
Joined: Feb 2007
Reputation: 8
Post: #18
RE: RC4 testers needed
I have some permission denied problem with nightly 2008-03-09.

The postfix is working, but the courier (pop3 and imap) has permission denied

Code:
Mar 10 06:11:26 www couriertcpd: kalman@domain.tld: chdir(/var/mail/virtual/domain.tld/kalman) failed!!
Mar 10 06:11:26 www couriertcpd: error: Permission denied
Mar 10 06:11:26 www couriertcpd: LOGIN FAILED, user=kalman@domain.tld, ip=[::ffff:127.0.0.1]
Mar 10 06:11:26 www couriertcpd: authentication error: Permission denied
Code:
Mar 10 06:11:29 www courierpop3login: kalman@domain.tld: chdir(/var/mail/virtual/domain.tld/kalman) failed!!
Mar 10 06:11:29 www courierpop3login: error: Permission denied
Mar 10 06:11:29 www courierpop3login: LOGIN FAILED, user=kalman@domain.tld, ip=[::ffff:84.0.208.85]
Mar 10 06:11:29 www courierpop3login: authentication error: Permission denied
the owner of the directory /var/mail/virtual/domain.tld/kalman is vmail:mail (drwxr-xr-x)

Other problem is the domain status. When i logged in into the ispCP than i see that my domains are stoped (all domains are works). I click to the status icon and than i give this error:

store_file() | ERROR: Undefined input data, fname: |/etc/awstats/awstats.domain.tld.conf|, fdata, fuid: '', fgid: '', fperms: '420'


On my other server i found an error in the nightly 2008-02-28 too. When i create a domain the system can't create the default mail addresses, but try to create again and again.
(This post was last modified: 03-10-2008 10:23 PM by Kika.)
03-10-2008 03:25 PM
Find all posts by this user
joximu Offline
helper
*****
Moderators

Posts: 7,024
Joined: Jan 2007
Reputation: 92
Post: #19
RE: RC4 testers needed
this may be the courier authdaemonrc setting.
See http://www.isp-control.net/ispcp/ticket/1100

is solved in the trunk from today

/J
03-10-2008 07:35 PM
Visit this user's website Find all posts by this user
Kika Offline
Member
***

Posts: 293
Joined: Feb 2007
Reputation: 8
Post: #20
RE: RC4 testers needed
I done an upgrade only, didn't run the setup script and before the upgrade the mail sevices worked. So i think this error caused by other things.

I created an automatic setup script for nightly upgrades, but this script upgrade the /var/www/ispcp and the database status only and run the set-engine-permission.sh and the set-gui-permission.sh. I also upgraded my ispcp.conf, but i think this does not contain wrong entry :S
03-10-2008 07:53 PM
Find all posts by this user
Thread Closed 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)