Current time: 10-04-2022, 05:03 PM Hello There, Guest! (LoginRegister)


Post Reply 
How to change script timeout settings?
Author Message
zabersoft Offline
Junior Member
*

Posts: 14
Joined: Apr 2008
Reputation: 0
Post: #1
How to change script timeout settings?
Hi,

I thought I'd create a new thread as the other one was getting rather large and the headline no longer fit the question.
(http://www.isp-control.net/forum/curl-cr...3082.html)

Here's the problem:

- Server is killing a slow script (it's performing a lengthy curl request) after 30 seconds. All the end user sees is a HTTP 500 error - And there is no indication of what happened in the Apache error log.

All other possibilites have been investigated however - and I am fairly certain the script is simply timing out.

What I have tried:

php.ini
max_execution_time = 300

httpd.conf
Timeout 300

and setting
curl_setopt($curl_session, CURLOPT_CONNECTTIMEOUT, 300);
curl_setopt($curl_session, CURLOPT_TIMEOUT, 600);

I'm using the standard fastcgi and I have changed php ini for both php4 and php5 on the domain in question in /var/www/fcgi etc.

In addition to this I changed php.ini for mod_php just for safety sake.

Result:

Nothing I have done is working. The script still dies after 30 seconds. Also, as a side question I get this when I run phpinfo()

Configuration File (php.ini) Path /etc/php5/cgi
Loaded Configuration File /var/www/fcgi/xxxx.dk/php4/php.ini
Scan this dir for additional .ini files /etc/php5/cgi/conf.d

Why is it using php4 ini when php5 is loaded?


Thanks! Smile

- Zaber
04-30-2008 02:25 AM
Find all posts by this user Quote this message in a reply
zabersoft Offline
Junior Member
*

Posts: 14
Joined: Apr 2008
Reputation: 0
Post: #2
RE: How to change script timeout settings?
Ping! ... I'm still wondering about this one ...
11-20-2008 02:38 AM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)