Current time: 12-08-2021, 10:37 PM Hello There, Guest! (LoginRegister)


Post Reply 
Internal Server Error
Author Message
systray Offline
Newbie
*

Posts: 5
Joined: Mar 2007
Reputation: 0
Post: #1
Internal Server Error
Hi,

I sometimes got an error "Internal Server Error" after the Login-Page. (I would login and then I waited more than a minute)
But the most time, I can login. I restarted apache2 but it doesn't matter. Loggs didn't say anything usable

Cheers.
04-16-2007 01:12 AM
Find all posts by this user Quote this message in a reply
BeNe Offline
Moderator
*****
Moderators

Posts: 5,899
Joined: Jan 2007
Reputation: 68
Post: #2
RE: Internal Server Error
Is your Machine OK ?
High Server Load at this time ? Or full Memory ?
04-16-2007 04:38 AM
Visit this user's website Find all posts by this user Quote this message in a reply
systray Offline
Newbie
*

Posts: 5
Joined: Mar 2007
Reputation: 0
Post: #3
RE: Internal Server Error
BeNe Wrote:Is your Machine OK ?
High Server Load at this time ? Or full Memory ?

No, nothing at all. It's only 125 MB of RAM used. Load is near 0

Cheers.
04-16-2007 04:53 AM
Find all posts by this user Quote this message in a reply
adigit Offline
Junior Member
*

Posts: 68
Joined: Apr 2007
Reputation: 0
Post: #4
RE: Internal Server Error
I believe that there should be some clues in the logs, maybe you check again or post it here
04-16-2007 08:28 PM
Visit this user's website Find all posts by this user Quote this message in a reply
ephigenie Offline
Project Leader
*******
Administrators

Posts: 1,578
Joined: Oct 2006
Reputation: 15
Post: #5
RE: Internal Server Error
mh perhaps you can shift the timeouts in your /etc/apache2/mods_available/fastcgi.conf a bit - so that php - processes may not be killed so fast.

The settings are a bit aggressive - so on slow machines php may not be started fast enough if there's actually no process under the current user.

I'd that on another VPS, too altough the server itself was fast - the io was a bit too slow. After i set it to :
Code:
FastCgiConfig -minProcesses 1 -maxProcesses 20 -singleThreshold 80  -killInterval 6000  -idle-timeout 4800 -pass-header HTTP_AUTHORIZATION
there were no more complaints about error 500...
04-16-2007 09:10 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)