Current time: 10-18-2021, 09:16 PM Hello There, Guest! (LoginRegister)


Post Reply 
Fallos en Maia Installer
Author Message
djtenssy Offline
Junior Member
*

Posts: 85
Joined: Jun 2008
Reputation: 0
Post: #1
Sad Fallos en Maia Installer
Hola a todos.
He intentado ya varias veces instalar Maia, pero siempre tira errores. La última vez que lo he hecho y corregido las rutas en php.ini, no podía acceder a login.php?super=register, porque decía DB Error: connect failed. Creo que hay algún punto donde no instala algo o no en su sitio correcto. Decir que lo intenté con el script de instalación y que tuve que corregir la descarga de Smarty, porque no la coge ya.
Desinstalé todo apt-get remove --purge, e intenté de nuevo, pero si no falla una cosa falla otra, de hecho la última vez se quedó colgado intentando arrancar el proceso de amavis. Ahora ya me dice el sistema que tengo dependencia incumplidas con amavis, spamassassin, etc, todo esto después de corregir también el dpkg.
En la prueba de configtest me sale FAILED: Could not connect to database. Check the $maia_sql_dsn setting in config.php.
Algún voluntario que me pueda echar una mano? Sad

PD. Mi sistema es un Debian Etch
09-10-2008 11:24 PM
Visit this user's website Find all posts by this user Quote this message in a reply
victor531 Offline
Junior Member
*

Posts: 167
Joined: Oct 2007
Reputation: 3
Post: #2
RE: Fallos en Maia Installer
Hola, lo primero que debes hacer es verificar que tienes todo bien instalado, por lo que primero vamos a ver el tema del SO

1.- Revisa tu sources.list ( si la puedes pegar aqui)
2.- Actualiza apt-get update ; apt-get upgrade
3.- Revisa que todo este bien; apt-get check
4.- Si todo esta bien, reinstala lo que desinstalaste , ya que no mencionas que es "todo"
La forma de hacerlo es ;apt-get -–reinstall install amavis (o spamassasin, o lo que debas reinstalar, revisa bien los paquetes que se instalan , esto lo puedes ver en el How to http://www.isp-control.net/documentation...omega_rc3)
5.- Si no esta todo bien y tienes problemas de dependencias, realiza el comando ; apt-get -f install.
Este comando con un sources.list correctamente configurado te debiera dar un resultado sin dependencias rotas y te debiera mostrar algo como esto

# apt-get -f install
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias...
Hecho 0 actualizados, 0 se instalarán, 0 para eliminar y 13 no actualizados.
Esto es propio de linux mas que del panel.
Despues que tengas esto arreglado, vamos por el tema de la configuración de Maia.

Suerte

Victor
09-11-2008 12:35 AM
Find all posts by this user Quote this message in a reply
djtenssy Offline
Junior Member
*

Posts: 85
Joined: Jun 2008
Reputation: 0
Post: #3
RE: Fallos en Maia Installer
Hola Victor, gracias por tu pronta respuesta.
En primer lugar, mi sources es esta:

deb ftp://mir1.ovh.net/debian/ etch main
deb-src ftp://mir1.ovh.net/debian/ etch main

deb http://security.debian.org/ etch/updates main
deb-src http://security.debian.org/ etch/updates main

deb http://ftp.de.debian.org/debian etch main contrib non-free
deb http://security.debian.org/ etch/updates main contrib non-free

un apt-get update sin problemas
apt-get upgrade me dice que hay dependencias incumplidas en amavisd-new, clamav-daemon, libclamav2, libcurl3, libssl0.9.8 y spamassassin.
apt-get -f install me pide instalar los paquete, los descarga y al final tira
id: clamav: no existe este usuario
dpkg no registrado como instalado...
error al procesar /var/cache/apt/archives/zlib1g_1%3a1.2.3-13_i386.deb.....
dpkg-divert: fallo al abrir fichero de desvios: No existe el fichero o directorios.
Y lo mismo con coreutils_5.97-5.3_i386.deb
sub-process /usr/bin/dpkg returned an error code (1)

Seguiré probando a reinstalar, a ver si va esto, pero en principio a ver si me puedes indicar alguna solución también.
Gracias y salu2.
(This post was last modified: 09-11-2008 01:46 AM by djtenssy.)
09-11-2008 01:41 AM
Visit this user's website Find all posts by this user Quote this message in a reply
victor531 Offline
Junior Member
*

Posts: 167
Joined: Oct 2007
Reputation: 3
Post: #4
RE: Fallos en Maia Installer
Tu fuente de listas se ve bien, lo que se ve mal es que aparentemente borraste algunos componentes del dpkg, intenta instalarlo nuevamente, cuando tengas eso resuelto veremos que podemos hacer, insisto que primero repares tu debian y su dependencias que no es propio del panel , ......... ...google es buen ayudante.

Victor
09-11-2008 06:39 AM
Find all posts by this user Quote this message in a reply
djtenssy Offline
Junior Member
*

Posts: 85
Joined: Jun 2008
Reputation: 0
Post: #5
RE: Fallos en Maia Installer
En primer lugar gracias por responder tan rápido Victor. Al final he tenido que hacer un backup de lo que no tenía y formatear el server, estaba todo cascado.
Lo tengo instalado de nuevo, como antes, con Etch. Acabo de corregir algunos problemillas de la versión 1.0.0-rc6, como el proftpd, que no cogía el uid y gid mínimo, y otras cosillas.
En el panel de admin, en settings_ports me aparece esto:
')" class="link">Eliminar
en lugar de un botón o selector, no sé seguro qué era. Alguna idea para resolverlo? he mirado en los foros, pero no acabo de verlo claro.
Por otra parte, me da miedo ya de instalar de nuevo el maia, porque la verdad, es la tercera vez que formateo el server, y esta vez lo tenía con varias webs alojadas, he tenido que decir a los clientes que estaría toda la noche offline Rolleyes
Podría alguien pegar las rutas que tiene configuradas en el php.ini? es que es una de las cosas que suele fallar, y la otra es que el clamav (creo que era), cuando intenta arrancar se queda pillado y ahí acaba todo. Si sigo después instalando el maia, da fallos.
Esta última vez lo hice con el script, pero me falló las rutas de php.
Alguna sugerencia para que esta vez salga todo bien???
Gracias y salu2.
(This post was last modified: 09-12-2008 03:01 AM by djtenssy.)
09-12-2008 03:00 AM
Visit this user's website Find all posts by this user Quote this message in a reply
kurgans Offline
Moderator
*****
Moderators

Posts: 1,565
Joined: Feb 2008
Reputation: 23
Post: #6
RE: Fallos en Maia Installer
Sigue este howto a mi me fue a la perfeccion, no tienes nada mas que copiar y pegar en la consola y va de lujo
http://www.isp-control.net/documentation..._omega_rc3
09-13-2008 05:13 AM
Visit this user's website Find all posts by this user Quote this message in a reply
djtenssy Offline
Junior Member
*

Posts: 85
Joined: Jun 2008
Reputation: 0
Post: #7
RE: Fallos en Maia Installer
Gracias Kurgans
Ya lo hice a través del script, corrigiendo antes las rutas de php, y alguna que otra cosa más. Ahora no me arranca el clamav, se queda colgado y me dice clamd running as user clamav, y ahí se queda.
Por otro lado, cuando he intentado el super=register en el maia, siempre me da error de login.
Y me he dado cuenta que el puerto del spamassassin está abajo, tiene eso algo que ver también.
Salu2.
09-13-2008 05:54 AM
Visit this user's website Find all posts by this user Quote this message in a reply
djtenssy Offline
Junior Member
*

Posts: 85
Joined: Jun 2008
Reputation: 0
Post: #8
RE: Fallos en Maia Installer
Ya vamos avanzando.
He corregido muchos problemas en la instalación con el script de maia, que he tenido que hacer a mano. Cuando tuve que reiniciar clamav-daemon lo hizo sin problemas, pero al final, con todo funcionando me vuelve a hacer lo mismo, clamd running as user clamav y ahí se queda pensando.
He mirado en el webmin, en la cola del postfix, y se quedan los mensajes atascados, ni siquiera con un flush salen.
Además, en el panel de control del ispcp, en server ports, a la derecha, en acciones me aparece en algunas líneas esto:
')" class="link">Eliminar
concretamente en amavis y spamassassin salen, además de estar el puerto de spamassassin (783) abajo.
Alguna sugerencia???
Gracias y salu2.
(This post was last modified: 09-13-2008 08:21 AM by djtenssy.)
09-13-2008 08:16 AM
Visit this user's website Find all posts by this user Quote this message in a reply
victor531 Offline
Junior Member
*

Posts: 167
Joined: Oct 2007
Reputation: 3
Post: #9
RE: Fallos en Maia Installer
hi djtenssy
Perdona pero no estaba en la ciudad, acabo de ver tus nuevos problemas , me parece que debes hacer a mano el porocedimiento según el howto para ello.
Analicemo lo siguiente :
" pero al final, con todo funcionando me vuelve a hacer lo mismo, clamd running as user clamav y ahí se queda pensando."
Me parce raro , ya que ese usuario clamav que se crea es el usuario del grupo AMAVIS, y el usuario general es AMAVIS con su contraseña propia, asi que verifica que este usuario este creado en la BD con PMA (debes ingresar como root), si no existe debes crearlo
# usermod -G amavis clamav
# passwd amavis
# chsh -s /bin/false amavis
Pero primero verifica que no este creado

"Además, en el panel de control del ispcp, en server ports, a la derecha, en acciones me aparece en algunas líneas esto:
')" class="link">Eliminar..."
Me parce que faltan algunos simbolos en el template , no se mucho de php , pero una persona que conozca esto, aunque sea poco te puede ayudar.

"concretamente en amavis y spamassassin salen, además de estar el puerto de spamassassin (783) abajo."

Tienes algun firewall funcionando que cierra los puertos? , si no , me parce que esto solo indica los estados de los puertos que tu mismo seteas en el panel del admin de ISPCP.

Ojala te sirva de alguna ayuda, si no , te recomiendo seguir los pasos uno a uno de este howto , lo que este hecho , el mismo sistema te lo ira indicando. / http://www.isp-control.net/documentation..._omega_rc3

Suerte

Victor
09-13-2008 09:08 AM
Find all posts by this user Quote this message in a reply
djtenssy Offline
Junior Member
*

Posts: 85
Joined: Jun 2008
Reputation: 0
Post: #10
RE: Fallos en Maia Installer
Hola Victor531
Ya tengo resuelto un problema, el clamav, que al final resulta ser que la vesión estable que se instala es la 0.92 y tiene un bug, además de no poder conectar con la db de virus. He actualizado a la 0.94 y todo va estupendo, la cola del postfix de maravilla.
Seguiremos con el resto, ya te comentaré.
Salu2.
09-13-2008 08:09 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)