Current time: 06-28-2022, 09:19 AM Hello There, Guest! (LoginRegister)


Post Reply 
[SOLVED] Bug , fail to create new user Again..
Author Message
v3ss0n Offline
Junior Member
*

Posts: 11
Joined: Sep 2008
Reputation: 0
Post: #1
[SOLVED] Bug , fail to create new user Again..
Hello ISPCP

I need urgent help..

Last time i posted the same problem , now it happens again ..
I tried to fix it by removing everything and reinstall from scratch but now it happens again.

Distro is Debian linux - Lenny.

ISPCP fails to add user ,1.0.0.RC6

When i am adding new user from reseller , to create new domain it fails with when i check details , it saids Unknown Error in status.

When i check /etc/passwd , there is nothing about new user in there.
Also there is no new Virtual Host created

I am using it in production enviorment .. Please help.. I cannot add any new customers ..

There is no log to check for ispcp too which is very bad..
(This post was last modified: 09-22-2008 02:48 AM by BeNe.)
09-20-2008 05:40 PM
Find all posts by this user Quote this message in a reply
v3ss0n Offline
Junior Member
*

Posts: 11
Joined: Sep 2008
Reputation: 0
Post: #2
RE: Bug , fail to create new user Again..
When i restart the server.

i found this :

is that because of it?

Starting inbound DomainKeys-filter: dkimproxy.in/sbin/start-stop-daemon: stat /usr/sbin/dkimproxy.in: No such file or directory (No such file or directory)
failed!
Not starting internet superserver: no services enabled. (warning).
Starting Postfix Mail Transport Agent: postfix.
Starting SASL Authentication Daemon: saslauthdNo run directory defined for saslauthd, not starting failed!
Starting OpenBSD Secure Shell server: sshd.
09-20-2008 05:54 PM
Find all posts by this user Quote this message in a reply
v3ss0n Offline
Junior Member
*

Posts: 11
Joined: Sep 2008
Reputation: 0
Post: #3
RE: Bug , fail to create new user Again..
now DKIMporxy is ok , but SASL is not .. pls how to configure SASL to work
09-20-2008 06:50 PM
Find all posts by this user Quote this message in a reply
v3ss0n Offline
Junior Member
*

Posts: 11
Joined: Sep 2008
Reputation: 0
Post: #4
RE: Bug , fail to create new user Again..
I think ISPCP dont support Lenny?

There is no SASL config for lenny
09-20-2008 06:53 PM
Find all posts by this user Quote this message in a reply
sci2tech Away
Senior Member
****

Posts: 1,285
Joined: Jan 2007
Reputation: 23
Post: #5
RE: Bug , fail to create new user Again..
Im using debian lenny with ispcp on 3 boxes and 1 is a productive server. It work perfectly. SASL is used to add new user to postfix. Can you enable debug (in /etc/ispcp/ispcp.conf DEBUG=1) then try to add new user and post here output from /var/log/ispcp*.err?
09-20-2008 07:13 PM
Visit this user's website Find all posts by this user Quote this message in a reply
v3ss0n Offline
Junior Member
*

Posts: 11
Joined: Sep 2008
Reputation: 0
Post: #6
RE: Bug , fail to create new user Again..
thanks a lot!!!
ok i will see the debug.
09-20-2008 07:52 PM
Find all posts by this user Quote this message in a reply
v3ss0n Offline
Junior Member
*

Posts: 11
Joined: Sep 2008
Reputation: 0
Post: #7
RE: Bug , fail to create new user Again..
I just remove ispcp and apt-get --purge remove apache , php
and re install all. works ok now..

I dont know why it is happening.

Anyways , Can you guys show me what kind of trouble-shooting commands , scripts avaliable for ispcp please ?
09-21-2008 03:00 AM
Find all posts by this user Quote this message in a reply
v3ss0n Offline
Junior Member
*

Posts: 11
Joined: Sep 2008
Reputation: 0
Post: #8
RE: Bug , fail to create new user Again..
Now i am sure it happens when a reseller creates more than 2 domains

There is no such var/log/ispcp*.err

but under /var/log/ispcp/:

spcp-arpl-msgr/ ispcp_daemon-stderr.log.1221928561 ispcp_daemon-stdout.log.1221928561
ispcp-dmn-mngr.stderr ispcp_daemon-stderr.log.1221929543 ispcp_daemon-stdout.log.1221929543
ispcp-dmn-mngr.stdout ispcp_daemon-stderr.log.1221938433 ispcp_daemon-stdout.log.1221938433
ispcp-mbox-mngr.stderr ispcp_daemon-stderr.log.1221938541 ispcp_daemon-stdout.log.1221938541
ispcp-mbox-mngr.stdout ispcp_daemon-stderr.log.1221938613 ispcp_daemon-stdout.log.1221938613
ispcp-serv-mngr.stderr ispcp_daemon-stderr.log.1221938642 ispcp_daemon-stdout.log.1221938642
ispcp-serv-mngr.stdout ispcp_daemon-stderr.log.1221938698 ispcp_daemon-stdout.log.1221938698
ispcp_daemon-stderr.log.1221928355 ispcp_daemon-stdout.log.1221928355 ispcp_network.log
09-21-2008 05:28 AM
Find all posts by this user Quote this message in a reply
v3ss0n Offline
Junior Member
*

Posts: 11
Joined: Sep 2008
Reputation: 0
Post: #9
RE: Bug , fail to create new user Again..
FINALLY IT WORKED! thankyou!!

v3ss:/var/log/ispcp# cat ispcp-dmn-mngr.stderr
groupadd: group vu2005 exists
v3ss:/var/log/ispcp# delgroup vu2005
Removing group `vu2005' ...
Done.


AFter that i can able to add wooo!!!
(This post was last modified: 09-21-2008 05:36 AM by v3ss0n.)
09-21-2008 05:35 AM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)