Current time: 07-04-2020, 12:24 PM Hello There, Guest! (LoginRegister)


Post Reply 
Instalacja na Ubuntu 8.10
Author Message
ugo Offline
Junior Member
*

Posts: 10
Joined: Dec 2008
Reputation: 0
Post: #1
Instalacja na Ubuntu 8.10
Witam, czy ktoś może podać dokładnie jak zainstalować ispcp na czystym ubuntu 8.10? Zawsze po rozpoczęciu instalacji wyskakują jakieś błędy, już 7 razy przeinstalowałem ubuntu i za każdym razem to samo Sad

Czy trzeba dodać jakieś konkretne źródła lub coś doinstalować żeby instalacja zakończyła się sukcesem?
12-22-2008 09:19 AM
Find all posts by this user Quote this message in a reply
Alex Joe Offline
Junior Member
*

Posts: 72
Joined: Oct 2007
Reputation: 0
Post: #2
RE: Instalacja na Ubuntu 8.10
A odwiedziłeś dział Documentation? A konkretnie http://www.isp-control.net/documentation...ion/ubuntu ?

Jeśli tak, to opisz jakie błędy Ci wyskakują, wtedy coś poradzimy. Jeśli nie - zapoznaj się najpierw z tą instrukcją, i jeśli władasz językiem angielskim przeszukaj na forum dział installation (pod hasłem ubuntu znalazłem kilka wątków dotyczących problemów z instalacją na tej dystrybucji linuxa).
(This post was last modified: 12-23-2008 05:29 AM by Alex Joe.)
12-23-2008 05:28 AM
Visit this user's website Find all posts by this user Quote this message in a reply
ugo Offline
Junior Member
*

Posts: 10
Joined: Dec 2008
Reputation: 0
Post: #3
RE: Instalacja na Ubuntu 8.10
Starting Installation...
* Stopping domain name service... bind9 [ OK ]
Enabling site ispcp.conf.
Run '/etc/init.d/apache2 reload' to activate new configuration!
Enabling site 00_master.conf.
Run '/etc/init.d/apache2 reload' to activate new configuration!
* Starting domain name service... bind9 Site default disabled.
Run '/etc/init.d/apache2 reload' to activate new configuration!
ERROR: Module fastcgi_ispcp does not exist!
Enabling module rewrite.
Run '/etc/init.d/apache2 restart' to activate new configuration!
Enabling module actions.
Run '/etc/init.d/apache2 restart' to activate new configuration!
Module cgi already enabled
ERROR: Module fcgid does not exist!
ERROR: Module fcgid_ispcp does not exist!
Enabling module suexec.
Run '/etc/init.d/apache2 restart' to activate new configuration!
ERROR: Module fastcgi does not exist!
[ OK ]
ERROR: Module php4 does not exist!
Module php5 disabled.
Run '/etc/init.d/apache2 restart' to activate new configuration!
Warning: SuexecUserGroup directive requires SUEXEC wrapper.
[Wed Dec 24 10:44:08 2008] [warn] NameVirtualHost *:80 has no VirtualHosts
sh: /etc/init.d/courier-authdaemon: not found
sh: /etc/init.d/courier-imap: not found
sh: /etc/init.d/courier-pop: not found
* Stopping Postfix Mail Transport Agent postfix Can't exec "/usr/sbin/makeuserdb": No such file or directory at /var/www/ispcp/engine/setup/../ispcp_common_methods.pl line 756.
ERROR: External command '/usr/sbin/makeuserdb' returned '16777215' status !
root@hg-desktop:/var/www/ispcp/engine/setup# * Starting Postfix Mail Transport Agent postfix [ OK ]
[ OK ]

Instaluje dokładnie wg instrukcji.
12-24-2008 07:49 PM
Find all posts by this user Quote this message in a reply
ugo Offline
Junior Member
*

Posts: 10
Joined: Dec 2008
Reputation: 0
Post: #4
RE: Instalacja na Ubuntu 8.10
OK, zainstalowałem już wszystko ale nie mogę wejść do admina ani do żadnej innej strony pisze Error 404.

Co trzeba doinstalować do czystego ubuntu 8.10?

- bind9
- courier
- postfix
- proftpd
- suexec
- LAMB

coś jeszcze?
12-24-2008 11:13 PM
Find all posts by this user Quote this message in a reply
Alex Joe Offline
Junior Member
*

Posts: 72
Joined: Oct 2007
Reputation: 0
Post: #5
RE: Instalacja na Ubuntu 8.10
(12-24-2008 11:13 PM)ugo Wrote:  ERROR: Module fastcgi_ispcp does not exist!
Enabling module rewrite.
Run '/etc/init.d/apache2 restart' to activate new configuration!
Enabling module actions.
Run '/etc/init.d/apache2 restart' to activate new configuration!
Module cgi already enabled
ERROR: Module fcgid does not exist!
ERROR: Module fcgid_ispcp does not exist!
Enabling module suexec.
Run '/etc/init.d/apache2 restart' to activate new configuration!
ERROR: Module fastcgi does not exist!
[ OK ]
ERROR: Module php4 does not exist!

Z powyższego widzę, że nie masz modułów do Apache. Trzeba doinstalować moduły obsługi php4 , fcgid, fastcgi (na forum był gdzieś post w angielskim o różnicach między tymi modułami, ja wybrałem fcgid).
12-27-2008 08:46 PM
Visit this user's website Find all posts by this user Quote this message in a reply
ugo Offline
Junior Member
*

Posts: 10
Joined: Dec 2008
Reputation: 0
Post: #6
RE: Instalacja na Ubuntu 8.10
OK, rozwiązałem problem i zainstalowałem ispcp. Wszystko działa (chociaż ftp działa tylko na debianie nie wiem czemu na ubuntu nie chce mimo bez błędnej instalacji).

Przy setupie podaje domene servera czyli debian.example.com potem prosi o podanie ścieżki do admina czyli admin.debian.example.com potem adres servera itd. Jednak po instalacji panel jest dostępny tylko pod adresem servera. W przeglądarce wpisuje http://10.0.0.30 bo (admin.)debian.example.com nie działa. Nie moge dostać się też do kont użytkowników. Jak to skonfigurować poprawnie?
01-09-2009 07:56 AM
Find all posts by this user Quote this message in a reply
artek Offline


Posts: 4
Joined: Jul 2009
Reputation: 0
Post: #7
RE: Instalacja na Ubuntu 8.10
Jeśli chodzi o błąd z modułami do apache to u mnie też był i jakoś wszystko działało Tongue

Co do ftp to spróbuj ręcznie zrestartować serwer ftp (proftpd?) i wyskoczy Ci błąd Smile Chodzi o to, że jeden moduł jest dwa razy ładowany i przez to się wysypuje. W komunikacie będzie który plik (niestety ja nie pamiętam), to po prostu zachaszuj tę linie i pójdzie Smile

EDIT:

Z tego co widziałem to błąd z konfiguracją już naprawili. Także na najnowszym snapshocie powinno śmigać.
(This post was last modified: 08-21-2009 04:04 PM by artek.)
08-09-2009 07:03 AM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)