Current time: 06-19-2018, 02:32 PM Hello There, Guest! (LoginRegister)


Poll: Describe the results after testing ispCP v1.0.0
This poll is closed.
Fresh Installation went smooth. 42.42% 14 42.42%
Update from RC went smooth. 42.42% 14 42.42%
Update from VHCS went smooth. 12.12% 4 12.12%
I found a bugs. Tell us more! 3.03% 1 3.03%
Total 33 votes 100%
* You voted for this item. [Show Results]

Thread Closed 
ISPCP v1.0.0 stable is ready, testers needed
Author Message
sci2tech Away
Senior Member
****

Posts: 1,285
Joined: Jan 2007
Reputation: 23
Post: #1
ISPCP v1.0.0 stable is ready, testers needed
Today's nightly build will become the final release of ispCP v1.0.0 Stable.
You can grab the latest nightly builds from:
http://www.isp-control.net/download.html

Please test the package thoroughly. We expect you to install on a fresh system, update from previous version of ispCP Omega as well as update from VHCS. If you encounter any errors, be sure to mention them here or in the bug tracker. The more people testing, the quicker we can get an official release out the door.

Here are some of the things you can help us with as a starting point:

Upgrade tests from:
- vhcs 2.4.7.1
- vhcs 2.4.8
- RC2
- RC3
- RC4
- RC5
- RC6
- RC7

Functional tests:
- domains
- subdomains
- alias domains
- alias subdomains
- htaccess
- mailboxes
- autoresponder
- forwarders
- crypted passwords?

Any questions? Don't hesitate to ask. Don't forget to make a backup before install / update.

ispCP v1.0.0 is feature frozen - please only report bugs here. As soon v1.0.0 is out we will start working on v1.0.1 with more features added. No feature requests are allowed here. Feature requests can be made in the wish list.
(This post was last modified: 02-19-2009 04:13 PM by BioALIEN.)
02-16-2009 07:12 PM
Visit this user's website Find all posts by this user
tango Offline
Member
***

Posts: 461
Joined: Jun 2007
Reputation: 0
Post: #2
RE: ISPCP v1.0.0 stable is ready, testers needed
Have freshly installed debian Lenny and the current Trunk 20090216 trying to install
.
During the make install procedure is an error of
for over half hour it counts continue uninterrupted.

here a screenshot

http://www.alleslegal.net/16.02.png
02-16-2009 08:10 PM
Find all posts by this user
alecksievici Offline
Junior Member
*
Beta Team

Posts: 112
Joined: May 2008
Reputation: 0
Post: #3
RE: ISPCP v1.0.0 stable is ready, testers needed
Just did a fresh install on debian lenny with ispcp-omega-trunk-20090216.tar.bz2 and everything worked fine.

But, there is a bug in the Client/Manage SQL - http://img.greenbit.ro/uploads/36295dbec...bb54dc.jpg and i think it has to do with this bug - http://www.isp-control.net/ispcp/ticket/1649

Everything else seems to work as it should.
02-16-2009 08:31 PM
Visit this user's website Find all posts by this user
Zothos Offline
Release Manager
*****
Dev Team

Posts: 1,262
Joined: Feb 2007
Reputation: 10
Post: #4
RE: ISPCP v1.0.0 stable is ready, testers needed
Also, please test the upgrades from vhcs 2.4.7.1 and 2.4.8. I will post a howto test the upgrades howto soon Smile
02-16-2009 09:56 PM
Find all posts by this user
emil_arkman Offline


Posts: 2
Joined: Feb 2009
Reputation: 0
Post: #5
RE: ISPCP v1.0.0 stable is ready, testers needed
Hi!

I Just installed in on Deb 5.0 and clicked around a bit:


Created an admin and logged in as that admin.

Created a reseller and logged in as that reseller.

Created a hosting plan that allows for 1 DB + 1 DB user.

Created a user with the above hosting plan and logged in as that user.

Created a DB and a DB user.

Clicked ManageSql -> Action -> phpMyAdmin ...
... boom:

----------------------------

Error 500!

/client/sql_auth.php
Internal Server Error!

----------------------------

The PhpMyAdmin link to the left works allright though, so I guess it is just some auto login feature that is broken?


I might also add that logging in takes a few more seconds than I would expect regardless of account role.


Other than that, this is sooooo good I almost wet my pants a bit while playing around Big Grin

Cheers,
Emil

Edit: I installed from isp-control-20090216.tar.gz
(This post was last modified: 02-16-2009 10:58 PM by emil_arkman.)
02-16-2009 10:56 PM
Find all posts by this user
sci2tech Away
Senior Member
****

Posts: 1,285
Joined: Jan 2007
Reputation: 23
Post: #6
RE: ISPCP v1.0.0 stable is ready, testers needed
@emil_arkman: Please test that your BASE_SERVER_VHOST can be resolved by server. Value for BASE_SERVER_VHOST can be found in /etc/ispcp/ispcp.conf. If not consiter adding 127.0.0.1 to your /etc/resolv.conf
02-16-2009 11:15 PM
Visit this user's website Find all posts by this user
itanium Offline
Junior Member
*

Posts: 35
Joined: Apr 2007
Reputation: 0
Post: #7
RE: ISPCP v1.0.0 stable is ready, testers needed
Hello,

Debian Lenny with last trunk -> Ok (250 users) with no problem.

Traffic for admin, reseller and client bug but the fix is for 1.0.1?

Great job! Wink

Ps: I am looking for the last little bugs.
02-17-2009 01:38 AM
Find all posts by this user
BioALIEN Offline
Public Relations Officer
*****
Dev Team

Posts: 620
Joined: Feb 2007
Reputation: 5
Post: #8
RE: ISPCP v1.0.0 stable is ready, testers needed
I've modified the announcement with some tips on what we are looking for and hints on what to test.

We welcome more reports from the community.
02-17-2009 03:21 AM
Find all posts by this user
CHBIE Offline
Junior Member
*

Posts: 225
Joined: May 2008
Reputation: 11
Post: #9
RE: ISPCP v1.0.0 stable is ready, testers needed
Errors in German http://www.isp-control.net/forum/showthr...p?tid=5734

Gruss CHBIE
02-17-2009 05:11 AM
Visit this user's website Find all posts by this user
sci2tech Away
Senior Member
****

Posts: 1,285
Joined: Jan 2007
Reputation: 23
Post: #10
RE: ISPCP v1.0.0 stable is ready, testers needed
(02-17-2009 05:11 AM)CHBIE Wrote:  Errors in German http://www.isp-control.net/forum/showthr...p?tid=5734

Gruss CHBIE
Thank you for your report. But was only 1 bug -> Language uninstall is always the previous uninstalled.
Logs not being translated is not a bug, but an enhancement. Please open a ticket for V1.0.1
For the rest you need to update you language table from database (this is not performed automatically on update).
02-17-2009 06:11 AM
Visit this user's website Find all posts by this user
Thread Closed 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)