Current time: 10-05-2022, 06:52 PM Hello There, Guest! (LoginRegister)


Post Reply 
Can´t receive Mails in trunk #639 ?!
Author Message
BeNe Offline
Moderator
*****
Moderators

Posts: 5,899
Joined: Jan 2007
Reputation: 68
Post: #1
Question Can´t receive Mails in trunk #639 ?!
Hello,

i tested the trunk #639 and i am not able to receive E-Mails.
The E-Mail always comes back:

Code:
This is the mail system at host mydomain.tld

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                   The mail system

<test@mydomain.tld>: unknown user: "test"

But there is a user test@mydomain.tld on my System:

Code:
# cat /etc/postfix/ispcp/aliases

# MTA Managment Virtual Aliases List;
#
# Please do NOT edit it manually;
#
test@mydomain.tld      test@mydomain.tld

Here is the mail.log:
Code:
Jun  2 10:45:08 vs248999 postfix/smtpd[27778]: connect from static-ip-62-75-XX-XX.inaddr.intergenia.de[62.75.xx.xx]      
Jun  2 10:45:08 vs248999 postfix/trivial-rewrite[27780]: warning: do not list domain mydomain.tld in BOTH mydestination and virtual_mailbox_domains
Jun  2 10:45:08 vs248999 postgrey[11839]: cleaning up old logs..
Jun  2 10:45:08 vs248999 postgrey[11839]: delayed 2138 seconds: client=static-ip-62-75-XX-XX.inaddr.intergenia.de, from=bene@sender-domain.de, to=test@mydomain.tld
Jun  2 10:45:08 vs248999 postfix/smtpd[27778]: D549443F155A:client=static-ip-62-75-XX-XX.inaddr.intergenia.de[62.75.xx.xx]
Jun  2 10:45:08 vs248999 postfix/cleanup[27781]: D549443F155A: message-id=<466141CF.2070204@sender-domain.tld>                              Jun  2 10:45:08 vs248999 postfix/qmgr[5688]: D549443F155A: from=<bene@sender-domain.de>, size=2166, nrcpt=1 (queue active)                 Jun  2 10:45:08 vs248999 postfix/trivial-rewrite[27780]: warning: do not list domain mydomain.tld in BOTH mydestination and virtual_mailbox_domains
Jun  2 10:45:08 vs248999 postfix/local[27782]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Jun  2 10:45:08 vs248999 postfix/local[27782]: D549443F155A: to=<test@mydomain.tld>, relay=local, delay=0.08, delays=0.07/0.01/0/0.01, dsn=5.1.1, status=bounced (unknown user: "test")
Jun  2 10:45:08 vs248999 postfix/cleanup[27781]: E13D543F1562: message-id=<20070602104508.E13D543F1562@mydomain.tld>              Jun  2 10:45:08 vs248999 postfix/bounce[27783]: D549443F155A: sender non-delivery notification: E13D543F1562
Jun  2 10:45:08 vs248999 postfix/qmgr[5688]: E13D543F1562: from=<>, size=3989, nrcpt=1 (queue active)
Jun  2 10:45:08 vs248999 postfix/qmgr[5688]: D549443F155A: removed        
Jun  2 10:45:09 vs248999 postfix/smtpd[27778]: disconnect from static-ip-62-75-XX-XX.inaddr.intergenia.de[62.75.xx.xx]                   Jun  2 10:46:00 vs248999 postfix/smtp[27784]: E13D543F1562: to=<bene@sender-domain.de>, relay=mail.sender-domain.de[62.75.xx.xx]:25, delay=52, delays=0/0.01/0.01/52, dsn=2.0.0, status=sent (250 OK id=1HuR7C-0004aI-KC)

To send e-Mails is no problem!
I don´t understand why only "test" is checked and not "test@mydomain.tld"

Greez BeNe
06-02-2007 09:09 PM
Visit this user's website Find all posts by this user Quote this message in a reply
joximu Offline
helper
*****
Moderators

Posts: 7,024
Joined: Jan 2007
Reputation: 92
Post: #2
RE: Can´t receive Mails in trunk #639 ?!
Quote:warning: do not list domain mydomain.tld in BOTH mydestination and virtual_mailbox_domains

maybe you have "mydomain.tld" in mydestination then it's ignored - you should have a neutral name there (can be a hostname then it's not a problem with domains)

/J
06-02-2007 09:19 PM
Visit this user's website Find all posts by this user Quote this message in a reply
BeNe Offline
Moderator
*****
Moderators

Posts: 5,899
Joined: Jan 2007
Reputation: 68
Post: #3
RE: Can´t receive Mails in trunk #639 ?!
"mydomain.tld" is a real "de"-domain. i only changed it to "mydomain.tld" in this Post. Need not more SPAM or something. Rolleyes
06-02-2007 09:21 PM
Visit this user's website Find all posts by this user Quote this message in a reply
joximu Offline
helper
*****
Moderators

Posts: 7,024
Joined: Jan 2007
Reputation: 92
Post: #4
RE: Can´t receive Mails in trunk #639 ?!
yes I though that. But it seems that you put this-domain.de in "mydestination" (main.cf) AND in a virtualhost...

But maybe there is really a problem in 639...???
06-02-2007 09:24 PM
Visit this user's website Find all posts by this user Quote this message in a reply
BeNe Offline
Moderator
*****
Moderators

Posts: 5,899
Joined: Jan 2007
Reputation: 68
Post: #5
RE: Can´t receive Mails in trunk #639 ?!
The default main.cf after ispCP install

Code:
#
# Postfix MTA Manager Main Configuration File;
#
# Please do NOT edit this file manually;
#

#
# Postfix directory settings; These are critical for normal Postfix MTA functionallity;
#

command_directory = /usr/sbin
daemon_directory  = /usr/lib/postfix
program_directory = /usr/lib/postfix

#
# Some common configuration parameters;
#

inet_interfaces  = all
mynetworks_style = host

myhostname = mydomain.tld
mydomain   = mydomain.tld.local
myorigin   = $mydomain

smtpd_banner = $myhostname ISPCP 1.0 Priamos Managed ESMTP 1.0.0 RC2 OMEGA
setgid_group = postdrop

#
# Receiving messages parameters;
#

mydestination       = $myhostname, $mydomain
append_dot_mydomain = no
append_at_myorigin  = yes
local_transport     = local
virtual_transport   = virtual
transport_maps      = hash:/etc/postfix/ispcp/transport

In "mydestination" is mydomain.tld
And why ".local" in $mydomain ??
06-02-2007 09:25 PM
Visit this user's website Find all posts by this user Quote this message in a reply
joximu Offline
helper
*****
Moderators

Posts: 7,024
Joined: Jan 2007
Reputation: 92
Post: #6
RE: Can´t receive Mails in trunk #639 ?!
Correction:
mydestination is both
myhostname and mydomain - so
mydomain.tld and mydomain.tld.local

if you change
myhostname = mydomain.tld
to
myhostname = hostname.mydomain.tld

(of course hostname.domain.tld should resolve to your ip) then it should work...

/Joxi (this weekend in .de)
06-02-2007 09:44 PM
Visit this user's website Find all posts by this user Quote this message in a reply
BeNe Offline
Moderator
*****
Moderators

Posts: 5,899
Joined: Jan 2007
Reputation: 68
Post: #7
RE: Can´t receive Mails in trunk #639 ?!
Is set "mail" before the hostname and it works now.
Fine - i will create a ticket about it.
By default there should be set "mail" before the hostname.
Read it in a RFC about the Mail Protocol.

Joxi is in Germany - *yeah* Wink
06-02-2007 10:05 PM
Visit this user's website Find all posts by this user Quote this message in a reply
joximu Offline
helper
*****
Moderators

Posts: 7,024
Joined: Jan 2007
Reputation: 92
Post: #8
RE: Can´t receive Mails in trunk #639 ?!
Hi BeNe
IMHO a host name is not the same as a domain name.
So, ispcp should put a hostname there but it didn't in your case... (I don't know what you typed in on the "give the full qualified hostname" question...

Well, the whole thing about hostname/domainname & changing "/etc/hosts" and "/etc/resolv.conf" is not a good situation... I think this should be the job of the admin - of course a good HOWTO should be delivered :-)

/Joximu
06-02-2007 10:16 PM
Visit this user's website Find all posts by this user Quote this message in a reply
BeNe Offline
Moderator
*****
Moderators

Posts: 5,899
Joined: Jan 2007
Reputation: 68
Post: #9
RE: Can´t receive Mails in trunk #639 ?!
Yeah i typed the FQDN during the Setup.
ispCP put it in the main.cf - everything was right.

BUT - in my opinion is the "mail." before the hostname missing.
After the change from:
Code:
mydomain.tld
to
Code:
mail.mydomain.tld

Postfix delivers the mail now right and everything works.
There is a RFC (cant find it now) about the hostname for a Mailserver,
and this should always be "mail.hostname.tld".

Or i´m wrong ?
06-02-2007 10:32 PM
Visit this user's website Find all posts by this user Quote this message in a reply
joximu Offline
helper
*****
Moderators

Posts: 7,024
Joined: Jan 2007
Reputation: 92
Post: #10
RE: Can´t receive Mails in trunk #639 ?!
I don't know about this "mail." - ok, it is ONE of various possibilities...

If it's a must, then the postfix manula would tell this:
http://www.postfix.org/postconf.5.html#myhostname

it's just: myhostname should be resolvable and not be used by any other customer (so in your example there should be no customer who want's a subdomain mail.domain.tld...) :-)
06-02-2007 10:41 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)