Current time: 02-26-2020, 04:37 AM Hello There, Guest! (LoginRegister)


Post Reply 
upgrade 1.0.0 1.0.2 ispcp daemon issues [SOLVED]
Author Message
pge Offline
Newbie
*

Posts: 8
Joined: Aug 2009
Reputation: 0
Post: #1
upgrade 1.0.0 1.0.2 ispcp daemon issues [SOLVED]
Hey all, after performing an upgrade from 1.0.0 stable to 1.0.2 stable i was having trouble starting the ispcp daemon.
< I cannot remember the error right now, but if i can find it i will post it later >
So i searched the web and all i found was the advice to compile an ispcpd from the latest SVN trunk.

I did so and then it did start without a problem. The only thing is - no updates are written.

When i add a subdomain, the DB status changes to "toadd" but nothing is done.
After manually running the rqst manager the Domain is added without a Problem but still the question remains - why doesnt the ispcp_daemon react?

Greetings

pge
(This post was last modified: 08-28-2009 07:42 PM by pge.)
08-28-2009 05:59 PM
Find all posts by this user Quote this message in a reply
Nuxwin
Unregistered

 
Post: #2
RE: upgrade 1.0.0 1.0.2 ispcp daemon issues
Hi ;

You've added the subdomain before or after compiling and start the new daemon ?

Did you try to reproduce the error several times or just once?

What OS you use?
08-28-2009 06:20 PM
Quote this message in a reply
pge Offline
Newbie
*

Posts: 8
Joined: Aug 2009
Reputation: 0
Post: #3
RE: upgrade 1.0.0 1.0.2 ispcp daemon issues
I tried the upgrade several times and then rolled back after the ispcpd did not work correctly.
So yes, ive been at the "ispcpd not working" point a couple of times before i tried to seek a workaround (trunk compile ispcpd).

my os is debian 5.0
(This post was last modified: 08-28-2009 06:24 PM by pge.)
08-28-2009 06:24 PM
Find all posts by this user Quote this message in a reply
kilburn Offline
Development Team
*****
Dev Team

Posts: 2,182
Joined: Feb 2007
Reputation: 34
Post: #4
RE: upgrade 1.0.0 1.0.2 ispcp daemon issues
Can you try to manually execute a request? Follow this procedure (from a shell on your server):
Code:
telnet localhost 9876
helo me
execute query
bye

This should execute the request manager for you...
08-28-2009 06:27 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Nuxwin
Unregistered

 
Post: #5
RE: upgrade 1.0.0 1.0.2 ispcp daemon issues
(08-28-2009 06:24 PM)pge Wrote:  I tried the upgrade several times and then rolled back after the ispcpd did not work correctly.
So yes, ive been at the "ispcpd not working" point a couple of times before i tried to seek a workaround (trunk compile ispcpd).

my os is debian 5.0

Regarding the daemon version 1.0.2, it is a known error that will be corrected in the next version.

You do not understand my question. Is with the daemon from trunk you still experience the problem? Thank you to redo the tests with the new daemon.

Thank
(08-28-2009 06:27 PM)kilburn Wrote:  Can you try to manually execute a request? Follow this procedure (from a shell on your server):
Code:
telnet localhost 9876
helo me
execute query
bye

This should execute the request manager for you...

Or via admin frontend directly
08-28-2009 06:29 PM
Quote this message in a reply
pge Offline
Newbie
*

Posts: 8
Joined: Aug 2009
Reputation: 0
Post: #6
RE: upgrade 1.0.0 1.0.2 ispcp daemon issues
Code:
Escape character is '^]'.
250 OK ispCP Daemon v1.1 Welcomes You!
helo me
250 OK 127.0.0.1/me
execute query
250 OK request is being processed.
bye
250 OK Good Bye!
Connection closed by foreign host.
08-28-2009 06:32 PM
Find all posts by this user Quote this message in a reply
Nuxwin
Unregistered

 
Post: #7
RE: upgrade 1.0.0 1.0.2 ispcp daemon issues
(08-28-2009 06:32 PM)pge Wrote:  
Code:
Escape character is '^]'.
250 OK ispCP Daemon v1.1 Welcomes You!
helo me
250 OK 127.0.0.1/me
execute query
250 OK request is being processed.
bye
250 OK Good Bye!
Connection closed by foreign host.

Please , Go to frontend (GUI) and added a new subdomain (just to test.. remove after). And post the result here to confirm the bug if necessary.

Thank
08-28-2009 06:36 PM
Quote this message in a reply
pge Offline
Newbie
*

Posts: 8
Joined: Aug 2009
Reputation: 0
Post: #8
RE: upgrade 1.0.0 1.0.2 ispcp daemon issues
Also perform a manual request afterwards?
08-28-2009 06:37 PM
Find all posts by this user Quote this message in a reply
Nuxwin
Unregistered

 
Post: #9
RE: upgrade 1.0.0 1.0.2 ispcp daemon issues
(08-28-2009 06:37 PM)pge Wrote:  Also perform a manual request afterwards?

No, I want you to confirm that the bug occurs with the version of the daemon from the trunk. After adding the sub-domain, check the status of the database and also that the subdomain has been created.

Thank
08-28-2009 06:41 PM
Quote this message in a reply
pge Offline
Newbie
*

Posts: 8
Joined: Aug 2009
Reputation: 0
Post: #10
RE: upgrade 1.0.0 1.0.2 ispcp daemon issues
Here Screenshots of added Domain.
Debugger view.
DB toadd view.


Attached File(s) Thumbnail(s)
           
08-28-2009 06:57 PM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)