Current time: 12-19-2018, 01:48 AM Hello There, Guest! (LoginRegister)


Thread Closed 
[IMPORTANT] ispCP 1.0.4 - Ubuntu Users - Please Read
Author Message
Nuxwin
Unregistered

 
Post: #1
Exclamation [IMPORTANT] ispCP 1.0.4 - Ubuntu Users - Please Read
Dear ispCP users ;

The new ispCP 1.0.4 version provides an older version of permissions scripts that are not POSIX Compliant. The version of these scripts is not supported by Ubuntu because the bash extended syntax is not allowed by the default system shell (Dash).

It's my fault because, when I've rewritten the permissions scripts to be POSIX compliant, I forgot the reintegration into the main development branch. Guys, I'm really sorry for my mistake and so, please, accept my apologies.

So, let me explain how to fix the problem now:

Depending on your current situation:

I. If you want install ispCP 1.0.4 on a fresh Ubuntu installation:

Before executing the script `ispcp-setup`, follow these instructions:

Code:
# cd /var/www/ispcp/engine/setup
# wget -O- 'http://www.isp-control.net/ispcp/raw-attachment/ticket/2247/permission-fix-1.0.4.tar.gz' | tar -xzv

2. If you have already run the `ispcp-setup` script:

You've probably encountered the following error:

Code:
...
/var/www/ispcp/engine/setup/ispcp-permission-functions.sh: 70: Syntax error: "}" unexpected
ERROR: External command '/bin/sh /var/www/ispcp/engine/setup/set-gui-permissions.sh' returned '2' status
...

That is not a big problem since only two small tasks were not performed (Fixing permissions and restart services), so, you can finish the install process by following these instructions:

Code:
# cd /var/www/ispcp/engine/setup
# wget -O- 'http://www.isp-control.net/ispcp/raw-attachment/ticket/2247/permission-fix-1.0.4.tar.gz' | tar -xzv
# perl ispcp-update

3. If you performed an upgrade from an older version of ispCP, follow these instructions:

Before run the `ispcp-update` script:
Code:
# cd /var/www/ispcp/engine/setup
# wget -O- 'http://www.isp-control.net/ispcp/raw-attachment/ticket/2247/permission-fix-1.0.4.tar.gz' | tar -xzv

Note: If you have already run the `ispcp-update` script and encountered the error described above, rerun the script after following these instructions.

Best Regards.
03-03-2010 01:02 PM
xantios Offline
Newbie
*

Posts: 7
Joined: Feb 2010
Reputation: 0
Post: #2
RE: [IMPORTANT] ispCP 1.0.4 - Ubuntu Users - Please Read
Ah,thats why i could not get the new version working. thnx
03-10-2010 11:09 PM
Find all posts by this user
rhinestone Offline
Banned

Posts: 1
Joined: Mar 2010
Post: #3
RE: [IMPORTANT] ispCP 1.0.4 - Ubuntu Users - Please Read
thank you very much for this new version of ispCP 1.0.4.. It helps a lot..
03-22-2010 09:24 PM
Find all posts by this user
Thread Closed 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)