Current time: 12-08-2019, 08:58 PM Hello There, Guest! (LoginRegister)


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Error after clean Install
Author Message
greenie Offline


Posts: 2
Joined: May 2010
Reputation: 0
Post: #1
[SOLVED] Error after clean Install
Hello there. After a clean install of ispcp omega 1.0.5 on a virtual Centos machine I tried to open the defalut page but I saw a blank page. http://guest-00715.limehost.ro/
After a consult of /var/log/httpd/users/default-error.log i saw the next error.
I am not a great linux specialist. perhaps someone of you have any ideea about that. i read many posts on that forum but nothing helped.

[Sun May 23 09:25:10 2010] [error] [client 188.25.170.93] PHP Warning: require_once(/var/www/ispcp/gui/include/ispcp-db-keys.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: Permission denied in /var/www/ispcp/gui/include/ispcp-lib.php on line 67
[Sun May 23 09:25:10 2010] [error] [client 188.25.170.93] PHP Fatal error: require_once() [<a href='function.require'>function.require</a>]: Failed opening required '/var/www/ispcp/gui/include/ispcp-db-keys.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/ispcp/gui/include/ispcp-lib.php on line 67

I tried to apply solutions from
http://isp-control.net/forum/thread-1007...l#pid78186
but I receive next errors

[Sun May 23 09:24:30 2010] [error] [client 188.25.170.93] PHP Warning: PDO::prepare() [<a href='function.PDO-prepare'>function.PDO-prepare</a>]: SQLSTATE[00000]: No error: PDO constructor was not called in /var/www/ispcp/gui/include/class.Database.php on line 115
[Sun May 23 09:24:30 2010] [error] [client 188.25.170.93] PHP Warning: PDO::query() [<a href='function.PDO-query'>function.PDO-query</a>]: SQLSTATE[00000]: No error: PDO constructor was not called in /var/www/ispcp/gui/include/class.Database.php on line 100
[Sun May 23 09:24:30 2010] [error] [client 188.25.170.93] PHP Warning: PDO::setAttribute() [<a href='function.PDO-setAttribute'>function.PDO-setAttribute</a>]: SQLSTATE[00000]: No error: PDO constructor was not called in /var/www/ispcp/gui/include/class.Database.php on line 112
[Sun May 23 09:24:30 2010] [error] [client 188.25.170.93] PHP Warning: PDO::prepare() [<a href='function.PDO-prepare'>function.PDO-prepare</a>]: SQLSTATE[00000]: No error: PDO constructor was not called in /var/www/ispcp/gui/include/class.Database.php on line 115
[Sun May 23 09:24:30 2010] [error] [client 188.25.170.93] PHP Warning: PDO::query() [<a href='function.PDO-query'>function.PDO-query</a>]: SQLSTATE[00000]: No error: PDO constructor was not called in /var/www/ispcp/gui/include/class.Database.php on line 100
[Sun May 23 09:24:31 2010] [notice] child pid 4917 exit signal Segmentation fault (11)
Can anybody give me a clue?
Thanks.
(This post was last modified: 05-26-2010 08:11 PM by gOOvER.)
05-23-2010 08:01 PM
Visit this user's website Find all posts by this user Quote this message in a reply
RatS Offline
Project Leader
******

Posts: 1,854
Joined: Oct 2006
Reputation: 17
Post: #2
RE: Error after clean Install
please try to re-run ./ispcp/engine/setup/set-gui-permissions - there is something wrong with your permissions.
(This post was last modified: 05-24-2010 12:00 AM by RatS.)
05-24-2010 12:00 AM
Visit this user's website Find all posts by this user Quote this message in a reply
greenie Offline


Posts: 2
Joined: May 2010
Reputation: 0
Post: #3
RE: Error after clean Install
(05-24-2010 12:00 AM)RatS Wrote:  please try to re-run ./ispcp/engine/setup/set-gui-permissions - there is something wrong with your permissions.

was not that... After several trying.. i decided to reinstall on a clean server... My mistake was in php... I didn't corect the php and I used 5.1.3 version.
After upgrade with corect repository I found the page ... but.. now I have new errors.
After i login in Admin panel I see many errors of php function
Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'UTC' for 'UTC/0.0/no DST' instead in /var/www/ispcp/gui/admin/index.php on line 129

Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'UTC' for 'UTC/0.0/no DST' instead in /var/www/ispcp/gui/admin/index.php on line 129

Warning: mktime() [function.mktime]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'UTC' for 'UTC/0.0/no DST' instead in /var/www/ispcp/gui/admin/index.php on line 129

Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'UTC' for 'UTC/0.0/no DST' instead in /var/www/ispcp/gui/admin/index.php on line 131

Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'UTC' for 'UTC/0.0/no DST' instead in /var/www/ispcp/gui/admin/index.php on line 131

Warning: mktime() [function.mktime]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'UTC' for 'UTC/0.0/no DST' instead in /var/www/ispcp/gui/admin/index.php on line 131

My php version installed by repository automated is php-5.3.2-1.el5.remi.x86_64
on a Centos 5.3 virtual machine
Anybody have a clue?
Thanks...
(This post was last modified: 05-25-2010 12:35 AM by greenie.)
05-25-2010 12:30 AM
Visit this user's website Find all posts by this user Quote this message in a reply
kroko Offline


Posts: 2
Joined: May 2010
Reputation: 0
Post: #4
RE: Error after clean Install
i have the same issue
05-26-2010 08:33 AM
Find all posts by this user Quote this message in a reply
kroko Offline


Posts: 2
Joined: May 2010
Reputation: 0
Post: #5
RE: Error after clean Install
solved with this:
http://isp-control.net/forum/thread-1016...78330.html

good luck
05-26-2010 05:59 PM
Find all posts by this user Quote this message in a reply
junk Offline


Posts: 1
Joined: Jun 2010
Reputation: 0
Post: #6
RE: [SOLVED] Error after clean Install
CentOS 5.5 i386 ispcp 1.0.6 Fresh install

Error in /var/www/ispcp/gui/admin/index.php on line 129 etc...

From above link:
nano /var/www/fcgi/master/php5/php.ini

Find:
;date.timezone =

Uncomment to look like this:
date.timezone = "America/New_York"

Restart Apache:
service httpd restart
(This post was last modified: 10-06-2010 04:35 PM by junk.)
10-06-2010 04:34 PM
Find all posts by this user Quote this message in a reply
Nuxwin
Unregistered

 
Post: #7
RE: [SOLVED] Error after clean Install
Thank for your report. Already fixed in 1.0.7 rc1.
10-06-2010 04:56 PM
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)