Current time: 06-21-2018, 01:10 AM Hello There, Guest! (LoginRegister)


Post Reply 
Getting Mod_Mono to work.
Author Message
manix Offline


Posts: 2
Joined: Jun 2010
Reputation: 0
Post: #1
Getting Mod_Mono to work.
Hey, i'm totally new to ispCP but i've gotten it to work perfectly Smile

Now i'm trying to enable Mod_Mono so i can run some aspx pages aswell.

So far I've followed the installation guide from https://help.ubuntu.com/community/ModMono

But i'm currently stuck after point 3. The packages have been installed, the module is running(so is php yay) but i can't seem to find what to alter to enable it on a given page.

I've tried to alter /etc/apache2/sites-available/ispcp.conf but nothing works Sad

Does any of you know how to do this?

I'm running Ubuntu 8.04 on a virtual server.
06-06-2010 01:02 AM
Find all posts by this user Quote this message in a reply
gOOvER Offline
Banned

Posts: 3,564
Joined: Jul 2007
Post: #2
RE: Getting Mod_Mono to work.
-> moved to Smalltalk. This has nothing to do with ispCP Smile
06-06-2010 03:21 AM
Visit this user's website Find all posts by this user Quote this message in a reply
manix Offline


Posts: 2
Joined: Jun 2010
Reputation: 0
Post: #3
RE: Getting Mod_Mono to work.
Uhm - It's slightly connected to ispCP because i'm not sure what ispCP manipulated files i should edit to get it to work.
06-06-2010 06:40 PM
Find all posts by this user Quote this message in a reply
pgentoo Offline
Member
*****
Dev Team

Posts: 328
Joined: Mar 2007
Reputation: 0
Post: #4
RE: Getting Mod_Mono to work.
I you use autohosting, you should be able to just edit some main file (httpd.conf) or the corresponding module conf file, without touching any of the ispcp files.
06-07-2010 12:54 PM
Find all posts by this user Quote this message in a reply
pgentoo Offline
Member
*****
Dev Team

Posts: 328
Joined: Mar 2007
Reputation: 0
Post: #5
RE: Getting Mod_Mono to work.
From a security point of view, you may want to look at selectively enabling (like we do for PHP/CGI currently) mod_fcigd/mod_fastcgi hosted mono processes.

I do this on my side manually, by adding in the proper FCGIWrapper entries for virtualhosts that need mono support.

Example:


<IfModule mod_fcgid.c>

<Directory /var/www/virtual/monosite.com/proxy/htdocs>
##### START EXISTING LINES
FCGIWrapper /var/www/fcgi/monosite.com/php5-fcgi-starter .php
FCGIWrapper /var/www/fcgi/monosite.com/php5-fcgi-starter .php5
FCGIWrapper /var/www/fcgi/monosite.com/php5-fcgi-starter .phtml
Options +ExecCGI
##### END EXISTING LINES

##### START MONO LINES
FCGIWrapper "/var/www/fcgi/monosite.com/mono-fcgi-starter /applications=/:/var/www/virtual/monosite.com/proxy/htdocs" .asax
FCGIWrapper "/var/www/fcgi/monosite.com/mono-fcgi-starter /applications=/:/var/www/virtual/monosite.com/proxy/htdocs" .ashx
FCGIWrapper "/var/www/fcgi/monosite.com/mono-fcgi-starter /applications=/:/var/www/virtual/monosite.com/proxy/htdocs" .asmx
FCGIWrapper "/var/www/fcgi/monosite.com/mono-fcgi-starter /applications=/:/var/www/virtual/monosite.com/proxy/htdocs" .aspx
FCGIWrapper "/var/www/fcgi/monosite.com/mono-fcgi-starter /applications=/:/var/www/virtual/monosite.com/proxy/htdocs" .ascx
FCGIWrapper "/var/www/fcgi/monosite.com/mono-fcgi-starter /applications=/:/var/www/virtual/monosite.com/proxy/htdocs" .axd
FCGIWrapper "/var/www/fcgi/monosite.com/mono-fcgi-starter /applications=/:/var/www/virtual/monosite.com/proxy/htdocs" .config
FCGIWrapper "/var/www/fcgi/monosite.com/mono-fcgi-starter /applications=/:/var/www/virtual/monosite.com/proxy/htdocs" .cs
FCGIWrapper "/var/www/fcgi/monosite.com/mono-fcgi-starter /applications=/:/var/www/virtual/monosite.com/proxy/htdocs" .dll
FCGIWrapper "/var/www/fcgi/monosite.com/mono-fcgi-starter /applications=/:/var/www/virtual/monosite.com/proxy/htdocs" .rem
FCGIWrapper "/var/www/fcgi/monosite.com/mono-fcgi-starter /applications=/:/var/www/virtual/monosite.com/proxy/htdocs" .soap
##### END MONO LINES

</Directory>
<Directory "/var/www/fcgi/monosite.com">
AllowOverride None
Options +ExecCGI MultiViews -Indexes
Order allow,deny
Allow from all
</Directory>
</IfModule>


My fcgid script for mono looks like:

#!/bin/sh
umask 022
exec /usr/bin/fastcgi-mono-server2 /applications=/:/var/www/virtual/monosite.com/htdocs
06-10-2010 11:19 AM
Find all posts by this user Quote this message in a reply
caramel Offline


Posts: 1
Joined: Oct 2010
Reputation: 0
Post: #6
RE: Getting Mod_Mono to work.
(06-07-2010 12:54 PM)pgentoo Wrote:  I you use autohosting, you should be able to just edit some main file (httpd.conf) or the corresponding module conf file, without touching any of the ispcp files.

I've also problems to get the mod_mono module working. I'd like to use autohosting to get an ASP.NET web service running. I've enabled the mod_mono module in apache2 via "a2enmod mod_mono", added the line "Include /etc/apache2/mods-available/mod_mono.conf" in the /etc/apache2/apache2.conf and restarted apache2.
When I now enter the url to my web service (an *.asmx file) I can download this file. The file will not be handled by the mono server.
What should I do to get it running?

I'm using Debian Lenny with ispCP 1.0.6 OMEGA.

Any help is appreciated.
10-11-2010 06:43 AM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)