Current time: 07-15-2020, 09:31 AM Hello There, Guest! (LoginRegister)


Post Reply 
Warnings en panel de control
Author Message
waltervalderrama Offline
Newbie
*

Posts: 7
Joined: Feb 2010
Reputation: 0
Post: #1
Question Warnings en panel de control
Hola a todos.
Acabo de instalar ISPCP Omega 1.0.6 en un Centos 5.5 x64 según la documentación. La instalación fue OK. Puedo ingresar sin problemas al PHP My Admin via: http://IP-DEL-SERVIDOR/pma.
El problema está cuando intento ingresar al panel de administración. Ingreso con el usuario admin y la contraseña definida durante la instalación y una vez dentro, aparecen muchas warningns como esta:


Warning: mktime() [function.mktime]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Lima' for 'PET/-5.0/no DST' instead in /var/www/ispcp/gui/admin/index.php on line 129

Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Lima' for 'PET/-5.0/no DST' instead in /var/www/ispcp/gui/admin/index.php on line 131


Puedo ingresar a los menús y opciones pero no quiero comenzar a configurar nada hasta no superar esto. He verificado el archivo que indica el warning - /var/www/ispcp/gui/admin/index.php, pero no entiendo mucho de php y esas funciones mencionadas.

Me vendría bien un poco de ayuda por favor, gracias.
08-27-2010 03:33 AM
Find all posts by this user Quote this message in a reply
kurgans Offline
Moderator
*****
Moderators

Posts: 1,565
Joined: Feb 2008
Reputation: 23
Post: #2
RE: Warnings en panel de control
Es por la version de php, no se si ispcp estará aun para funcionar en 5.3, si no tendras que quitarla y montar una version 5.2

Yo uso debian, pero recuerdo algo de ese tema de cuando leo por ahi en el foro.
08-27-2010 04:12 AM
Visit this user's website Find all posts by this user Quote this message in a reply
waltervalderrama Offline
Newbie
*

Posts: 7
Joined: Feb 2010
Reputation: 0
Post: #3
At RE: Warnings en panel de control
(08-27-2010 04:12 AM)kurgans Wrote:  Es por la version de php, no se si ispcp estará aun para funcionar en 5.3, si no tendras que quitarla y montar una version 5.2

Yo uso debian, pero recuerdo algo de ese tema de cuando leo por ahi en el foro.

Tengo la versión 5.3 de php efectivamente. Pero me parece extraño, la misma documentación indica cambiar los repositorios para el php. Y la versión que se instala es la 5.3
08-27-2010 05:14 AM
Find all posts by this user Quote this message in a reply
vanshyr Offline
Junior Member
*

Posts: 33
Joined: Apr 2009
Reputation: 0
Post: #4
RE: Warnings en panel de control
Sinceramente nose de que puede ser pero se me ocure...

el sistema horario que tienes definido es el mismo que el sistema horario del servidor?

(08-27-2010 05:14 AM)waltervalderrama Wrote:  
(08-27-2010 04:12 AM)kurgans Wrote:  Es por la version de php, no se si ispcp estará aun para funcionar en 5.3, si no tendras que quitarla y montar una version 5.2

Yo uso debian, pero recuerdo algo de ese tema de cuando leo por ahi en el foro.

Tengo la versión 5.3 de php efectivamente. Pero me parece extraño, la misma documentación indica cambiar los repositorios para el php. Y la versión que se instala es la 5.3
08-27-2010 10:23 AM
Find all posts by this user Quote this message in a reply
kilburn Offline
Development Team
*****
Dev Team

Posts: 2,182
Joined: Feb 2007
Reputation: 34
Post: #5
RE: Warnings en panel de control
Al principio del documento de instalación deja bien clarito que "CentOS version: 5.4". Por eso aunque te haga cambiar los repositorios no se espera que te meta php 5.3, sino php 5.2.

Lo mejor que puedes hacer es buscar como "downgradear" el php a la versión 5.2, puesto que a parte de ese warning (que es inofensivo), tendrás algunos problemas más tanto en el panel como en el webmail.

El trunk actual (de la que sacaremos una RC en breve) ya tiene todos los fallos con php5.3 corregidos, de modo que es cuestión de tiempo, pero por el momento esa es la mejor solución si quieres un sistema estable.
08-28-2010 02:58 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)