Current time: 09-19-2018, 04:15 AM Hello There, Guest! (LoginRegister)


Post Reply 
ispCP Omega 1.0.7 Release
Author Message
Lucan Offline
Member
*
Beta Team

Posts: 982
Joined: Jul 2008
Reputation: 12
Post: #21
RE: ispCP Omega 1.0.7 Release
I updated 3 of my Debian Lenny installations from ispcp 1.0.5 (with security fixes)

In all 3 updates, the main.cf file looked like:
Code:
check_policy_service inet:127.0.0.1:12525,
check_policy_service inet:127.0.0.1:10023,
So i had to change it manually to
Code:
check_policy_service inet:127.0.0.1:12525,
check_policy_service inet:127.0.0.1:60000,

Also in all 3 updates, ispcp wasn't able to resolve ispcp pma passwort -> but that wasn't a problem for me, because i've got all my passwords.


Greetings.
11-27-2010 12:28 AM
Find all posts by this user Quote this message in a reply
RatS Offline
Project Leader
******

Posts: 1,854
Joined: Oct 2006
Reputation: 17
Post: #22
RE: ispCP Omega 1.0.7 Release
(11-26-2010 08:56 PM)alecksievici Wrote:  
Code:
http://isp-control.net/ispcp/browser/tags/omega-1.0.7/gui/themes/omega_original/reseller/users.tpl
http://isp-control.net/ispcp/browser/trunk/gui/themes/omega_original/reseller/users.tpl
Take a look at line 111 you'll see {STATUS_ICON}.png and {STATUS_ICON} in users.php is already defined as reload.png so there goes your second .png extension.

Thanks, I fixed this in r3680.
11-27-2010 02:29 AM
Visit this user's website Find all posts by this user Quote this message in a reply
RatS Offline
Project Leader
******

Posts: 1,854
Joined: Oct 2006
Reputation: 17
Post: #23
RE: ispCP Omega 1.0.7 Release
(11-27-2010 12:28 AM)Lucan Wrote:  I updated 3 of my Debian Lenny installations from ispcp 1.0.5 (with security fixes)

In all 3 updates, the main.cf file looked like:
Code:
check_policy_service inet:127.0.0.1:12525,
check_policy_service inet:127.0.0.1:10023,
So i had to change it manually to
Code:
check_policy_service inet:127.0.0.1:12525,
check_policy_service inet:127.0.0.1:60000,

Also in all 3 updates, ispcp wasn't able to resolve ispcp pma passwort -> but that wasn't a problem for me, because i've got all my passwords.


Greetings.
Please try the changed ispcp-update from r3682.
Thanks
11-27-2010 09:18 AM
Visit this user's website Find all posts by this user Quote this message in a reply
MasterTH Offline
Member
***

Posts: 570
Joined: Feb 2009
Reputation: 4
Post: #24
RE: ispCP Omega 1.0.7 Release
got a problem with a fresh installation


Code:
System checks
         * Mysql server connection:                                    [ Done ]

        Services setup
         * ispCP users and groups:                                     [ Done ]
         * ispCP directories:                                          [ Done ]
         * ispCP main configuration file:                              [ Done ]
         * ispCP database:                                             [ Done ]
         * ispCP default language table:                               [ Done ]
         * ispCP default SQL data:                                     [ Done ]
         * ispCP system hosts file:                                    [ Done ]
         * ispCP system resolver:                                      [ Done ]
         * ispCP crontab file:                                         [ Done ]
         * ispCP Bind9 main configuration file:                        [ Done ]
         * ispCP Apache fastCGI modules configuration:               [ Failed ]

        [FATAL] An error occurred during setup process!
        Correct it and re-run this program.

        Log files are stored in /var/log/ispcp/setup
        You can also find help at http://isp-control.net/forum

this is a part of the log-file
Code:
getCmdExitValue()              | [DEBUG] External command exited with value 0
getCmdExitValue()              | Ending...
sys_command('/bin/cp -pf /etc/ispcp/apache/working/fcgid_ispcp.load /etc/apache2/mods-available/') | Ending...
sys_command()                  | Starting...
system()                       | [DEBUG] ERROR: Module php4 does not exist!
ERROR: Module php5 does not exist!
getCmdExitValue()              | Starting...
getCmdExitValue()              | [DEBUG] External command exited with value 1
getCmdExitValue()              | Ending...
sys_command()                  | [ERROR] External command '/usr/sbin/a2dismod php4 php5' exited with value 1 !
sys_command()                  | Starting...
system()                       | [DEBUG] Module actions already enabled
getCmdExitValue()              | Starting...
getCmdExitValue()              | [DEBUG] External command exited with value 0
getCmdExitValue()              | Ending...
sys_command('/usr/sbin/a2enmod actions') | Ending...
sys_command()                  | Starting...
system()                       | [DEBUG] Module fastcgi_ispcp already disabled
getCmdExitValue()              | Starting...
getCmdExitValue()              | [DEBUG] External command exited with value 0
getCmdExitValue()              | Ending...
sys_command('/usr/sbin/a2dismod fastcgi_ispcp') | Ending...
sys_command()                  | Starting...
system()                       | [DEBUG] Module fcgid_ispcp already enabled
getCmdExitValue()              | Starting...
getCmdExitValue()              | [DEBUG] External command exited with value 0
getCmdExitValue()              | Ending...
sys_command('/usr/sbin/a2enmod fcgid_ispcp') | Ending...
sys_command()                  | Starting...
system()                       | [DEBUG] ERROR: Module fastcgi does not exist!
Module fcgid already disabled
getCmdExitValue()              | Starting...
getCmdExitValue()              | [DEBUG] External command exited with value 1
getCmdExitValue()              | Ending...
sys_command()                  | [ERROR] External command '/usr/sbin/a2dismod fastcgi fcgid' exited with value 1 !
exit_msg()                     | Starting...
exit_msg()                     | Ending...
del_file()                     | Starting...
del_file()                     | Ending...

used fcigd, just awstats enabled and mysql prefix infront
Used the installer from Trunk
(This post was last modified: 11-28-2010 05:12 AM by MasterTH.)
11-28-2010 04:56 AM
Find all posts by this user Quote this message in a reply
microworld Offline


Posts: 1
Joined: Mar 2009
Reputation: 0
Post: #25
RE: ispCP Omega 1.0.7 Release
(11-28-2010 04:56 AM)MasterTH Wrote:  got a problem with a fresh installation


Code:
* ispCP crontab file:                                         [ Done ]
         * ispCP Bind9 main configuration file:                        [ Done ]
         * ispCP Apache fastCGI modules configuration:               [ Failed ]

        [FATAL] An error occurred during setup process!
        Correct it and re-run this program.

this is a part of the log-file
Code:
sys_command()                  | Starting...
system()                       | [DEBUG] ERROR: Module fastcgi does not exist!
Module fcgid already disabled
used fcigd, just awstats enabled and mysql prefix infront
Used the installer from Trunk

I just installed a VPS with Ubuntu 10.04 base install and attempted to install ispCP 1.0.7 Release however, I had the same problems listed above. Tried using fcgi option instead, rebuilt a dozen times, verified packages, verified everything was up to date (multiverse, etc). I had no luck getting it to work.

So, I purged the VPS, started clean and installed 1.0.7RC2 instead. At first I had a problem with rkhunter not installing, but after waiting about 10 minutes (ld's were updating in the background?), the install worked.

So, I'm running 1.0.7RC2 and would like to upgrade to the release, however I've done lots of mods tonight (subdomain hosting mods, etc) and hoping the upgrade will keep those settings.

Anyway, I figured I would chime in cuz 1.0.7 was just released and in case anyone else running Ubuntu 10.04 is running into this same problem. After trying forever, I figured it might just be a bug in the installation scripts and someone would find it after a few reports? :-)

I'm getting ready to migrate from 1.0.5 on an old server and the purpose of the upgrade was mainly for the API support as I want to complete automation of the signup process for our customers and I feel API is the best way to do it. Just hope the API is stable enough cuz I couldn't get it working in 1.0.5 and from what I was reading in forums, 1.0.7 may not install on my older Ubuntu 8.04 machine, so I figured a good clean start would go smoothly (not so much, but close).

Is there any chance someone could add support for upgrade of ispCP within the control panel admin pages, something that would do a backup and have the option to downgrade if the upgrade didn't go smoothly? I guess the control panel would not work if the upgrade didn't go smoothly, maybe a quick restore script if upgrade fails? Maybe a backup script in each new release, with the option to restore the previous working version? I would try new versions a lot more often if it was easy to fix, but in the past, if install's failed, it was a pain, sometimes having to recreate domains manually (including email addresses) and I can't be doing that in a large production environment. Just a thought..
11-29-2010 09:19 PM
Find all posts by this user Quote this message in a reply
seeberg Offline


Posts: 1
Joined: Nov 2010
Reputation: 0
Post: #26
RE: ispCP Omega 1.0.7 Release
Having a large production environment I agree with microworld. Any plans for a more polished 1.0.7 release including fixes for the most common problems with upgrading? If not I'll probably wait for 1.0.8 till I upgrade my Debian Lenny systems.
(This post was last modified: 11-30-2010 10:20 PM by seeberg.)
11-30-2010 10:20 PM
Find all posts by this user Quote this message in a reply
marceloctec Offline
Junior Member
*

Posts: 20
Joined: Dec 2010
Reputation: 0
Post: #27
RE: ispCP Omega 1.0.7 Release
Hi,

I can´t update from 1.05.

2 error messages appear:

1. After command "aptitude install $(cat ./docs/Ubuntu/ubuntu-packages-`lsb_release -cs`)"
cat: ./docs/Ubuntu/ubuntu-packages-karmic: file not found

2. After command "perl ispcp-update"

Can't locate DateTime.pm in @INC (@INC contains: /var/www/ispcp/engine/setup/.. /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at ispcp-setup-methods.pl line 43.
BEGIN failed--compilation aborted at ispcp-setup-methods.pl line 43.
Compilation failed in require at ispcp-update line 46.

My system is:
Ubuntu 9.10

Best Regards,
Marcelo
12-02-2010 08:14 AM
Find all posts by this user Quote this message in a reply
motokochan Offline
Member
***

Posts: 274
Joined: Jul 2008
Reputation: 1
Post: #28
RE: ispCP Omega 1.0.7 Release
(12-02-2010 08:14 AM)marceloctec Wrote:  1. After command "aptitude install $(cat ./docs/Ubuntu/ubuntu-packages-`lsb_release -cs`)"
cat: ./docs/Ubuntu/ubuntu-packages-karmic: file not found

It is my understanding that older versions (pre 10.x) versions of Ubuntu are no longer supported. At the very least, there is no package list for your version of Ubuntu. You may have to use another package list and install by hand.


(12-02-2010 08:14 AM)marceloctec Wrote:  2. After command "perl ispcp-update"

Can't locate DateTime.pm in @INC (@INC contains: /var/www/ispcp/engine/setup/.. /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at ispcp-setup-methods.pl line 43.
BEGIN failed--compilation aborted at ispcp-setup-methods.pl line 43.
Compilation failed in require at ispcp-update line 46.

You're missing a required Perl module. The package installation process, if it worked, would have taken care of this issue. You'll need to install "libdatetime-perl" or use CPAN to install DateTime.
12-04-2010 01:46 AM
Visit this user's website Find all posts by this user Quote this message in a reply
marceloctec Offline
Junior Member
*

Posts: 20
Joined: Dec 2010
Reputation: 0
Post: #29
RE: ispCP Omega 1.0.7 Release
Thanks motokochan!

Quote:It is my understanding that older versions (pre 10.x) versions of Ubuntu are no longer supported. At the very least, there is no package list for your version of Ubuntu. You may have to use another package list and install by hand.

Where I find the package list to Ubuntu 9.10?


Quote:You're missing a required Perl module. The package installation process, if it worked, would have taken care of this issue. You'll need to install "libdatetime-perl" or use CPAN to install DateTime.

I instaled "libdatetime-perl" and after of the execute "perl ispcp-update". occurred a Fatal Error: "[ERROR]: Error: Unable to establish connection to the database! SQL returned: SQLSTATE[28000] [1045] Access denied for user 'root'@'localhost' (using passwo$..."

I'm still unable to access the ispcp panel.

Regards,
Marcelo
12-04-2010 04:02 AM
Find all posts by this user Quote this message in a reply
elitepilot Offline
Member
***

Posts: 352
Joined: Feb 2008
Reputation: 0
Post: #30
RE: ispCP Omega 1.0.7 Release
I got error during Upgrade(1.06 to 1.07):

sys_command() | [ERROR] External command 'perl /var/www/ispcp/engine/ispcp-rqst-mngr norestart' exited with value 1 !

Can anyone help me?


Attached File(s)
.txt  ispcp-update.log.txt (Size: 91.52 KB / Downloads: 7)
12-07-2010 12:28 AM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)