Current time: 02-26-2020, 05:20 AM Hello There, Guest! (LoginRegister)


Post Reply 
[SOLVED] websites down after update to 1.07
Author Message
fluser Offline
Documentation Team
***
Docu Team

Posts: 246
Joined: May 2010
Reputation: 1
Post: #11
RE: websites down after update to 1.07
Rename eaccelerator.ini in /etc/apache2/conf.d to eaccelerator.ini_old using mv
Edit: It is stored in /etc/php5/conf.d/

After that:
Code:
sudo /etc/init.d/apache2 restart

Let us know, if it worked! Smile

Best Regards
Fluser
(This post was last modified: 12-08-2010 01:28 AM by fluser.)
12-08-2010 01:26 AM
Find all posts by this user Quote this message in a reply
marceloctec Offline
Junior Member
*

Posts: 20
Joined: Dec 2010
Reputation: 0
Post: #12
RE: websites down after update to 1.07
(12-08-2010 01:26 AM)fluser Wrote:  Rename eaccelerator.ini in /etc/apache2/conf.d to eaccelerator.ini_old using mv
Edit: It is stored in /etc/php5/conf.d/

After that:
Code:
sudo /etc/init.d/apache2 restart

Let us know, if it worked! Smile

Best Regards
Fluser


Hi Fluser,

Don't work. Apache don't start.

If execute the command apache2ctl configtest, show me many errors

Quote:root@server:~# apache2ctl configtest
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 14:17:16 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
[Tue Dec 07 14:17:16 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
Syntax OK

Regards,
Marcelo
12-08-2010 02:18 AM
Find all posts by this user Quote this message in a reply
fluser Offline
Documentation Team
***
Docu Team

Posts: 246
Joined: May 2010
Reputation: 1
Post: #13
RE: websites down after update to 1.07
Please do this howto again. Something's wrong with your virtualhosts.
http://isp-control.net/documentation/how.../change_ip

Or post the text of /etc/apache2/sites-available/ispcp.conf or something like that

Best Regards
Fluser
12-08-2010 02:42 AM
Find all posts by this user Quote this message in a reply
marceloctec Offline
Junior Member
*

Posts: 20
Joined: Dec 2010
Reputation: 0
Post: #14
RE: websites down after update to 1.07
(12-08-2010 02:42 AM)fluser Wrote:  Please do this howto again. Something's wrong with your virtualhosts.
http://isp-control.net/documentation/how.../change_ip

Or post the text of /etc/apache2/sites-available/ispcp.conf or something like that

Best Regards
Fluser


Don't work...same error.

/etc/apache2/sites-available/ispcp.conf:

Quote: # httpd awstats support END.

# httpd dmn entry cgi support BEGIN.
# httpd dmn entry cgi support END.

<Directory /var/www/virtual/tecnomott.com.br/htdocs>
# httpd dmn entry PHP support BEGIN.
# httpd dmn entry PHP support END.
Options -Indexes Includes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
Allow from all
</Directory>

# httpd dmn entry PHP2 support BEGIN.
<IfModule mod_php5.c>
php_admin_value open_basedir "/var/www/virtual/tecnomott.com.br/:/var/www/virtual/tecnomott.com.br/phptmp/:/usr/share/php/"
php_admin_value upload_tmp_dir "/var/www/virtual/tecnomott.com.br/phptmp/"
php_admin_value session.save_path "/var/www/virtual/tecnomott.com.br/phptmp/"
php_admin_value sendmail_path '/usr/sbin/sendmail -f vu2003 -t -i'
</IfModule>
<IfModule mod_fastcgi.c>
ScriptAlias /php5/ /var/www/fcgi/tecnomott.com.br/
<Directory "/var/www/fcgi/tecnomott.com.br">
AllowOverride None
Options +ExecCGI -MultiViews -Indexes
Order allow,deny
Allow from all
</Directory>
</IfModule>
<IfModule mod_fcgid.c>
<Directory /var/www/virtual/tecnomott.com.br/htdocs>
FCGIWrapper /var/www/fcgi/tecnomott.com.br/php5-fcgi-starter .php
Options +ExecCGI
</Directory>
<Directory "/var/www/fcgi/tecnomott.com.br">
AllowOverride None
Options +ExecCGI MultiViews -Indexes
Order allow,deny
Allow from all
</Directory>
</IfModule>
# httpd dmn entry PHP2 support END.

Include /etc/apache2/ispcp/tecnomott.com.br.conf

</VirtualHost>
# httpd [tecnomott.com.br] dmn entry END.

# httpd [tecnomott.com.br] dmn group entry END.

# httpd [certitec.com.br] dmn group entry BEGIN.

<IfModule mod_cband.c>
<CBandUser certitec.com.br>
# CBandUserLimit 0Mi
# CBandUserScoreboard /var/www/scoreboards/certitec.com.br
# CBandUserPeriod 4W
# CBandUserPeriodSlice 1W
# CBandUserExceededURL http://admin.server.tecnomott.com.br/err...eeded.html
</CBandUser>
</IfModule>


# httpd [bimsolutions.certitec.com.br] sub entry BEGIN.
<VirtualHost server2-ip:80>

#
#User vu2011
#Group vu2011
#

<IfModule suexec_module>
SuexecUserGroup vu2011 vu2011
</IfModule>

ServerAdmin webmaster@certitec.com.br
DocumentRoot /var/www/virtual/certitec.com.br/bimsolutions/htdocs

ServerName bimsolutions.certitec.com.br
ServerAlias http://www.bimsolutions.certitec.com.br bimsolutions.certitec.com.br

Alias /errors /var/www/virtual/certitec.com.br/errors/

RedirectMatch permanent ^/ftp[\/]?$ http://admin.server.tecnomott.com.br/ftp/
RedirectMatch permanent ^/pma[\/]?$ http://admin.server.tecnomott.com.br/pma/
RedirectMatch permanent ^/webmail[\/]?$ http://admin.server.tecnomott.com.br/webmail/
RedirectMatch permanent ^/ispcp[\/]?$ http://admin.server.tecnomott.com.br/

ErrorDocument 401 /errors/401.html
ErrorDocument 403 /errors/403.html
ErrorDocument 404 /errors/404.html
ErrorDocument 500 /errors/500.html
ErrorDocument 503 /errors/503.html

<IfModule mod_cband.c>
CBandUser certitec.com.br
</IfModule>

# httpd sub entry redirect entry BEGIN.
# httpd sub entry redirect entry END.

# httpd sub entry cgi support BEGIN.
# httpd sub entry cgi support END.

<Directory /var/www/virtual/certitec.com.br/bimsolutions/htdocs>
# httpd sub entry PHP support BEGIN.
# httpd sub entry PHP support END.
Options -Indexes Includes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
Allow from all
</Directory>

# httpd sub entry PHP2 support BEGIN.
<IfModule mod_php5.c>
php_admin_value open_basedir "/var/www/virtual/certitec.com.br/:/var/www/virtual/certitec.com.br/phptmp/:/usr/share/php/"
php_admin_value upload_tmp_dir "/var/www/virtual/certitec.com.br/phptmp/"
php_admin_value session.save_path "/var/www/virtual/certitec.com.br/phptmp/"
php_admin_value sendmail_path '/usr/sbin/sendmail -f vu2011 -t -i'
</IfModule>
<IfModule mod_fastcgi.c>
ScriptAlias /php5/ /var/www/fcgi/certitec.com.br/
<Directory "/var/www/fcgi/certitec.com.br">
AllowOverride None
Options +ExecCGI -MultiViews -Indexes
Order allow,deny
Allow from all
</Directory>
</IfModule>
<IfModule mod_fcgid.c>
<Directory /var/www/virtual/certitec.com.br/bimsolutions/htdocs>
FCGIWrapper /var/www/fcgi/certitec.com.br/php5-fcgi-starter .php
Options +ExecCGI
</Directory>
<Directory "/var/www/fcgi/certitec.com.br">
AllowOverride None
Options +ExecCGI MultiViews -Indexes
Order allow,deny
Allow from all
</Directory>
</IfModule>
# httpd sub entry PHP2 support END.

Include /etc/apache2/ispcp/bimsolutions.certitec.com.br.conf

</VirtualHost>
# httpd [bimsolutions.certitec.com.br] sub entry END.

# httpd [{SUB_NAME}] sub entry BEGIN.
# httpd [{SUB_NAME}] sub entry END.

# httpd [certitec.com.br] dmn entry BEGIN.
<VirtualHost server2-ip:80>

<IfModule suexec_module>
SuexecUserGroup vu2011 vu2011
</IfModule>

ServerAdmin webmaster@certitec.com.br
DocumentRoot /var/www/virtual/certitec.com.br/htdocs

ServerName certitec.com.br
ServerAlias http://www.certitec.com.br certitec.com.br vu2011.admin.server.tecnomott.com.br

Alias /errors /var/www/virtual/certitec.com.br/errors/

RedirectMatch permanent ^/ftp[\/]?$ http://admin.server.tecnomott.com.br/ftp/
RedirectMatch permanent ^/pma[\/]?$ http://admin.server.tecnomott.com.br/pma/
RedirectMatch permanent ^/webmail[\/]?$ http://admin.server.tecnomott.com.br/webmail/
RedirectMatch permanent ^/ispcp[\/]?$ http://admin.server.tecnomott.com.br/

ErrorDocument 401 /errors/401.html
ErrorDocument 403 /errors/403.html
ErrorDocument 404 /errors/404.html
ErrorDocument 500 /errors/500.html
ErrorDocument 503 /errors/503.html

<IfModule mod_cband.c>
CBandUser certitec.com.br
</IfModule>

# httpd awstats support BEGIN.

# httpd awstats support END.

# httpd dmn entry cgi support BEGIN.
# httpd dmn entry cgi support END.

<Directory /var/www/virtual/certitec.com.br/htdocs>
# httpd dmn entry PHP support BEGIN.
# httpd dmn entry PHP support END.
Options -Indexes Includes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
Allow from all
</Directory>

# httpd dmn entry PHP2 support BEGIN.
<IfModule mod_php5.c>
php_admin_value open_basedir "/var/www/virtual/certitec.com.br/:/var/www/virtual/certitec.com.br/phptmp/:/usr/share/php/"
php_admin_value upload_tmp_dir "/var/www/virtual/certitec.com.br/phptmp/"
php_admin_value session.save_path "/var/www/virtual/certitec.com.br/phptmp/"
php_admin_value sendmail_path '/usr/sbin/sendmail -f vu2011 -t -i'
</IfModule>
<IfModule mod_fastcgi.c>
ScriptAlias /php5/ /var/www/fcgi/certitec.com.br/
<Directory "/var/www/fcgi/certitec.com.br">
AllowOverride None
Options +ExecCGI -MultiViews -Indexes
Order allow,deny
Allow from all
</Directory>
</IfModule>
<IfModule mod_fcgid.c>
<Directory /var/www/virtual/certitec.com.br/htdocs>
FCGIWrapper /var/www/fcgi/certitec.com.br/php5-fcgi-starter .php
Options +ExecCGI
</Directory>
<Directory "/var/www/fcgi/certitec.com.br">
AllowOverride None
Options +ExecCGI MultiViews -Indexes
Order allow,deny
Allow from all
</Directory>
</IfModule>
# httpd dmn entry PHP2 support END.

Include /etc/apache2/ispcp/certitec.com.br.conf

</VirtualHost>
# httpd [certitec.com.br] dmn entry END.

# httpd [certitec.com.br] dmn group entry END.


# httpd [{ALS_NAME}] als entry BEGIN.
# httpd [{ALS_NAME}] als entry END.

# httpd [server2-ip] virtual host entry END.

# httpd [{IP}] virtual host entry BEGIN.
# httpd [{IP}] virtual host entry END.

# httpd Data END.


If I try reinstall 1.07 upgrade, the error appears.

/var/log/ispcp/setup/ispcp-update.log

Quote:sys_command('/usr/sbin/a2enmod suexec') | Ending...
sys_command() | Starting...
system() | [DEBUG] ERROR: Site ispcp.conf not properly enabled: /etc/apache2/sites-enabled/ispcp.conf is a real file, not touching it
getCmdExitValue() | Starting...
getCmdExitValue() | [DEBUG] External command exited with value 1
getCmdExitValue() | Ending...
sys_command() | [ERROR] External command '/usr/sbin/a2ensite ispcp.conf' exited with value 1 !
exit_msg() | Starting...
exit_msg() | Ending...
del_file() | Starting...
del_file() | Ending...



Regards,
Marcelo
Fluser,

wher you see "server2-ip", is my server ip.

But, don't work...the same problem.

regards
(This post was last modified: 12-08-2010 03:38 AM by marceloctec.)
12-08-2010 03:18 AM
Find all posts by this user Quote this message in a reply
fluser Offline
Documentation Team
***
Docu Team

Posts: 246
Joined: May 2010
Reputation: 1
Post: #15
RE: websites down after update to 1.07
This is your problem: <VirtualHost server2>
replace it with your ipadress
12-08-2010 03:57 AM
Find all posts by this user Quote this message in a reply
marceloctec Offline
Junior Member
*

Posts: 20
Joined: Dec 2010
Reputation: 0
Post: #16
RE: websites down after update to 1.07
Hi Fluser,

I can install the update now, but apache don't work.

I remove the /etc/apache2/sites-enabled/ispcp.conf (a normal file) and the update generate a new file. A symbolic link.

Could you tell me what files are simbolic liks?

Regards,
Marcelo


(12-08-2010 03:57 AM)fluser Wrote:  This is your problem: <VirtualHost server2>
replace it with your ipadress

Only /etc/apache2/sites-available/ispcp.conf ? If yes, I did.
(This post was last modified: 12-08-2010 04:19 AM by marceloctec.)
12-08-2010 04:14 AM
Find all posts by this user Quote this message in a reply
marceloctec Offline
Junior Member
*

Posts: 20
Joined: Dec 2010
Reputation: 0
Post: #17
RE: websites down after update to 1.07
I replace the ip adress in the file /etc/apache2/sites-available/ispcp.conf, but don't work.

And the command apache2ctl configtest, show me many errors.
Quote:root@server:~# apache2ctl configtest
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [error] (EAI 2)Name or service not known: Could not resolve host name server2-ip -- ignoring!
[Tue Dec 07 17:24:15 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
Syntax OK



This is a mods-enabled folder. Thats correct?

Quote:root@server:/etc/apache2/mods-enabled# ls
actions.conf authn_file.load autoindex.conf deflate.conf fcgid.conf.save mime.load proxy_html.load setenvif.load
actions.load authz_default.load autoindex.load deflate.load fcgid_ispcp.conf negotiation.conf proxy_http.load status.conf
alias.conf authz_groupfile.load cgid.conf dir.conf fcgid_ispcp.load negotiation.load proxy.load status.load
alias.load authz_host.load cgid.load dir.load include.load proxy.conf rewrite.load suexec.load
auth_basic.load authz_user.load cgi.load env.load mime.conf proxy_html.conf setenvif.conf


The files to apache work properly is here?

I can't run my server.

Regards,
Marcelo
12-08-2010 05:27 AM
Find all posts by this user Quote this message in a reply
fluser Offline
Documentation Team
***
Docu Team

Posts: 246
Joined: May 2010
Reputation: 1
Post: #18
RE: websites down after update to 1.07
What I did:
a2dissite 00_master.conf
a2dissite ispcp.conf

I moved all files from /etc/apache2/sites-enabled/* to /root because in /etc/apache2/sites-enabled/* should only be symlinks and not files.

Edit: After moving all files from /etc/apache2/sites-enabled/* I ran apache2ctl configtest and all what I get back was "Syntax OK". So there was one of the problems.

moved /etc/apache2/httpd.conf to /etc/apache2/httpd.conf_bck
because this was the biggest problem. The text in the file is wrong. Maybe something is needed, so I didn't delete it.

After that, I created an empty file /etc/apache2/httpd.conf

after /etc/init.d/apache2.1 restart
all worked again.

Best Regards
Fluser
(This post was last modified: 12-08-2010 09:45 PM by fluser.)
12-08-2010 09:21 PM
Find all posts by this user Quote this message in a reply
marceloctec Offline
Junior Member
*

Posts: 20
Joined: Dec 2010
Reputation: 0
Post: #19
SOLVED: websites down after update to 1.07
(12-08-2010 09:21 PM)fluser Wrote:  What I did:
a2dissite 00_master.conf
a2dissite ispcp.conf

I moved all files from /etc/apache2/sites-enabled/* to /root because in /etc/apache2/sites-enabled/* should only be symlinks and not files.

Edit: After moving all files from /etc/apache2/sites-enabled/* I ran apache2ctl configtest and all what I get back was "Syntax OK". So there was one of the problems.

moved /etc/apache2/httpd.conf to /etc/apache2/httpd.conf_bck
because this was the biggest problem. The text in the file is wrong. Maybe something is needed, so I didn't delete it.

After that, I created an empty file /etc/apache2/httpd.conf

after /etc/init.d/apache2 restart
all worked again.

Best Regards
Fluser


Thanks Flusher.
12-09-2010 05:20 AM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)