Current time: 08-16-2022, 06:08 AM Hello There, Guest! (LoginRegister)


Post Reply 
Dovecot authentication error
Author Message
evopark Offline


Posts: 3
Joined: Jul 2010
Reputation: 0
Post: #1
Dovecot authentication error
Hi!

After the Update from ispcp 1.0.5 to 1.0.7, dovecot mail server couldn't check the mailpasswords.

In the syslog are this errors:


Quote:Dec 15 02:43:57 evomail1 postfix/smtpd[3245]: connect from unknown[93.185.128.229]
Dec 15 02:43:57 evomail1 dovecot: auth(default): new auth connection: pid=3245
Dec 15 02:43:57 evomail1 dovecot: auth(default): client in: AUTH#0111#011LOGIN#011service=smtp#011nologin#011lip=178.63.14.115#011rip=93.185​.128.229
Dec 15 02:43:57 evomail1 dovecot: auth(default): client out: XXX
Dec 15 02:43:57 evomail1 dovecot: auth(default): client in: XXX
Dec 15 02:43:57 evomail1 dovecot: auth(default): client out: XXX
Dec 15 02:43:57 evomail1 dovecot: auth(default): client in: XXX
Dec 15 02:43:57 evomail1 dovecot: auth(default): checkpassword(peter@mechatronixs.com,93.185.128.229): execute: /var/www/ispcp/engine/ispcp-dovecot-mngr /usr/lib/dovecot/checkpassword-reply
Dec 15 02:43:57 evomail1 dovecot: auth(default):
Dec 15 02:43:57 evomail1 dovecot: auth(default): [FATAL] Module [File::Copy::Recursive] WAS NOT FOUND !
Dec 15 02:43:57 evomail1 dovecot: auth(default):
Dec 15 02:43:57 evomail1 dovecot: auth(default): Modules [File::Copy::Recursive] WAS NOT FOUND in your system...
Dec 15 02:43:57 evomail1 dovecot: auth(default): checkpassword(peter@mechatronixs.com,93.185.128.229): Received no input
Dec 15 02:43:57 evomail1 dovecot: auth(default): checkpassword(peter@mechatronixs.com,93.185.128.229): exit_status=1
Dec 15 02:43:57 evomail1 dovecot: auth(default): checkpassword(peter@mechatronixs.com,93.185.128.229): Login failed (status=1)
Dec 15 02:43:59 evomail1 dovecot: auth(default): client out: FAIL#0111#011user=peter@mechatronixs.com
Dec 15 02:43:59 evomail1 postfix/smtpd[3245]: warning: unknown[93.185.128.229]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
Dec 15 02:43:59 evomail1 postfix/smtpd[3245]: lost connection after AUTH from unknown[93.185.128.229]
Dec 15 02:43:59 evomail1 postfix/smtpd[3245]: disconnect from unknown[93.185.128.229]
Quote:I don't change any Config Files of dovecot during update.

Can anyone help me please!!!

Thanks!
(This post was last modified: 12-15-2010 05:42 PM by Zothos.)
12-15-2010 11:47 AM
Find all posts by this user Quote this message in a reply
fluser Offline
Documentation Team
***
Docu Team

Posts: 246
Joined: May 2010
Reputation: 1
Post: #2
RE: Dovecot authentication error
See into the howto. The authentication script changed. Replace it and it will work againSmile

Best Regards
Fluser
12-15-2010 02:09 PM
Find all posts by this user Quote this message in a reply
motokochan Offline
Member
***

Posts: 274
Joined: Jul 2008
Reputation: 1
Post: #3
RE: Dovecot authentication error
evopark, change the password for that account immediately. You provided the password in your first post (base64 can be easily reversed).
12-15-2010 04:01 PM
Visit this user's website Find all posts by this user Quote this message in a reply
gutek Offline
Junior Member
*

Posts: 11
Joined: May 2008
Reputation: 0
Post: #4
RE: Dovecot authentication error
(12-15-2010 02:09 PM)fluser Wrote:  See into the howto. The authentication script changed. Replace it and it will work againSmile

Best Regards
Fluser

Hello,

i have the same problem, incorect password or username Sad Where i can find new authentication script? I have tried tis one (http://isp-control.net/forum/thread-6088-page-1.html) , but still i cant log in with dovecot.

Best regards
Gutek
01-06-2011 10:52 PM
Find all posts by this user Quote this message in a reply
fluser Offline
Documentation Team
***
Docu Team

Posts: 246
Joined: May 2010
Reputation: 1
Post: #5
RE: Dovecot authentication error
How did you renamed the script?
01-06-2011 11:17 PM
Find all posts by this user Quote this message in a reply
aseques Offline
Member
*****
Dev Team

Posts: 330
Joined: May 2008
Reputation: 4
Post: #6
RE: Dovecot authentication error
(01-06-2011 11:17 PM)fluser Wrote:  How did you renamed the script?
The problem appears to be with this missing component:
[FATAL] Module [File::Copy::Recursive] WAS NOT FOUND !

Just doing this should fix it ...
Code:
apt-get install libfile-copy-recursive-perl
01-07-2011 05:53 PM
Find all posts by this user Quote this message in a reply
gutek Offline
Junior Member
*

Posts: 11
Joined: May 2008
Reputation: 0
Post: #7
RE: Dovecot authentication error
problem solved.

Script was OK, but all old e-mail passwords gone in /dev/null (i had to regenerate all email passwords) just like in thread http://isp-control.net/forum/thread-12346.html

Best Regards
Gutek
01-08-2011 06:16 AM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)