Current time: 09-25-2018, 12:07 AM Hello There, Guest! (LoginRegister)


Post Reply 
iscp 1.0.7 is not installed on FreeBSD 8.1
Author Message
schmel Offline
Junior Member
*

Posts: 65
Joined: May 2010
Reputation: 0
Post: #11
RE: iscp 1.0.7 is not installed on FreeBSD 8.1
I replaced the maintainer-helper.sh
http://isp-control.net/ispcp/browser/tru...v=3701#L69
else this error:
http://isp-control.net/forum/thread-12315-page-1.html

Error at the last stage of the installation:
# perl ./ispcp-setup

Code:
GUI setup
         * ispCP GUI Bind9 configuration:        [ Done ]
         * ispCP GUI fastCGI/PHP configuration:  [ Done ]
         * ispCP GUI vhost file:                 [ Done ]
         * ispCP PMA configuration file:         [ Done ]
Post-installation tasks for freeBSD
Version: not found
[FATAL] An error occurred during setup process!
Correct it and re-run this program.
It's last lines in logs:
Code:
sys_command()                  | Starting...
getCmdExitValue()              | Starting...
getCmdExitValue()              | [DEBUG] External command exited with value 127
getCmdExitValue()              | Ending...
sys_command()                  | [ERROR] External command '/bin/sh postinst configure' exited with value 127 !
exit_msg()                     | Starting...
exit_msg()                     | Ending...
del_file()                     | Starting...
del_file()                     | Ending...
how to fix it?
translate by google
(This post was last modified: 01-30-2011 07:24 PM by schmel.)
01-25-2011 05:09 AM
Find all posts by this user Quote this message in a reply
schmel Offline
Junior Member
*

Posts: 65
Joined: May 2010
Reputation: 0
Post: #12
RE: iscp 1.0.7 is not installed on FreeBSD 8.1
up. problem is relevant
03-08-2011 06:15 PM
Find all posts by this user Quote this message in a reply
thewiizard Offline
Newbie
*

Posts: 5
Joined: Mar 2011
Reputation: 0
Post: #13
RE: iscp 1.0.7 is not installed on FreeBSD 8.1
having the same problem on 8.2 after quite a few others.

/usr/local/bin/bash postinst configure
./maintainer-helper.sh: line 71: Version: command not found

also, setup failed on a few files being missing but managed to find these in trunk.

database/database.sql
pma/config.inc.tpl
pma/working/config.inc.tpl

Also doesn't like UTC as a time zone.
03-10-2011 11:09 AM
Find all posts by this user Quote this message in a reply
schmel Offline
Junior Member
*

Posts: 65
Joined: May 2010
Reputation: 0
Post: #14
RE: iscp 1.0.7 is not installed on FreeBSD 8.1
I got install. FreeBSD 8.2 x64, nightly build from 19/04/2011. Errors were at the stage of the database and pma. The solution was simple, copy the folders - databases of pma ./ispcp/configs/common/ in /usr/local/etc/ispcp

ispcp 1.0.7 supports fcgid for FreeBSD? I installe with FastCGI...
04-20-2011 10:48 PM
Find all posts by this user Quote this message in a reply
schmel Offline
Junior Member
*

Posts: 65
Joined: May 2010
Reputation: 0
Post: #15
RE: iscp 1.0.7 is not installed on FreeBSD 8.1
if you use a script set-gui-permissions.sh
Code:
hosting# ./set-gui-permissions.sh
MR_LOCK_FILE: not found
CMD_AWK: not found
CMD_BZCAT: not found
CMD_BZIP: not found
CMD_CHOWN: not found
CMD_CAT: not found
CMD_CHMOD: not found
CMD_CP: not found
CMD_DIFF: not found
CMD_CMP: not found
CMD_DF: not found
CMD_DU: not found
CMD_ECHO: not found
CMD_EGREP: not found
CMD_GZCAT: not found
CMD_GZIP: not found
CMD_GREP: not found
CMD_GROUPADD: not found
CMD_GROUPDEL: not found
CMD_HOSTNAME: not found
CMD_IFCONFIG: not found
CMD_IPTABLES: not found
CMD_LN: not found
............................
for some reason this script during the installation did not work out. and all the folders and files to the owner of "33 ". had to manually put all the files vu2000: www ... Then it worked.
04-23-2011 05:17 PM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)