Current time: 06-19-2018, 02:44 PM Hello There, Guest! (LoginRegister)


Post Reply 
Error after Update to php 5.3
Author Message
C-Cosmo Offline


Posts: 2
Joined: Oct 2011
Reputation: 0
Post: #1
Exclamation Error after Update to php 5.3
I updated my php and mysql Versions.

After that I have a lot of Errors.

At Adminpannel:
Quote:Warning: require_once(/var/www/ispcp/gui/include/ispcp-db-keys.php): failed to open stream: Permission denied in /var/www/ispcp/gui/include/ispcp-lib.php on line 90 Fatal error: require_once(): Failed opening required '/var/www/ispcp/gui/include/ispcp-db-keys.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/ispcp/gui/include/ispcp-lib.php on line 90

At phpmyadmin:
Quote:Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.

At Website:
http://ultimate-esport.de

php -v:
Quote:PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/adodb.so' - /usr/lib/php5/20090626/adodb.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/mhash.so' - /usr/lib/php5/20090626/mhash.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP 5.3.8-1~dotdeb.1 with Suhosin-Patch (cli) (built: Aug 26 2011 12:46:54)
Copyright © 1997-2011 The PHP Group
Zend Engine v2.3.0, Copyright © 1998-2011 Zend Technologies
with Suhosin v0.9.32.1, Copyright © 2007-2010, by SektionEins GmbH
The Chmod Permissions at the Website are the same as they was.

Please help me what to do!
10-18-2011 05:41 PM
Find all posts by this user Quote this message in a reply
DragonZX Offline
Moderator
*****
Moderators

Posts: 441
Joined: Aug 2010
Reputation: 5
Post: #2
RE: Error after Update to php 5.3
Ask the developer for update. This engine doesn't support php 5.3 Another variant is to use community cms like Joomla or Drupal
10-19-2011 12:42 AM
Visit this user's website Find all posts by this user Quote this message in a reply
C-Cosmo Offline


Posts: 2
Joined: Oct 2011
Reputation: 0
Post: #3
RE: Error after Update to php 5.3
Its not only the Problem with this System.

Have a look at the ispCP Controll Pannel..
phpmyadmin doesn't work too..

Adminpannel: admin.dj-cosmo.net
phpmyadmin: admin.dj-cosmo.net/pma
(This post was last modified: 10-19-2011 12:53 AM by C-Cosmo.)
10-19-2011 12:52 AM
Find all posts by this user Quote this message in a reply
DragonZX Offline
Moderator
*****
Moderators

Posts: 441
Joined: Aug 2010
Reputation: 5
Post: #4
RE: Error after Update to php 5.3
Update the phpmyadmin to the latest version. You may use http://isp-control.net/forum/thread-15349.html to update it quickly.
If update won't help, write here a pma error
10-20-2011 02:39 AM
Visit this user's website Find all posts by this user Quote this message in a reply
akora Offline


Posts: 2
Joined: Feb 2012
Reputation: 0
Post: #5
RE: Error after Update to php 5.3
I´m having the same problem, just update the ispCP to 1.0.7 (from 1.0.5) on Lenny, everything worked. Then I updated the PHP from 5.2 to 5.3 and after that nothing works.

I noticed that if I change chmod to 644 on this file "/var/www/ispcp/gui/include/ispcp-db-keys.php" I can reach the login page, but I can not login. And no websites works. So I think it has something to do with rights and I will keep search for the answear in that direction.

If you found a solution, please post it back here.

EDIT: When I look in the combined log for a website, it tells me its a 500 error:
[24/Feb/2012:10:34:37 +0100] "GET / HTTP/1.1" 500 - "-"
(This post was last modified: 02-24-2012 07:35 PM by akora.)
02-24-2012 07:34 PM
Find all posts by this user Quote this message in a reply
joximu Offline
helper
*****
Moderators

Posts: 7,039
Joined: Jan 2007
Reputation: 92
Post: #6
RE: Error after Update to php 5.3
Since lenny is outdated - maybe upgrading to squeeze (which includes php 5.3) is an option.

ispcp 1.0.7 can run on squeeze... (a.g. deactivate the display of deprecated errors).

/J
02-24-2012 10:41 PM
Visit this user's website Find all posts by this user Quote this message in a reply
iCeFrEsH Offline
Junior Member
*

Posts: 25
Joined: Mar 2008
Reputation: 0
Post: #7
RE: Error after Update to php 5.3
I've the same problem on squeeze! Can't log on to my ispCP anymore. Any idea what to do??

edit: fixed it myself.
did the following:

chmod 644 /var/www/ispcp/gui/include/ispcp-db-keys.php
chmod 644 /var/www/ispcp/gui/include/ispcp-lib.php
chmod 644 /var/www/ispcp/gui/include/ispCP/Initializer.php
chmod 777 /var/www/ispcp/gui/phptmp/
(This post was last modified: 07-13-2012 01:35 PM by iCeFrEsH.)
07-13-2012 01:26 PM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)