Current time: 10-18-2019, 07:22 PM Hello There, Guest! (LoginRegister)


Thread Closed 
[fixed] ERROR: Module fastcgi_ispcp does not exist!
Author Message
sakal Offline
Junior Member
*

Posts: 42
Joined: Mar 2010
Reputation: 0
Post: #1
[fixed] ERROR: Module fastcgi_ispcp does not exist!
Hello all, after one year i decide to forgot on my old "ispCP Omega 1.0.6" and try to install new version : '1.1.0 Beta 1OMEGA'

of course there is error waiting for my and i cannot find answer why i so lucky to have it Wink

My OS: Description: Debian GNU/Linux 5.0.9 (lenny)

error in installation:

Quote: * ispCP Bind9 main configuration file: [ Done ]
* ispCP Apache fastCGI modules configuration: [ Failed ]

[FATAL] An error occurred during setup process!

info from : /var/log/ispcp/setup/ispcp-setup.log

Quote:getCmdExitValue() | Starting...
getCmdExitValue() | [DEBUG] External command exited with value 0
getCmdExitValue() | Ending...
sys_command('/bin/cp -pf /etc/ispcp/apache/working/fcgid_ispcp.load /etc/apache2/mods-available/') | Ending...
sys_command() | Starting...
system() | [DEBUG] ERROR: Module php4 does not exist!
Module php5 already disabled
getCmdExitValue() | Starting...
getCmdExitValue() | [DEBUG] External command exited with value 1
getCmdExitValue() | Ending...
sys_command() | [ERROR] External command '/usr/sbin/a2dismod php4 php5' exited with value 1 !
sys_command() | Starting...
system() | [DEBUG] Module actions already enabled
getCmdExitValue() | Starting...
getCmdExitValue() | [DEBUG] External command exited with value 0
getCmdExitValue() | Ending...
sys_command('/usr/sbin/a2enmod actions') | Ending...
sys_command() | Starting...
system() | [DEBUG] Module fcgid_ispcp disabled.
Run '/etc/init.d/apache2 restart' to activate new configuration!
getCmdExitValue() | Starting...
getCmdExitValue() | [DEBUG] External command exited with value 0
getCmdExitValue() | Ending...
sys_command('/usr/sbin/a2dismod fcgid_ispcp') | Ending...
sys_command() | Starting...
system() | [DEBUG] ERROR: Module fastcgi_ispcp does not exist!
getCmdExitValue() | Starting...
getCmdExitValue() | [DEBUG] External command exited with value 1
getCmdExitValue() | Ending...
sys_command() | [ERROR] External command '/usr/sbin/a2enmod fastcgi_ispcp' exited with value 1 !
exit_msg() | Starting...
exit_msg() | Ending...
del_file() | Starting...
del_file() | Ending...


Can somebody tell my why i am so lucky to have this error ? Smile
(This post was last modified: 01-11-2012 10:42 PM by joximu.)
01-10-2012 10:19 PM
Find all posts by this user
joximu Offline
helper
*****
Moderators

Posts: 7,034
Joined: Jan 2007
Reputation: 92
Post: #2
RE: ERROR: Module fastcgi_ispcp does not exist!
You have to decide what sort of PHP you'd like.

mod_php
php with fcgid
php with fastcgi

and you have to install exactly those apache libraries which fit your decision.

some of them are not in the default apt-get sources... you may add the non-free sources

See http://packages.debian.org/squeeze/libap...od-fastcgi

/J
01-10-2012 10:57 PM
Visit this user's website Find all posts by this user
sakal Offline
Junior Member
*

Posts: 42
Joined: Mar 2010
Reputation: 0
Post: #3
RE: ERROR: Module fastcgi_ispcp does not exist!
Thanks for your help joximu
your answer help my to solve problem, this is solution:

add to your /etc/apt/sources.list :

Quote:deb http://ftp.de.debian.org/debian squeeze main non-free

next:

Quote:apt-get update
apt-get upgrade
apt-get install libapache2-mod-fastcgi

After this all works fine and gr8. Shy

Thanks for your help AGAIN!!!! Wink
01-11-2012 01:17 AM
Find all posts by this user
joximu Offline
helper
*****
Moderators

Posts: 7,034
Joined: Jan 2007
Reputation: 92
Post: #4
RE: ERROR: Module fastcgi_ispcp does not exist!
You're welcome.
[close]
01-11-2012 10:42 PM
Visit this user's website Find all posts by this user
Thread Closed 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)