Current time: 12-08-2021, 09:48 PM Hello There, Guest! (LoginRegister)


Post Reply 
[Resuelto] No puedo conectar con servidor POP3 despues de migrar servidor y version
Author Message
amorales Offline
Junior Member
*

Posts: 29
Joined: Nov 2008
Reputation: 0
Post: #1
[Resuelto] No puedo conectar con servidor POP3 despues de migrar servidor y version
Hola.

He reinstalado en una nueva maquina ISPCP 1.0.7 y migrado desde otra maquina que tenia una versión 1.0.0RC. Después he basculado la IPFailover (Ovh) de uno al otro y he cambiado la IP del servidor como comenta Kurgans en este post en el punto 6.3: http://isp-control.net/forum/thread-5210...l#pid43448

Todo ha ido más o menos bien hasta que he probado una cuenta con Outlook y Pop3 (Con IMAP va bien).

Dede webmail funciona todo bien. He chequeado el servidor pop3 por un agente externo via web y ha ido OK.

La cuestión es que cuando elijo POP3 me salta un error que dice:
Cannot connect to POP Server <MI_IP> (<MI_IP:995> connect error 10061

Las configuraciones de la cuenta de correo están bien porque no es la primera vez que lo configuro.
Servidor entrante y saliente: mail.dominio.tld
nombre de usuario: @correo
Servidor de salida requiere autenticacion
Puertos por defecto 110 y 25

La historia es que parece que trata de conectarse sobre pop3ssl y no se por qué.

Alguna idea?

Se me olvidaba lo he probado desde Outlook2007.
(This post was last modified: 02-01-2012 10:09 PM by kurgans.)
02-01-2012 01:53 PM
Find all posts by this user Quote this message in a reply
kurgans Offline
Moderator
*****
Moderators

Posts: 1,565
Joined: Feb 2008
Reputation: 23
Post: #2
RE: No puedo conectar con servidor POP3 despues de migrar de servidor y version
Eso tendras que ver el log del correo, como que el del outlook no sirve para mucho solo que no conecta pero la razon la tienes en tu log
02-01-2012 08:33 PM
Visit this user's website Find all posts by this user Quote this message in a reply
amorales Offline
Junior Member
*

Posts: 29
Joined: Nov 2008
Reputation: 0
Post: #3
RE: No puedo conectar con servidor POP3 despues de migrar de servidor y version
(02-01-2012 08:33 PM)kurgans Wrote:  Eso tendras que ver el log del correo, como que el del outlook no sirve para mucho solo que no conecta pero la razon la tienes en tu log

Justo ahora estaba viendolo...

Este es lo que me sale en el log de mail.info
Code:
Feb  1 11:06:28 emserver03 postfix/smtpd[5375]: warning: No server certs available. TLS won't be enabled
Feb  1 11:06:28 emserver03 postfix/smtpd[5375]: connect from 84.124.154.24.dyn.user.ono.com[84.124.154.24]
Feb  1 11:06:28 emserver03 postfix/smtpd[5375]: warning: Wrapper-mode request dropped from 84.124.154.24.dyn.user.ono.com[84.124.154.24] for service
smtps. TLS context initialization failed. For details see earlier warnings in your logs.
Feb  1 11:06:28 emserver03 postfix/smtpd[5375]: disconnect from 84.124.154.24.dyn.user.ono.com[84.124.154.24]
Feb  1 11:06:28 emserver03 postfix/smtpd[5375]: connect from 84.124.154.24.dyn.user.ono.com[84.124.154.24]
Feb  1 11:06:28 emserver03 postfix/smtpd[5375]: warning: Wrapper-mode request dropped from 84.124.154.24.dyn.user.ono.com[84.124.154.24] for service
smtps. TLS context initialization failed. For details see earlier warnings in your logs.
Feb  1 11:06:28 emserver03 postfix/smtpd[5375]: disconnect from 84.124.154.24.dyn.user.ono.com[84.124.154.24]
Feb  1 11:06:28 emserver03 postfix/smtpd[5375]: connect from 84.124.154.24.dyn.user.ono.com[84.124.154.24]
Feb  1 11:06:28 emserver03 postfix/smtpd[5375]: warning: Wrapper-mode request dropped from 84.124.154.24.dyn.user.ono.com[84.124.154.24] for service
smtps. TLS context initialization failed. For details see earlier warnings in your logs.
Feb  1 11:06:28 emserver03 postfix/smtpd[5375]: disconnect from 84.124.154.24.dyn.user.ono.com[84.124.154.24]
Feb  1 11:06:28 emserver03 postfix/smtpd[5376]: warning: No server certs available. TLS won't be enabled



Tengo que comentar que lo he probado en esa ocasión con Thunderbird. Thunderbird salta con que no se ha podido verificar la configuración. Con Outlook me pasa igual.

Además de esos warnings me sale lo siguiente:

Code:
Feb  1 11:38:38 emserver03 postfix/smtpd[5883]: warning: SASL authentication failure: no secret in database
Feb  1 11:38:38 emserver03 postfix/smtpd[5883]: warning: 219.Red-95-124-220.staticIP.rima-tde.net[95.124.220.219]: SASL NTLM authentication failed: a
uthentication failure
Feb  1 11:38:38 emserver03 postfix/smtpd[5883]: warning: SASL authentication failure: realm changed: authentication aborted
Feb  1 11:38:38 emserver03 postfix/smtpd[5883]: warning: 219.Red-95-124-220.staticIP.rima-tde.net[95.124.220.219]: SASL DIGEST-MD5 authentication fai
led: authentication failure

Pero no es en la misma petición de acceso. He leido que se pueden saltar las autenticaciones SASL añadiendo esto:
/etc/postfix/sasl/smtpd.conf

En ese fichero que hay que crear añadir:
mech_list: plain login
(This post was last modified: 02-01-2012 08:47 PM by amorales.)
02-01-2012 08:38 PM
Find all posts by this user Quote this message in a reply
kurgans Offline
Moderator
*****
Moderators

Posts: 1,565
Joined: Feb 2008
Reputation: 23
Post: #4
RE: No puedo conectar con servidor POP3 despues de migrar de servidor y version
Bastaria con eso y reiniciar postfix y verificar que no estas usando el puerto tls que no esta habilitado en la config de postfix

Quote:echo 'mech_list: plain login' > /etc/postfix/sasl/smtpd.conf && /etc/init.d/postfix restart
02-01-2012 09:02 PM
Visit this user's website Find all posts by this user Quote this message in a reply
amorales Offline
Junior Member
*

Posts: 29
Joined: Nov 2008
Reputation: 0
Post: #5
RE: No puedo conectar con servidor POP3 despues de migrar de servidor y version
(02-01-2012 09:02 PM)kurgans Wrote:  Bastaria con eso y reiniciar postfix y verificar que no estas usando el puerto tls que no esta habilitado en la config de postfix

Quote:echo 'mech_list: plain login' > /etc/postfix/sasl/smtpd.conf && /etc/init.d/postfix restart


Me acaban de confirmar que desde otra ubicación si pueden conectar con POP3 por lo que me decanto por problemas de conexión mia.

He puesto el Plain Login para SASL y ya no están apareciendo los warnings de SASL.

El hecho que no me funcione a mi no se a que se puede deber. Voy a investigar un poquillo.

Gracias por la rapidez Kurgans!
02-01-2012 09:05 PM
Find all posts by this user Quote this message in a reply
kurgans Offline
Moderator
*****
Moderators

Posts: 1,565
Joined: Feb 2008
Reputation: 23
Post: #6
RE: No puedo conectar con servidor POP3 despues de migrar de servidor y version
Pos puede ser que tu puerto 25 esta ko
Ponle el 587 es el que trae por defecto ispcp para estos casos
Reinicia postfix y a probar
02-01-2012 09:10 PM
Visit this user's website Find all posts by this user Quote this message in a reply
amorales Offline
Junior Member
*

Posts: 29
Joined: Nov 2008
Reputation: 0
Post: #7
RE: No puedo conectar con servidor POP3 despues de migrar de servidor y version
(02-01-2012 09:10 PM)kurgans Wrote:  Pos puede ser que tu puerto 25 esta ko
Ponle el 587 es el que trae por defecto ispcp para estos casos
Reinicia postfix y a probar

Te refieres a que el puerto 25 del servidor esta KO?

Otros usuarios desde otras ubicaciones si entran. No tiene más sentido que sea algún problema de mi ISP que en este caso es ONO?

Edito:
Algo como lo que comenta Killburn en este hilo... http://isp-control.net/forum/thread-11124.html
(This post was last modified: 02-01-2012 09:16 PM by amorales.)
02-01-2012 09:15 PM
Find all posts by this user Quote this message in a reply
kurgans Offline
Moderator
*****
Moderators

Posts: 1,565
Joined: Feb 2008
Reputation: 23
Post: #8
RE: No puedo conectar con servidor POP3 despues de migrar de servidor y version
No al tuyo de tu adsl, a tu server no le cierran el puerto
En tu config de outlook vete a los puertos y cambia el 25 por 587 en el smtp
(This post was last modified: 02-01-2012 10:10 PM by kurgans.)
02-01-2012 09:16 PM
Visit this user's website Find all posts by this user Quote this message in a reply
amorales Offline
Junior Member
*

Posts: 29
Joined: Nov 2008
Reputation: 0
Post: #9
RE: No puedo conectar con servidor POP3 despues de migrar de servidor y version
(02-01-2012 09:16 PM)kurgans Wrote:  No al tuyo de tu adsl, a tu server no le cierran el puerto
En tu config de outlook vete a los puertos y cambia el 25 por 587 en el smtp

Ok...

Nada sigue igual. Con Thunderbird lo mismo.

Haciendo comprobaciones...

Si elijo IMAP funciona bien aunque me salta un Warning todavía. (el del wrapper)

Si elijo POP3 no conecta y me saltan los 2 warnings (No server certs available y wrapper)

Edito...
Voy a reiniciar mi PC por descartar algun problema de mi maquina.
(02-01-2012 09:26 PM)amorales Wrote:  
(02-01-2012 09:16 PM)kurgans Wrote:  No al tuyo de tu adsl, a tu server no le cierran el puerto
En tu config de outlook vete a los puertos y cambia el 25 por 587 en el smtp

Ok...

Nada sigue igual. Con Thunderbird lo mismo.

Haciendo comprobaciones...

Si elijo IMAP funciona bien aunque me salta un Warning todavía. (el del wrapper)

Si elijo POP3 no conecta y me saltan los 2 warnings (No server certs available y wrapper)

Edito...
Voy a reiniciar mi PC por descartar algun problema de mi maquina.

Hola de nuevo.

Viendo que posibles causas de mi maquina he visto que el p*** antivirus me estaba bloqueando el correo. Lo he desactivado y funciona a la perfección.

Gracias por todo!

PD: Si lo sé... error de novato
(This post was last modified: 02-01-2012 10:11 PM by kurgans.)
02-01-2012 09:26 PM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)