Current time: 07-06-2020, 02:34 AM Hello There, Guest! (LoginRegister)


Thread Closed 
[solved] Emails don't go out to MX records, only internally
Author Message
RouterRat Offline
Junior Member
*

Posts: 30
Joined: Mar 2011
Reputation: 0
Post: #1
[solved] Emails don't go out to MX records, only internally
Hi,

I have a client that I am hosting on ispCP.
I am using another server for email(Google apps).

When my contact form sends email to info@mysite.com, server goes and puts it in the inbox on ispCP not out to Google..

How do I tell it to go out to where my MX records point in my Registrar's control panel.

-----
Same thing happens if two of my clients are hosted in same server, ispCP is sending emails internally, they are not going to the internet.

*btw my ispCP has a local addres it's interface is behind a firewall with NAT does this makes a difference?
(This post was last modified: 03-31-2012 08:04 AM by joximu.)
03-29-2012 12:32 PM
Find all posts by this user
joximu Offline
helper
*****
Moderators

Posts: 7,024
Joined: Jan 2007
Reputation: 92
Post: #2
RE: Emails don't go out to MX records, only internally
you should create the customer with "mail disabled" - then ispcp does not tell postfix to watch for this domain.

Now - to change things:
- set Mail to disabled for that customer
(maybe remove all mail addresses from the customer first - also the 3 default adresses)
- remove the domainname from /etc/ispcp/postfix/working/domains and from /etc/postfix/ispcp/domains
- run "postmap /etc/postfix/ispcp/domains
- be sure that either the server uses an external dns (not the bind on the ispcp server) - or make sure that the MX record on the local bind for this domain points to the correct external server

/J
03-29-2012 07:58 PM
Visit this user's website Find all posts by this user
RouterRat Offline
Junior Member
*

Posts: 30
Joined: Mar 2011
Reputation: 0
Post: #3
RE: Emails don't go out to MX records, only internally
Manage Users > mydomain.com > Edit Domain >
Mail accounts limit
(-1 disabled, 0 unlimited)
I've changed this section to -1 , after deleting all of the emails from the domain.


/etc/ispcp/postfix/working/domains
/etc/postfix/ispcp/domains

mydomain.com vdmn_entry, I found these and put # at the beginning.
Like this;
#mydomain.com vdmn_entry

Then ran postmap /etc/postfix/ispcp/domains .. It took it, didn't see any response from CLI.

When I do "ifconfig" , my first two name servers are from my ISP and 3rd one is 8.8.4.4

"make sure that the MX record on the local bind for this domain points to the correct external server"
How do I do this?

is it from" Add DNS zone's record "?

Thanks.
03-30-2012 08:30 AM
Find all posts by this user
joximu Offline
helper
*****
Moderators

Posts: 7,024
Joined: Jan 2007
Reputation: 92
Post: #4
RE: Emails don't go out to MX records, only internally
look at /var/cache/bind/mydomain.conf or similar.

there's a MX record.

Also set the working backup - somewhere in /etc/ispcp/bind/working/mydomain....

Maybe you also can set it via the DNS settings in the panel...?

when changing the zone files increment the serial!

/J
03-30-2012 11:03 AM
Visit this user's website Find all posts by this user
RouterRat Offline
Junior Member
*

Posts: 30
Joined: Mar 2011
Reputation: 0
Post: #5
RE: Emails don't go out to MX records, only internally
(03-30-2012 11:03 AM)joximu Wrote:  Maybe you also can set it via the DNS settings in the panel...?

/J

Yes this worked all along with other changes I've made.
I had those empty.

Thanks so much. Smile
03-30-2012 11:36 PM
Find all posts by this user
joximu Offline
helper
*****
Moderators

Posts: 7,024
Joined: Jan 2007
Reputation: 92
Post: #6
RE: Emails don't go out to MX records, only internally
Yes - both must be correct:

local bind (DNS) and local postfix (Mail) - otherwise you have more or less problems...

/J <closing>
03-31-2012 01:38 AM
Visit this user's website Find all posts by this user
Thread Closed 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)