Current time: 03-02-2021, 01:40 AM Hello There, Guest! (LoginRegister)


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[OFFTOPIC] Server Error 500 seit PHP-Upgrade: Ist FastCGI schuld?
Author Message
leapz Offline


Posts: 3
Joined: Mar 2008
Reputation: 0
Post: #1
[OFFTOPIC] Server Error 500 seit PHP-Upgrade: Ist FastCGI schuld?
Hallo Leute!

Ich hoffe, dass ihr mir helfen könnt, auch wenn mein Problem nichts unmittelbar mit ispCP zu tun hat. In diesem Forum habe ich allerdings trotzdem viele wertvolle Informationen genau zu meinem Problem gefunden, das ich euch gerne schildern möchte:

Ich habe einen Managed Server und bin daher relativ eingeschränkt, was eigenständige Veränderungen am Server betrifft. Für nahezu alle Änderungen muss ich ein Ticket bei meinem Host aufmachen, wie das nun mal so ist.

Auf meiner Webseite habe ich täglich etwa 20.000 Besucher und der Hauptbestandteil ist ein großes Diskussionsforum sowie ein Newsboard. Weitere (nennenswerte) PHP-Scripte auf SQL-Basis habe ich nicht im Einsatz.

Im Dezember wurde aus Sicherheitsgründen das bis dahin eingesetzte PHP 4.x durch 4.4.7 (heute 4.4.8) geupdated, zusätzlich zu anderen Updates: Apache (1.3.39), PHP5 (5.2.5), Perl (5.8.8) und Python (2.5.1). Das Apache-Modul wurde durch eine CGI-basierte Lösung ersetzt (FastCGI, würde ich mal raten...). Bis zu diesem Zeitpunkt hatte ich nahezu keine Probleme und der Server lief jeden Tag absolut problemlos.

Seit der Umstellung erhalte ich nun etwa 100x pro Tag den beliebten Server Error 500 - allerdings völlig willkürlich und ausschließlich beim Aufruf von PHP-Dateien (ganz egal, ob dahinter ein Script steckt oder nur der Satz "Hello World"). Es betrifft grundsätzlich alle .php Files, während der Rest funktioniert. Das bringt mir allerdings nicht viel, da meine Präsenz zu 99,9% aus PHP-Dateien besteht... Der 500er tritt nur für den Bruchteil einer Sekunde auf, d.h. ein Reload der Seite führt so gut wie immer sofort zur fehlerfreien Anzeite der Seite.

Diverse Calls bei meinem Host haben bislang noch kein Ergebnis gebracht; die Schuld wurde hauptsächlich auf "zu viele parallel stattfindende Suchanfragen von Google & Co." zurückgeführt, was ich allerdings nur schwer glauben kann. Denn erstens funktionierte unmittelbar vor den Updates wie gesagt alles problemlos und zweitens treten die Meldungen lt. HTTP-Logfiles auch bei normalen Anfragen auf, also nicht nur bei Google oder Slurp.

Als weitere Fehlerquelle wurde die Programmierung meiner Webseite genannt, was ich aber ebenfalls nur schwer glauben kann, denn vorher funktionierte wie gesagt alles wunderbar und auch heute tritt dieser Fehler nur sporadisch auf, egal ob nun gerade eine hohe Serverload herrscht oder ob es 4 Uhr in der Nacht ist.

Mein Host hat mir diesen Auszug aus den Logfiles zugeschickt und gleichzeitig den Idle-Timeout für FastCGI-Prozesse auf 120 Sekunden gesetzt, was allerdings nichts gebracht hat (und außerdem habe ich eh keine Scripte, die so eine lange Laufzeit benötigen könnten):

Code:
[Sun Jan  6 16:34:17 2008] [error] [client xx.xx.xx.xx] FastCGI: comm with (dynamic) server "/home/httpd/cgi-bin/php-fcgi-starter.fcgi" aborted: (first read) idle timeout (60 sec)
[Sun Jan  6 16:34:17 2008] [error] [client xx.xx.xx.xx] FastCGI: incomplete headers (0 bytes) received from server "/home/httpd/cgi-bin/php-fcgi-starter.fcgi"

Hier im Forum habe ich dann weitere Lösungsansätze gefunden, die sich allesamt auf den Einsatz von FastCGI beziehen. Unter anderem wurde erwähnt, dass PHP_FCGI_CHILDREN von "1" auf einen höheren Wert gesetzt werden sollte. Leider wurde diese Anfrage von meinem Host abgelehnt, da (Zitat) "PHP_FCGI_CHILDREN aus Kompatibilitätsgründen mit mod_fastcgi auf 1 gesetzt ist - diese Einstellung ändern wir nicht".

Ich bin nun mit meinem Latein am Ende und weiß nicht, was ich noch tun soll. Ein Anbieterwechsel würde erst dann Sinn machen, wenn ich sicher wäre, dass das Problem nicht auch dort auftritt. Wer kann mir helfen und hat vielleicht noch einen Tipp parat, was hier falsch läuft? Ist FastCGI denn überhaupt eine mögliche Fehlerquelle oder bin ich da auf dem Holzweg? Sad
(This post was last modified: 03-25-2008 08:59 PM by BeNe.)
03-25-2008 08:12 PM
Find all posts by this user Quote this message in a reply
BeNe Offline
Moderator
*****
Moderators

Posts: 5,899
Joined: Jan 2007
Reputation: 68
Post: #2
RE: Server Error 500 seit PHP-Upgrade: Ist FastCGI schuld?
Jetzt frage ich mich warum Du gerade hier fragst ?
Läuft den auf dem Server ispCP ? Was ist das für eine Machine ? Virtuell ?

Wenn nach einem Update von deinem Hoster die Seite nicht mehr ganz gehen dann würde ich da nochmals nachfragen. Ging ja vorher alles.
Wegen den PHP_FCGI_CHILDREN, ich weis das es was mit mod_fastcgi was bringt. Wäre dann mal interessant die jetztige Config zu sehen. Weil so ist das ein schuss ins blaue.

Greez BeNe
03-25-2008 08:47 PM
Visit this user's website Find all posts by this user Quote this message in a reply
leapz Offline


Posts: 3
Joined: Mar 2008
Reputation: 0
Post: #3
RE: Server Error 500 seit PHP-Upgrade: Ist FastCGI schuld?
Danke für deine Antwort. Wie gesagt, ich nutze ispCP nicht, von daher müsste ich natürlich damit leben, wenn dieser Thread geschlossen wird (habe die Regeln gelesen). Warum gerade hier? Dank Google habe ich in diesem Thread viel zu meinem Problem gefunden, auch wenn es in meinem Fall nicht um ispCP geht.

Bei der Maschine handelt es sich um einen eigenen (Managed) Server, keine virtuelle Geschichte.

Ich habe meinen Host wie gesagt schon mehrfach darauf hingewiesen, dass es vorher geklappt hat. Die Antwort war dann nur, dass sich der Host lt. AGB vorbehält, sicherheitsrelevante Updates einzuspielen.

Und PHP_FCGI_CHILDREN hochzusetzen hatte ich bereits ohne Erfolg beantragt (derzeit ist der Wert bei mir tatsächlich "1"). Antwort: "PHP_FCGI_CHILDREN ist aus Kompatibilitätsgründen mit mod_fastcgi auf 1 gesetzt - diese Einstellung ändern wir nicht."

Sad
03-25-2008 08:56 PM
Find all posts by this user Quote this message in a reply
BeNe Offline
Moderator
*****
Moderators

Posts: 5,899
Joined: Jan 2007
Reputation: 68
Post: #4
RE: Server Error 500 seit PHP-Upgrade: Ist FastCGI schuld?
Da Du leider keine eigenen Zugriff auf die Machine hast und auch kein ispCP einsetzt, können wir auch nicht helfen. Wenn sich der Hoster so quer stellt würde ich mal nach einer alternative suchen.

Greez BeNe
03-25-2008 08:59 PM
Visit this user's website Find all posts by this user Quote this message in a reply
leapz Offline


Posts: 3
Joined: Mar 2008
Reputation: 0
Post: #5
RE: [OFFTOPIC] Server Error 500 seit PHP-Upgrade: Ist FastCGI schuld?
Ok, trotzdem vielen Dank!
03-25-2008 08:59 PM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)