Current time: 03-31-2020, 08:07 AM Hello There, Guest! (LoginRegister)


Post Reply 
"main" panel domain lost after most recent RC5 update
Author Message
ergo Offline
Junior Member
*

Posts: 56
Joined: Apr 2008
Reputation: 0
Post: #1
"main" panel domain lost after most recent RC5 update
after the most recent RC5 update was uploaded again( fix for email - thanks R@s), ive run the update, and all of my websites work, apart the one i should access my panel, webmail etc.

i cant locate any reason for that to happen.

all other sites are in sites-enabled, and the panel vhost file seems in place too.
06-16-2008 06:05 PM
Find all posts by this user Quote this message in a reply
ergo Offline
Junior Member
*

Posts: 56
Joined: Apr 2008
Reputation: 0
Post: #2
RE: "main" panel domain lost after most recent RC5 update
hmm, so no one had that problem since yesterdays update ?
06-17-2008 12:31 AM
Find all posts by this user Quote this message in a reply
sci2tech Away
Senior Member
****

Posts: 1,285
Joined: Jan 2007
Reputation: 23
Post: #3
RE: "main" panel domain lost after most recent RC5 update
Post here this file: /etc/apache2/sites-enabled/00_master.conf
06-17-2008 01:11 AM
Visit this user's website Find all posts by this user Quote this message in a reply
ergo Offline
Junior Member
*

Posts: 56
Joined: Apr 2008
Reputation: 0
Post: #4
RE: "main" panel domain lost after most recent RC5 update
here you go

Code:
#
# Master Begin
#

<VirtualHost 205.134.253.25:80>

    ServerAdmin     info@webreactor.eu
    DocumentRoot    /var/www/ispcp/gui

    ServerName      admin.server.webreactor.eu

    ErrorLog        /var/log/apache2/users/admin.server.webreactor.eu-error.log
    TransferLog     /var/log/apache2/users/admin.server.webreactor.eu-access.log

    CustomLog       /var/log/apache2/admin.server.webreactor.eu-traf.log traff
    CustomLog       /var/log/apache2/admin.server.webreactor.eu-combined.log combined

    Alias /errors   /var/www/ispcp/gui/errordocs/

    ErrorDocument 401 /errors/401.html
    ErrorDocument 403 /errors/403.html
    ErrorDocument 404 /errors/404.html
    ErrorDocument 500 /errors/500.html
    ErrorDocument 503 /errors/503.html

    Alias /pma      /var/www/ispcp/gui/tools/pma/
    Alias /webmail  /var/www/ispcp/gui/tools/webmail/
    Alias /ftp      /var/www/ispcp/gui/tools/filemanager/

    <IfModule suexec_module>
           SuexecUserGroup vu2000 vu2000
    </IfModule>

    <Directory /var/www/ispcp/gui>
        Options -Indexes Includes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        Allow from all
    </Directory>

    <IfModule mod_fastcgi.c>
        ScriptAlias /php4/ /var/www/fcgi/master/
        ScriptAlias /php5/ /var/www/fcgi/master/
        <Directory "/var/www/fcgi/master">
            AllowOverride None
            Options +ExecCGI MultiViews -Indexes
            Order allow,deny
            Allow from all
        </Directory>
    </IfModule>

    <IfModule mod_php4.c>
        <Directory /var/www/ispcp/gui>
            php_admin_value open_basedir "/var/www/ispcp/gui/:/etc/ispcp/:/var/run/ispcp.lock:/proc/:/bin/df:/bin/mount:/var/log/rkhunter.log:/var/log/chkrootkit.log:/usr/share/php/"
            php_admin_value session.save_path "/var/www/ispcp/gui/phptmp/"
            php_admin_value upload_tmp_dir "/var/www/ispcp/gui/phptmp/"
        </Directory>
    </IfModule>
    <IfModule mod_php5.c>
        <Directory /var/www/ispcp/gui>
            php_admin_value open_basedir "/var/www/ispcp/gui/:/etc/ispcp/:/var/run/ispcp.lock:/proc/:/bin/df:/bin/mount:/var/log/rkhunter.log:/var/log/chkrootkit.log:/usr/share/php/"
            php_admin_value session.save_path "/var/www/ispcp/gui/phptmp/"
            php_admin_value upload_tmp_dir "/var/www/ispcp/gui/phptmp/"
        </Directory>
    </IfModule>

</VirtualHost>

#
# Master End
#
[/code]
06-17-2008 01:32 AM
Find all posts by this user Quote this message in a reply
sci2tech Away
Senior Member
****

Posts: 1,285
Joined: Jan 2007
Reputation: 23
Post: #5
RE: "main" panel domain lost after most recent RC5 update
Apache seems ok. The problem is with bind. in named.conf do you have the corresponding zone defined? Should look like
Code:
zone "admin.server.webreactor.eu" {
    type master;
    file "/var/cache/bind/admin.server.webreactor.eu.db";
    notify explicit;
};
And in /var/cache/bind/admin.server.webreactor.eu.db do you have zone definition?
(This post was last modified: 06-17-2008 05:23 AM by sci2tech.)
06-17-2008 05:23 AM
Visit this user's website Find all posts by this user Quote this message in a reply
ergo Offline
Junior Member
*

Posts: 56
Joined: Apr 2008
Reputation: 0
Post: #6
RE: "main" panel domain lost after most recent RC5 update
Code:
$TTL 12H
$ORIGIN admin.server.webreactor.eu.
@               IN              SOA             ns1.admin.server.webreactor.eu. postmaster.admin.server.webreactor.eu. (
; dmn [admin.server.webreactor.eu] timestamp entry BEGIN.
                2008040700     ; Serial
; dmn [admin.server.webreactor.eu] timestamp entry END.
                8H              ; Refresh
                15M             ; Retry
                4W              ; Expire
                3H              ; Minimum TTL
)
                IN              NS              ns1.admin.server.webreactor.eu.
                IN              NS              ns2.admin.server.webreactor.eu.
                IN              MX      10      mail.admin.server.webreactor.eu.

admin.server.webreactor.eu.     IN              A               205.134.253.25
www             IN              A               205.134.253.25
admin.server.webreactor.eu.     IN              TXT             "v=spf1 a mx ip4:205.134.253.25 ~all"
localhost       IN              A               127.0.0.1
mail            IN              A               205.134.253.25
ns1             IN              A               205.134.253.25
ns2             IN              A               205.134.253.26
; CNAME for mail transfer
imap            IN              CNAME           mail
pop             IN              CNAME           mail
pop3            IN              CNAME           mail
relay           IN              CNAME           mail
smtp            IN              CNAME           mail
; CNAME for web transfer
ftp             IN              CNAME           www
; sub [{SUB_NAME}] entry BEGIN.
; sub [{SUB_NAME}] entry END.
[/code][/quote]
06-17-2008 05:36 AM
Find all posts by this user Quote this message in a reply
sci2tech Away
Senior Member
****

Posts: 1,285
Joined: Jan 2007
Reputation: 23
Post: #7
RE: "main" panel domain lost after most recent RC5 update
Code:
dig @205.134.253.25 admin.server.webreactor.eu.db
; <<>> DiG 9.4.2 <<>> @205.134.253.25 admin.server.webreactor.eu.db
; (1 server found)
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 9540
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available
;; QUESTION SECTION:
;admin.server.webreactor.eu.db. IN      A
;; Query time: 207 msec
;; SERVER: 205.134.253.25#53(205.134.253.25)
;; WHEN: Mon Jun 16 20:35:40 2008
;; MSG SIZE  rcvd: 47
Not even your server did not resolv this subdomain. Do you have in named conf included this?
Code:
zone "admin.server.webreactor.eu" {
    type master;
    file "/var/cache/bind/admin.server.webreactor.eu.db";
    notify YES
};
Did you try to restart bind? in syslog is something about this?
06-17-2008 05:42 AM
Visit this user's website Find all posts by this user Quote this message in a reply
ergo Offline
Junior Member
*

Posts: 56
Joined: Apr 2008
Reputation: 0
Post: #8
RE: "main" panel domain lost after most recent RC5 update
ha there is no entry for that .... but what could have happened ? i wasnt playing with any files.
06-17-2008 05:54 AM
Find all posts by this user Quote this message in a reply
sci2tech Away
Senior Member
****

Posts: 1,285
Joined: Jan 2007
Reputation: 23
Post: #9
RE: "main" panel domain lost after most recent RC5 update
Put this entry in named.conf
Code:
zone "admin.server.webreactor.eu" {
    type master;
    file "/var/cache/bind/admin.server.webreactor.eu.db";
    notify YES
};
to include zone definition. Don`t know what hapend. If is ispcp related it will be reported by other and fix. It did not happened to me, but I did do some modification before to this files.
(This post was last modified: 06-17-2008 06:01 AM by sci2tech.)
06-17-2008 06:00 AM
Visit this user's website Find all posts by this user Quote this message in a reply
ergo Offline
Junior Member
*

Posts: 56
Joined: Apr 2008
Reputation: 0
Post: #10
RE: "main" panel domain lost after most recent RC5 update
ok it works ive added that entry, but is there an automatic way to regenerate all the files ?

the regenerate configs howto from wiki did not do the trick for me it seems...
06-17-2008 06:02 AM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)