Current time: 01-28-2021, 05:40 PM Hello There, Guest! (LoginRegister)


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Lösung] Windows Mobile und NTLM auth Fehler
Author Message
Knut Offline
Member
***

Posts: 736
Joined: Nov 2006
Reputation: 10
Post: #1
[Lösung] Windows Mobile und NTLM auth Fehler
Hi,

wer mit seinem Windows Mobile und IMAP/Pop3 eine Mail versenden will bekommt in der Regel folgende Fehlermeldung:
Code:
SASL NTLM authentication failed: authentication failure

Dies kann man wie folgt beheben:

Code:
pico /etc/default/saslauthd
und folgende Parameter anpassen:
Code:
START=yes
OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd"

Anschliessend die Datei /etc/postfix/sasl/smtpd.conf erstellen
Code:
pico etc/postfix/sasl/smtpd.conf
und folgendes einfügen:
Code:
pwcheck_method: auxprop
auxprop_plugin: sasldb
mech_list: PLAIN LOGIN CRAM-MD5 DIGEST-MD5

Nun die betroffenen Dienste neu starten:
Code:
/etc/init.d/saslauthd start
/etc/init.d/postfix restart

Ausprobieren und Log anschauen.

Ich würde mich freuen wenn dies hier Diskutiert werden könnte.
(This post was last modified: 07-19-2009 01:13 AM by Knut.)
04-01-2009 05:38 PM
Find all posts by this user Quote this message in a reply
joximu Offline
helper
*****
Moderators

Posts: 7,024
Joined: Jan 2007
Reputation: 92
Post: #2
RE: [Lösung?] Windows Mobile und NTLM auth Fehler
Hm, ich predige immer, den saslauthd gar nicht zu benutzen und evtl. vorhandene smtpd.conf Dateien umzubenennen... - aus meiner erfahrung funktioniert das irgendwie problemloser...

vielleiht kann es (NTLM) in den postfix/courier sasl Einstellungen erweitert werden...

Gruss J
04-01-2009 06:46 PM
Visit this user's website Find all posts by this user Quote this message in a reply
ZooL Offline
Moderator
*****
Moderators

Posts: 3,429
Joined: Jan 2007
Reputation: 79
Post: #3
RE: [Lösung?] Windows Mobile und NTLM auth Fehler
bei mir und bei den Kunden wo ich es installiere wird es direkt so konfiguriert..
04-01-2009 09:16 PM
Visit this user's website Find all posts by this user Quote this message in a reply
nesto Offline
Newbie
*

Posts: 7
Joined: Apr 2009
Reputation: 0
Post: #4
RE: [Lösung?] Windows Mobile und NTLM auth Fehler
Knut, danke für die Anleitung!
Ich habe diesen Effekt, wenn ein Script auf Basis von .NET Emails über meinen Mailserver versenden will. (Die Mails gehen trotzdem raus!)

(04-01-2009 05:38 PM)Knut Wrote:  
Code:
START=yes
OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd"

Dieser Pfad existierte bei mir ursprünglich nicht (ispCP RC7 auf Debian Etch), habe ihn einfach mal angelegt ...

Code:
ix012:~# mkdir  /var/spool/postfix/var/
ix012:~# mkdir  /var/spool/postfix/var/run/
ix012:~# mkdir  /var/spool/postfix/var/run/saslauthd

Dienste starten, logs sehen problemlos aus.

Sollte das trotzdem irgendwie das falsche Vorgehen gewesen sein, bitte kurze Info - DANKE Smile
(This post was last modified: 04-21-2009 04:10 PM by nesto.)
04-21-2009 04:00 PM
Find all posts by this user Quote this message in a reply
sebezahn Offline
Newbie
*

Posts: 7
Joined: Apr 2008
Reputation: 0
Post: #5
RE: [Lösung?] Windows Mobile und NTLM auth Fehler
(04-21-2009 04:00 PM)nesto Wrote:  Knut, danke für die Anleitung!
Ich habe diesen Effekt, wenn ein Script auf Basis von .NET Emails über meinen Mailserver versenden will. (Die Mails gehen trotzdem raus!)
...
Sollte das trotzdem irgendwie das falsche Vorgehen gewesen sein, bitte kurze Info - DANKE Smile

Hi,

DANKE, DANKE, DANKE!!! Dank dieser Anleitung funktioniert das endlich auch bei mir, Mails über Windows Mobile 6 zu versenden. Auch ich habe die Ordner einfach angelegt, danach beide Dienste (neu) gestartet, und es läuft.

Dennoch nochmal die Nachfrage, da das Thema schon was älter war: Hat es irgendeinen negativen Effekt bei euch gehabt?

Gruß
Sebezahn
05-22-2009 07:48 AM
Find all posts by this user Quote this message in a reply
Knut Offline
Member
***

Posts: 736
Joined: Nov 2006
Reputation: 10
Post: #6
RE: [Lösung?] Windows Mobile und NTLM auth Fehler
Kurz und knapp: NEIN


Gruß Knut
05-22-2009 05:01 PM
Find all posts by this user Quote this message in a reply
sebezahn Offline
Newbie
*

Posts: 7
Joined: Apr 2008
Reputation: 0
Post: #7
RE: [Lösung?] Windows Mobile und NTLM auth Fehler
DANKE! Smile
05-22-2009 06:50 PM
Find all posts by this user Quote this message in a reply
ekeis98 Offline
Junior Member
*

Posts: 32
Joined: Jul 2009
Reputation: 0
Post: #8
RE: [Lösung?] Windows Mobile und NTLM auth Fehler
Danke für diese Hinweise. Ich bin zwar nicht sicher, was ich da getan habe, aber ich kann endlich mit meinem Windows Mobile 6.1 Emails versenden und der Fehler 'SASL NTLM authentication failed: authentication failure' ist endlich verschwunden.

Gruß,
Oliver.
07-19-2009 12:36 AM
Find all posts by this user Quote this message in a reply
fulltilt Offline
Member
***

Posts: 1,225
Joined: Apr 2007
Reputation: 5
Post: #9
RE: [Lösung] Windows Mobile und NTLM auth Fehler
hatte das bislang auf einem etch System so eingerichtet, nun nach einem Update auf Lenny bekomme ich wieder die NTML Fehler bei win-mobile logins.
Die configs sind genau wie hier im howto angepasst - hat jemand eine Idee?
01-30-2010 04:48 AM
Find all posts by this user Quote this message in a reply
fulltilt Offline
Member
***

Posts: 1,225
Joined: Apr 2007
Reputation: 5
Post: #10
RE: [Lösung] Windows Mobile und NTLM auth Fehler
ist das auf einem Lenny System anders wie oben beschrieben?
Wenn ich das so einrichte bekomme ich jetzt auch im Kmail:
Ihr SMTP-Server unterstützt NTLM nicht

nehme ich die /etc/postfix/sasl/smtp.conf wieder raus - keine fehlermeldung aber auch kein Login mit Win-Mobile.
01-30-2010 07:14 PM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)