Current time: 01-22-2020, 03:52 PM Hello There, Guest! (LoginRegister)


Post Reply 
Problem with maia_mailguard, spam not reconized?
Author Message
robmorin Offline
Junior Member
*

Posts: 208
Joined: Apr 2007
Reputation: 0
Post: #1
Problem with maia_mailguard, spam not reconized?
Hello all... I installed Maia Mailguard as per the below link.
http://www.isp-control.net/documentation..._omega_rc3

I am using Ubuntu server Karmac
The setup went fine...
i also uncommitted the /etc/amavis/conf.d/15-content_filter_mode entries as this was not mentioned in the doc.... otherwise scanning will never work.

However when i send a test EICAR virus, it gets passed as CLEAN. Now i am not sure if i should post here, but maybe some has had the same issue?

The only thing that was changed form that doc i mentioned above is the location of the amavisd.conf file, as with Debian there is no amavisd.conf file, and i am actually using Ubuntu instead there is a conf.d directory with various sub conf files in it...

In the instructions it says to copy the the amavisd.conf file that comes with Maia to /etc/amavis/amavisd.conf and into /etc/, so what i did instead is i copied everything from amavisd.conf file into 50-user.conf located in /etc/amavis/conf.d as this file over rides anything else in other conf files... so i figured it would work and i also made a link from /etc and /etc/amavis to the 50-user conf file , but as amavis.conf... so all looks well

Here is some more info for you to look over.....

log file entries when EICAR comes through

Dec 1 13:29:00 oscar amavis[28166]: (28166-01) Passed CLEAN, [24.201.245.25] [207.253.38.186] <rob@irellx.com> -> <rob@things.com>, Message-ID: <008d01ca72b4$266bf710$7343e530$@com>, Hits: -, 492 ms
Dec 1 13:30:01 oscar amavis[28167]: (28167-01) Passed CLEAN, <root@oscar.224365.ca> -> <root@oscar.224365.ca>, Message-ID: <20091201183001.41F2561EE5@oscar.224365.ca>, Hits: -, 246 ms

What other info would be needed to help troubleshoot?

Thanks..
12-02-2009 04:57 AM
Find all posts by this user Quote this message in a reply
Jillian Offline
Junior Member
*

Posts: 51
Joined: Mar 2009
Reputation: 1
Post: #2
RE: Problem with maia_mailguard, spam not reconized?
Restart amavis service, check mail.log and post it here. Log start like this:
amavis[31922]: starting. /usr/sbin/amavisd-new at host.name.tld Maia Mailguard
12-02-2009 04:57 PM
Visit this user's website Find all posts by this user Quote this message in a reply
robmorin Offline
Junior Member
*

Posts: 208
Joined: Apr 2007
Reputation: 0
Post: #3
RE: Problem with maia_mailguard, spam not reconized?
Here is what you requested... i grepped for amavis stuff only after a restart

Dec 2 09:39:50 oscar amavis[14975]: starting. /usr/sbin/amavisd-new at mx.xxx.ca Maia Mailguard 1.0.2a, Unicode aware, LANG=en_CA.UTF-8
Dec 2 09:39:50 oscar amavis[14975]: Perl version 5.010000
Dec 2 09:39:50 oscar amavis[14976]: Module Amavis::Conf 2.034
Dec 2 09:39:50 oscar amavis[14976]: Module Archive::Tar 1.38
Dec 2 09:39:50 oscar amavis[14976]: Module Archive::Zip 1.18
Dec 2 09:39:50 oscar amavis[14976]: Module BerkeleyDB 0.39
Dec 2 09:39:50 oscar amavis[14976]: Module Compress::Zlib 2.008
Dec 2 09:39:50 oscar amavis[14976]: Module Convert::TNEF 0.17
Dec 2 09:39:50 oscar amavis[14976]: Module Convert::UUlib 1.11
Dec 2 09:39:50 oscar amavis[14976]: Module DBI 1.609
Dec 2 09:39:50 oscar amavis[14976]: Module DB_File 1.816_1
Dec 2 09:39:50 oscar amavis[14976]: Module MIME::Entity 5.427
Dec 2 09:39:50 oscar amavis[14976]: Module MIME::Parser 5.427
Dec 2 09:39:50 oscar amavis[14976]: Module MIME::Tools 5.427
Dec 2 09:39:50 oscar amavis[14976]: Module Mail::Header 2.04
Dec 2 09:39:50 oscar amavis[14976]: Module Mail::Internet 2.04
Dec 2 09:39:50 oscar amavis[14976]: Module Mail::SpamAssassin 3.002005
Dec 2 09:39:50 oscar amavis[14976]: Module Net::Cmd 2.29
Dec 2 09:39:50 oscar amavis[14976]: Module Net::DNS 0.65
Dec 2 09:39:50 oscar amavis[14976]: Module Net::SMTP 2.31
Dec 2 09:39:50 oscar amavis[14976]: Module Net::Server 0.97
Dec 2 09:39:50 oscar amavis[14976]: Module Time::HiRes 1.9711
Dec 2 09:39:50 oscar amavis[14976]: Module Unix::Syslog 1.1
Dec 2 09:39:50 oscar amavis[14976]: Amavis:Big GrinB code loaded
Dec 2 09:39:50 oscar amavis[14976]: Amavis::Cache code loaded
Dec 2 09:39:50 oscar amavis[14976]: Lookup::SQL code loaded
Dec 2 09:39:50 oscar amavis[14976]: Lookup::LDAP code NOT loaded
Dec 2 09:39:50 oscar amavis[14976]: AMCL-in protocol code NOT loaded
Dec 2 09:39:50 oscar amavis[14976]: SMTP-in protocol code loaded
Dec 2 09:39:50 oscar amavis[14976]: ANTI-VIRUS code loaded
Dec 2 09:39:50 oscar amavis[14976]: ANTI-SPAM code loaded
Dec 2 09:39:50 oscar amavis[14976]: Unpackers code loaded
Dec 2 09:39:50 oscar amavis[14976]: Found $file at /usr/bin/file
Dec 2 09:39:50 oscar amavis[14976]: Found $arc at /usr/bin/arc
Dec 2 09:39:50 oscar amavis[14976]: Found $gzip at /bin/gzip
Dec 2 09:39:50 oscar amavis[14976]: Found $bzip2 at /bin/bzip2
Dec 2 09:39:50 oscar amavis[14976]: No $lzop, not using it
Dec 2 09:39:50 oscar amavis[14976]: Found $lha at /usr/bin/lha
Dec 2 09:39:50 oscar amavis[14976]: Found $unarj at /usr/bin/arj
Dec 2 09:39:50 oscar amavis[14976]: Found $uncompress at /bin/uncompress
Dec 2 09:39:50 oscar amavis[14976]: No $unfreeze, not using it
Dec 2 09:39:50 oscar amavis[14976]: Found $unrar at /usr/bin/rar
Dec 2 09:39:50 oscar amavis[14976]: Found $zoo at /usr/bin/zoo
Dec 2 09:39:50 oscar amavis[14976]: No $pax, not using it
Dec 2 09:39:50 oscar amavis[14976]: Found $cpio at /bin/cpio
Dec 2 09:39:50 oscar amavis[14976]: Found $ar at /usr/bin/ar
Dec 2 09:39:50 oscar amavis[14976]: No $rpm2cpio, not using it
Dec 2 09:39:50 oscar amavis[14976]: No $cabextract, not using it
Dec 2 09:39:50 oscar amavis[14976]: No $ripole, not using it
Dec 2 09:39:50 oscar amavis[14976]: No $dspam, not using it
Dec 2 09:39:50 oscar amavis[14976]: Using internal av scanner code for (primary) ClamAV-clamd
Dec 2 09:39:50 oscar amavis[14976]: Found secondary av scanner ClamAV-clamscan at /usr/bin/clamscan
Dec 2 09:39:50 oscar amavis[14976]: Creating db in /var/lib/amavis/db/; BerkeleyDB 0.39, libdb 4.7
Dec 2 09:39:55 oscar amavis[15398]: (15398-01) Passed CLEAN, <root@oscar.xxx.ca> -> <root@oscar.xxx.ca>, Message-ID: <20091202143954.9962161F3A@oscar.xxx.ca>, Hits: -, 299 ms
Dec 2 09:39:55 oscar amavis[15399]: (15399-01) Passed CLEAN, <root@oscar.xxx.ca> -> <root@oscar.xxx.ca>, Message-ID: <20091202143954.AFD8C61EF1@oscar.xxx.ca>, Hits: -, 382 ms
Dec 2 09:40:00 oscar amavis[15749]: (15749-01) Passed CLEAN, <root@oscar.xxx.ca> -> <root@oscar.xxx.ca>, Message-ID: <20091202143956.A6C3361F1B@oscar.xxx.ca>, Hits: -, 277 ms
Dec 2 09:40:00 oscar amavis[15750]: (15750-01) Passed CLEAN, <root@oscar.xxx.ca> -> <root@oscar.xxx.ca>, Message-ID: <20091202143956.C2BD361F11@oscar.xxx.ca>, Hits: -, 406 ms
Dec 2 09:40:06 oscar amavis[15775]: (15775-01) Passed CLEAN, <root@oscar.xxx.ca> -> <root@oscar.xxx.ca>, Message-ID: <20091202143958.C87FB61EFC@oscar.xxx.ca>, Hits: -, 353 ms
Dec 2 09:40:06 oscar amavis[15777]: (15777-01) Passed CLEAN, <root@oscar.xxx.ca> -> <root@oscar.xxx.ca>, Message-ID: <20091202143958.E639761EF4@oscar.xxx.ca>, Hits: -, 282 ms
Dec 2 09:40:11 oscar amavis[15799]: (15799-01) Passed CLEAN, <root@oscar.xxx.ca> -> <root@oscar.xxx.ca>, Message-ID: <20091202144001.12BC661F03@oscar.xxx.ca>, Hits: -, 275 ms
Dec 2 09:40:11 oscar amavis[15801]: (15801-01) Passed CLEAN, <root@oscar.xxx.ca> -> <root@oscar.xxx.ca>, Message-ID: <20091202144001.27FB561EEB@oscar.xxx.ca>, Hits: -, 261 ms

Anything else?

Rob
Montreal

(12-02-2009 04:57 PM)Jillian Wrote:  Restart amavis service, check mail.log and post it here. Log start like this:
amavis[31922]: starting. /usr/sbin/amavisd-new at host.name.tld Maia Mailguard
12-03-2009 12:42 AM
Find all posts by this user Quote this message in a reply
robmorin Offline
Junior Member
*

Posts: 208
Joined: Apr 2007
Reputation: 0
Post: #4
RE: Problem with maia_mailguard, spam not reconized?
Bump ?
12-17-2009 03:23 AM
Find all posts by this user Quote this message in a reply
BeNe Offline
Moderator
*****
Moderators

Posts: 5,899
Joined: Jan 2007
Reputation: 68
Post: #5
RE: Problem with maia_mailguard, spam not reconized?
Did you configured everthing correct in Maia for your Domain ?
You have to set default for your Domain.

Greez BeNe
12-17-2009 08:53 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)